Gå til innhold
  • Bli medlem
Johs.

Heatit Z-TRM2fx

Anbefalte innlegg

Kjøpte meg en termostat og hadde tenkt til å ha flere, men etter mange timers knoting avventer jeg litt.. Har vært innom flere av temaene og fixene i tråden her, men noe henger litt enda..

 

Secure Mode

Jeg fikk ikke oppdatert FW (til 3.6) i Secure Mode. Måtte fjerne den og legge den til som Unsecure så gikk det.

La den først til i Secure Mode, men da fikk jeg ikke opp alle devicene. Fikk kun 8 og manglet bla a avlest temp og rele status. Fikk inn alle da jeg la den til som Unsecure.

Noen som får den til å funke i Secure mode?

 

Vise avlest temp i display

Endret param 14 for å vise avlest/målt temp i display. Dette funker med både gammel og ny FW, men måtte riktignok sette den 2-3 ganger før den gikk gjennom.

 

Logg

Får loggen fylt opp av data fra External sensor. Har fjernet assosiasjon for Group 2 som nevnt i forumet, men det løser ikke problemet hos meg. Har også koblet til en sensor på External inngangen i tillegg til gulvføleren. Da får jeg riktig avlesning på begge inngangene men fortsatt masse data i logg.

Noen som har noe tips til dette? Må jeg gjøre noe mer enn å fjerne Group 2 fra assosiasjoner?

image.png.2ea977f4d66841355d2c1a12397393d8.png

Del dette innlegget


Lenke til innlegg
Del på andre sider

Selv om jeg endrer Control Type til Text Box, så kan jeg fortsatt bare legge inn heltall. Prøver jeg å legge inn f.eks 20,5 så blir dette avrundet til 21.

Del dette innlegget


Lenke til innlegg
Del på andre sider
På 8.6.2019 den 13.03, Essand skrev:

Secure Mode

Jeg fikk ikke oppdatert FW (til 3.6) i Secure Mode. Måtte fjerne den og legge den til som Unsecure så gikk det.

La den først til i Secure Mode, men da fikk jeg ikke opp alle devicene. Fikk kun 8 og manglet bla a avlest temp og rele status. Fikk inn alle da jeg la den til som Unsecure.

Noen som får den til å funke i Secure mode?

 

Vise avlest temp i display

Endret param 14 for å vise avlest/målt temp i display. Dette funker med både gammel og ny FW, men måtte riktignok sette den 2-3 ganger før den gikk gjennom.

Det høres litt ut som om du sliter litt med dekningen eller at nettverket har det travelt...

 

På 8.6.2019 den 13.03, Essand skrev:

Noen som har noe tips til dette? Må jeg gjøre noe mer enn å fjerne Group 2 fra assosiasjoner?

Da jeg fjernet Gruppe 2, så fikk jeg ikke flere meldinger (det er jo slik det er beskrevet og fungert siden iallfall firmware 3.4). Jeg ville dobbeltsjekket at det var riktig, trykk på "Update"-knappen når du kikker på assosiasjonene til termostaten.

 

Du kan også endre på hyppigheten på rapportene (og forsåvidt deaktivere Z-wave debugging). Hva står den på nå?

Del dette innlegget


Lenke til innlegg
Del på andre sider
11 hours ago, Moskus said:

Det høres litt ut som om du sliter litt med dekningen eller at nettverket har det travelt...

Takk for info. Hadde termostat 1m fra PCen da jeg satte den opp og testet. Har ganske få devicer og det eneste som fyller loggen av betydning er termostaten som sender dette hvert minutt.

 

11 hours ago, Moskus said:

Da jeg fjernet Gruppe 2, så fikk jeg ikke flere meldinger (det er jo slik det er beskrevet og fungert siden iallfall firmware 3.4). Jeg ville dobbeltsjekket at det var riktig, trykk på "Update"-knappen når du kikker på assosiasjonene til termostaten.

 

Du kan også endre på hyppigheten på rapportene (og forsåvidt deaktivere Z-wave debugging). Hva står den på nå?

Ja, både Update og Audit bekrefter at Gruppe 2 er fjernet..

Nr 19 (temp report interval) står på 60sek og nr 21 (Meter report interval) har jeg slått av. Kunne kanskje slått av nr 19 og kun basert meg på Nr 20 (Temp report hysteresis)

 

Når det gjelder å deaktivere Z-wave debugging, så står jo den normal av (hvis vi tenker på det samme her). Trafikken for External sensor går vel uansett om debugging er av eller på?

Del dette innlegget


Lenke til innlegg
Del på andre sider
56 minutter siden, Essand skrev:

Hadde termostat 1m fra PCen da jeg satte den opp og testet. Har ganske få devicer og det eneste som fyller loggen av betydning er termostaten som sender dette hvert minutt.

Ja, muligens et dekningsproblem da. Hvor få er "få" noder, og over hvor stort areal er de fordelt?

 

57 minutter siden, Essand skrev:

Nr 19 (temp report interval) står på 60sek og nr 21 (Meter report interval) har jeg slått av. Kunne kanskje slått av nr 19 og kun basert meg på Nr 20 (Temp report hysteresis)

... eller iallfall øke parameter 19 til f.eks. 300 (5 minutter), muligens den ikke leser sin egen default-verdi, og man har ikke behov for temperaturrapportering så ofte uansett. Termostaten fungerer jo helt uavhengig av hvor ofte den rapporterer data.

 

59 minutter siden, Essand skrev:

Når det gjelder å deaktivere Z-wave debugging, så står jo den normal av (hvis vi tenker på det samme her). Trafikken for External sensor går vel uansett om debugging er av eller på?

Ja, vi tenker på det samme. Dataene er det samme, ja. Men med Z-wave debug på så forsvinner den nyttige informasjonen... ;) 

Del dette innlegget


Lenke til innlegg
Del på andre sider
On 11/06/2019 at 22:36, Moskus said:

Ja, muligens et dekningsproblem da. Hvor få er "få" noder, og over hvor stort areal er de fordelt?

 

Totalt 4 stk. Areal, kan gjette på 50m2. Har skjøtekabel på USB stick så denne står litt bedre til. Hadde samme problemene da termostaten var 1m fra PC, så vil jo ikke tro det er dekningen..

Har du lykkes med å ha termostaten lagt til i Secure Mode og få opp alle devices?

Del dette innlegget


Lenke til innlegg
Del på andre sider

@T_1

Jeg har også litt problemer med å sette halve grader, men ingen god løsning.

Setter halve grader fra Devices og Status oppdaterer seg korrekt, men på display på termostaten settes den til 24,0°.

Kan sette til halve grader rett på termostaten, og så veksler jeg bare mellom ECO og COMY mode fra Events eller Devices. Da har jeg i alle fall to settings å bruke.

 

image.png

Endret av Essand

Del dette innlegget


Lenke til innlegg
Del på andre sider
2 timer siden, Essand skrev:

Totalt 4 stk. Areal, kan gjette på 50m2. Har skjøtekabel på USB stick så denne står litt bedre til. Hadde samme problemene da termostaten var 1m fra PC, så vil jo ikke tro det er dekningen..

4 noder på 50 kvadrat er ikke for mye, for å si det sånn. Selv om termostaten selv skulle ha god dekning kan det være at andre noder sliter og "henger" kommunikasjonen og dermed får man brudd, men jeg er enig med at 1 m burde være tilstrekkelig hvis man ikke bruker Secure mode.

 

2 timer siden, Essand skrev:

Har du lykkes med å ha termostaten lagt til i Secure Mode og få opp alle devices?

Nei, men det ser jeg heller ikke poenget i.

Del dette innlegget


Lenke til innlegg
Del på andre sider

Hvorfor ser du ikke noe poeng med å bruke Secure Mode?

 

Jeg trodde det var enklere å ta over kontrollen på en enhet som ikke kommuniserer i Secure Mode.

Del dette innlegget


Lenke til innlegg
Del på andre sider
21 minutes ago, T_1 said:

Hvorfor ser du ikke noe poeng med å bruke Secure Mode?

 

Jeg trodde det var enklere å ta over kontrollen på en enhet som ikke kommuniserer i Secure Mode.

 

Pga overhead og zwave er en ekstrem treg protokoll i forhold til hva vi er vandt med. Secure mode er bare nødvendig på f.eks en dørlås

Del dette innlegget


Lenke til innlegg
Del på andre sider
23 minutter siden, T_1 skrev:

Hvorfor ser du ikke noe poeng med å bruke Secure Mode?

Jeg trodde det var enklere å ta over kontrollen på en enhet som ikke kommuniserer i Secure Mode.

Det er teknisk mulig å ta kontrollen på en enhet, men det er uendelig mer sannsynlig at uvedkommende vil komme inn via wifi eller internett.

 

I prinsippet skal ikke kryptering utgjøre noen merkbar forskjell på et stort og godt utbygget nettverk i form av hastighet, men 1) utveksling av krypteringsnøkler ved inkludering av nytt utstyr kan gjøre nettverksbygging mer utfordrende, 2) batteri-enheter bruker mer strøm (for det må sendes og mottas mer informasjon),  3) man kan få problemer med å bruke assosiasjon med utstyr som ikke støtter kryptering.

Del dette innlegget


Lenke til innlegg
Del på andre sider

Takk for denne tråden. 

Fikk montert to fx nylig og har slitt en hel del. 

Fikk endelig kontakt med den ene vertfall nå i kveld etter å ha lest alt som stod her. 

 

Driver nå og oppdaterer fw ota til den ene. 

Litt off topic, men hvor langt skal denne count'en gå når man oppdaterer via homeseer web interfacet? 

Er det bytes sendt? Er oppi 30.000 nå. 

Del dette innlegget


Lenke til innlegg
Del på andre sider
51 minutes ago, Moskus said:

Den skal opp til rett under 100.000 (er det 96.000?).

Ja, det var 96.000 noe. 

Men hva betyr det egentlig?

 

Får se om man får liv i nummer to etter jobb idag også da. 🤞 

Del dette innlegget


Lenke til innlegg
Del på andre sider

Har fått opp begge to nå. Måtte resette og inkludere noen ganger før alt av underdevicer kom inn. 

Fikk ikke til å remove, så måtte resette termostaten og remove bad node i homeseer. 

 

Manglet associations på den ene, men satt det opp likt som på den andre. Og så kom det inn data. 

 

Alt funka kjempe fint ett par timer. 

Nå kommer ikke temperatur data inn. 

Har satt opp polling hvert 5 min på alle. 

Volt, watt og kWh funker fint, men temperatur 3 har ikke blitt oppdatert på 24 timer nå. 

Noen andre som har opplevd dette? 

 

Del dette innlegget


Lenke til innlegg
Del på andre sider
42 minutter siden, ruant skrev:

Volt, watt og kWh funker fint, men temperatur 3 har ikke blitt oppdatert på 24 timer nå. 

Regner med at du har assosiasjon for Group 3 til HomeSeer?

Del dette innlegget


Lenke til innlegg
Del på andre sider
13 minutes ago, Moskus said:

Regner med at du har assosiasjon for Group 3 til HomeSeer?

Har for både 1,2,3 og 4.

 

Screenshot_20190616_125410_com.android.chrome.jpg

Screenshot_20190616_125221_com.android.chrome.jpg

Del dette innlegget


Lenke til innlegg
Del på andre sider
2 minutes ago, Moskus said:

... og parameter 19 er ikke 0?

 

image.png

Den returnerte 60 på is a begge to.

 

Nå er jeg helt fersk på zwave 

Men jeg har satt opp polling på alle underenheter til 1 eller 5 minutt, kommer an på hva den inneholder.

Har 5 plugin greier fra fibaro og 2 av disse termostaten. 

Er det mulig det blir for mye for nettverket?

Det meste andre blir oppdatert som planlagt. (foruten om watts på fibaro pluggene, men her er det jo en som heter power også, som rapporterer watts, så det er jo ikke krise) 

Del dette innlegget


Lenke til innlegg
Del på andre sider
3 timer siden, ruant skrev:

Men jeg har satt opp polling på alle underenheter til 1 eller 5 minutt, kommer an på hva den inneholder.

Det trenger du ikke gjøre. Tvert i mot er det ikke å anbefale.

 

3 timer siden, ruant skrev:

Er det mulig det blir for mye for nettverket?

Kanskje ikke akkurat nå, men det baller fort på seg.

 

3 timer siden, ruant skrev:

Den returnerte 60 på is a begge to.

Det holder med 300 der også.

Del dette innlegget


Lenke til innlegg
Del på andre sider
24 minutes ago, Moskus said:

Det trenger du ikke gjøre. Tvert i mot er det ikke å anbefale.

 

Kanskje ikke akkurat nå, men det baller fort på seg.

 

Det holder med 300 der også.

 

OK. Får tune ned litt da. 

Viktig med nok data inn i influx så grafana grafene blir fine 🤣

 

Men uansett, så kommer det ikke noe på temperatur 3, temperatur 2 derimot, står at blir oppdatert hvert minutt, men det er vel external sensor, som ikke er i bruk. 

 

Var det noe om at man måtte fjerne en av associationene? 

Jeg får leke litt og se hva som skjer. 

Del dette innlegget


Lenke til innlegg
Del på andre sider
9 timer siden, ruant skrev:

OK. Får tune ned litt da. 

... eller deaktivere. :) 

 

9 timer siden, ruant skrev:

Viktig med nok data inn i influx så grafana grafene blir fine 🤣

Mer data != bedre data. ;) 

 

9 timer siden, ruant skrev:

Var det noe om at man måtte fjerne en av associationene? 

Hvis du fjerner Group 2 skal ikke ekstern sensor bli oppdatert. Hvis du fjerner Group 3 skal ikke gulvsensor bli oppdatert.

Del dette innlegget


Lenke til innlegg
Del på andre sider
1 hour ago, Moskus said:
11 hours ago, ruant said:

Viktig med nok data inn i influx så grafana grafene blir fine 🤣

Mer data != bedre data. ;) 

Velger se bort fra denne 🤣

 

 

1 hour ago, Moskus said:
11 hours ago, ruant said:

Var det noe om at man måtte fjerne en av associationene? 

Hvis du fjerner Group 2 skal ikke ekstern sensor bli oppdatert. Hvis du fjerner Group 3 skal ikke gulvsensor bli oppdatert.

Fjerna Group2, da våkna den til livet igjen.

Da får vi se om den holder seg i livet fremover.

Takk for hjelpen :D

Del dette innlegget


Lenke til innlegg
Del på andre sider

Opprett en konto eller logg inn for å kommentere

Du må være et medlem for å kunne skrive en kommentar

Opprett konto

Det er enkelt å melde seg inn for å starte en ny konto!

Start en konto

Logg inn

Har du allerede en konto? Logg inn her.

Logg inn nå

  • Lignende innhold

    • Av Guahtdim
      Dette er en trigger plugin basert på det som gjøres i tråden til @ZoRaC 
       
       
       
      Triggeren brukes i eventer mot google kalender. Følgende må oppfylles: Man starter på/er inne i kalendermøtet/event/registreringen (fra nå av CalendarEvent) og kalender teksten (Summary text) er enten lik, starter med, inneholder en tekst som man setter opp. Eventuelt så bryr man seg ikke om teksten, men bare at det er en kalender event. (4 forskjellige valg som kan gjøres når man legger inn triggeren). Man kan søke i mer enn en kalender.
      Man kan også legge inn flere søkeord skilt med || (eller) eller && (og) slik at en trigger kan håndtere flere forskjellige ord. I noen av triggerne vil ikke det å skille med && (og) gi noen treff siden f.eks. matching exactly på ett søk hvor man har brukt && (og) ikke vil treffe noen gang. 
       
      En trigger slår til minst en gang, som oftest mange ganger etter hverandre! Jeg anbefaler at man derfor setter opp f.eks en device å sjekke mot slik at man unngår å trigge f.eks hvert tiende sekund i løpet av en halvtime når det skjer en event. Jeg setter opp events slik at de i tillegg til å bli trigget av triggere også sjekker mot device som den skal styre.
      Eks:

      Her er det triggeren som starter det hele, men den vil kun slå til hvis device "Unknown Unknown Events" er av (off). Da vil device settes til på (on).
       
       
      OBS OBS OBS
      Dette er i Alfa(nivået før beta, som igjen er nivået før man faktisk sier man har en versjon man er fornøyd med) og ser ut deretter Testet ok i Windows.   
      For nå er linken til siste versjon 
      GCalSeer_v0020
       
      Hvordan sette opp :
      VIKTIG!!! Stopp Homeseer og ta en kopi av hele katalogen til Homeseer (normalt "c:\program files (x86)\Homeseer HS3" for Windows) og legg kopien på ett trygt sted i tilfelle du trenger å gå tilbake. Pakk ut filen i din Homeseer katalog - pass på at du får følgende oppsett (katalogen "Homeseer HS3" skal inneholde 2 nye filer HSPI_GCalSeer.exe og HSPI_GCalSeer.exe.config, mens du i katalogen Homeseer HS3\bin skal ha fått en ny underkatalog - GCalSeer - med 30 filer)   Restart Homeseer Gå inn på Homeseer->Plugins->Manage og trykk enable på GCalSeer  
      Oppsett av Google kalender
       
      Oppsett av kobling mot Hotmail/Outlook live
       
      Du er nå klar for å sette opp en trigger 
       
      Ved hjelp av script: Mulighet til å lage en device som lister opp alle kalenderhendelser x dager framover :
       
      Ansvarsfraskrivelse:
      Laste ned og bruke plugin gjøres på eget ansvar. Skulle jeg ødelegge Homeseer oppsettet ditt så kan jeg desverre ikke hjelpe deg.
       
      Planlagte utvidelser/ønskeliste
      Mulighet for å hente ut data fra linkede kalendere i Google (linket mot f.eks. Apple iCal) Mulighet for å liste ut hendelser fra flere kalendere samtidig vha script.  Mulighet til å legge inn device som viser X nærmeste hendelser fra utvalgte kalendere eller for en gitt tidsperiode fra tidspunktet man er i (planlagt utvidelse) Mulighet for Regex/Wildcards i søketekst (ønske) Bedre kontroll på kobling mot Google slik at refreshtoken blir prøvd brukt hvis man har passert utløp på accesstoken Egen device for å vise status med tanke på autorisasjon Mulighet til å sette opp en trigger til å slå til på offsets Mulighet for å trigge på hendelser innenfor en dag, uke, måned, frem i tid Mulighet for å hente inn kalender events fra MS Outlook (antageligvis kun for de som kjører HS i Windows OS) Eget scriptkall for å hente events fra en eller flere kalendere - ref https://forums.homeseer.com/forum/ultilities-plug-ins/utilities-discussion/blgdata-blade/87199-event-listing-in-a-hs-device  
      Kjente feil:
      Mulig å sette tid mellom hver sjekk lenger enn hva en autorisering gjelder (3600 sekunder) For mye logging Autorisering mot google fungerer ikke i Linux - under arbeid.  
      Endringer:
      V 0.0.2.0 - Fikset opp slik at man kan få tilbake objekter fra script, ikke bare ferdige strenger 
      V 0.0.1.8 - Lagt til uthenting av kalenderinfo vha script for Microsoft kalendere.
      V 0.0.1.1 - Fikset opp i visning når man har brukt avanserte settinger. Dette vil nå bli vist når man har "krympet/rullet opp" eventet.
      V 0.0.1.0 - Fjernet noen småfeil i offset (takk til toonwolf for testing) og lagt til muligheten å kunne søke på flere ord ved hjelp av logiske operatorer - || (eller/OR) og && (og/AND)
      V 0.0.0.7 - Forbedret kobling mot Google + fjernet noen småfeil i offset
       0.0.0.6 - Microsoft kalenderfunksjonalitet lagt til (Hotmail/Outlook Live).
      V 0.0.0.5 - Mye ekstra funksjonalitet lagt inn på triggerne. Egen device for å vise status på koblingen mot Google.
      V 0.0.0.4 - Man kan ikke sette tid mellom ny info fra Google til mer enn 3599 sekunder.
      V 0.0.0.3 - Fungerer mot Linux. Autorisasjon endret.
      V 0.0.0.2 - Logging settes og slik sett får man mindre i HomeSeer loggen hvis det er ønskelig.
       
       
       
       
       
    • Av Guahtdim
      Jeg har fått meg Daikin varmepumpe med Wifi modul. Og det må jo inn i Homeseer. Jeg har hatt den i ca 36 timer, men ikke kommet lenger enn å teste av og på vha Postman basert på script av @Christoffer. Script er kult det, men jeg foretrekker å lage plugin.
       
      I første omgang ser jeg for meg å transformere scriptet til @Christoffer
      Men er det andre ting som hadde vært fint å ha? 
       
      Egne spørsmål : Skifter varmepumpen ofte ip? Eller holder den på den tar første gang? 
    • Av Sture00
      Er det noen som har en link/guide til hvordan man får frem alle knappene på den runde Trådfri fjernkontrollen i Homeseer? Har nå kun on/off og batteri. 
    • Av Sture00
      Sliter med å få koblet til 1000lm trådfri pærer med ConBee II. Har til nå fått opp to runde fjernkontroller og en rund dimmer fra trådfri samt 30w led driveren men ingen av pærene dukker opp. Har siste firmware på Deconz og begge pærene får jeg opp i Hue bridge. Begge pærene har jeg reset flere ganger. Noen så har bedre erfaring? 
    • Av Guahtdim
      Jeg holder på med en liten plugin for å kunne legge inn sms ved hjelp av Twilio. Kunne det være noe interresse for noe slikt?
       
      Rflink plugin ble litt for stor (så den er midlertidig lagt på vent) og selv hadde jeg behov for sms sending. Jeg har kokt sammen noe som er en alpha. Jeg er kommet dit at det sender greit, men jeg mangler litt overstyring (bl.a. muligheten til å overstyre default telefonnummer).
       
      I event

       
      2019-04-27: Nå også med muligheten til å hente inn telefonnummeret som det skal mottas fra i teksten på en annen enhet (device).
      Man kan plukke enhet.
      Velge om man skal ta teksten som
      As Is - som den er
      PlanyoFormat - eget format (47) 12345678
      RegEx - Regulært uttrykk
       

       
      Config
      Nytt fra 2019-04-27 er at man kan velge å legge inn alphanumeric id som avsender. Man kan f.eks. ha HomeSeer som avsender.
      Krav til alphanumeric id: Max 11 tegn. Kun A-Z, a-z, 1-9 og <space>. Man kan ikke ha kun tall for å spoofe andre nummer
      Resend guard - beskytter deg mot å sende samme melding mer enn en gang over gitt periode. Her har jeg selv satt den til 2 minutter. Så hvis det kommer en eksakt lik melding til samme mottaker og den allerede er sendt for 2 minutter siden eller mindre så sendes ikke ny.
       

       
       
       
      Videre planer:
      <ingen for øyeblikket> Kunne overstyre default receivers når man legger inn event. Kunne sette en levetid på sms slik at hvis den ikke blir sendt på første forsøk så prøves inntil sms blir sendt eller angitt levetid er over.  
      Jeg er åpen for innspill hvis noen ser noen mangler.
       
       
      HSPI_TwilioSeer_1.0.7069.32266.zip
       
       
×