Gå til innhold
  • Bli medlem

Altibox Pluss vs. egen router/wifi


Erling
 Del

Anbefalte innlegg

Her er eit tips frå meg ang oppsett for Altibox IPTV med Ubiquiti Security Gateway som router;

 

Det er ikkje alt det nødvendige oppsettet med IGMP-proxy som let seg sette opp med GUI i Unifi controller programvaren. Dersom oppsettet blir gjort lokalt på USG er det ein risiko for at oppsettet blir overskrive ved reboot eller meir spesifikt programvare oppgradering og "provisioning" via Ubnt kontroller. Dette kan ein forhindre gjennom at ein gjer følgende øvelse:

 

1) Legg inn konfigurasjon på USG direkte via SSH

2) Sikre at oppsettet er fungerende slik du ønsker det

3) Eksporter oppsettet fra USG med kommandoen ´mca-ctrl -t dump-cfg > config.gateway.json

4) Kopiere fila config.gateway.json til riktig katalog på din kontroller. Dette kan du gjere med ´scp´ dersom din kontroller kjører på Linux. På Linux vil riktig stad for config.gateway.json vere ´/usr/lib/unifi/data/sites´ og deretter navnet på din "site", typisk ´default´.

 

Som en ekstra trygghet kan du på forhånd validere JSON-fila med å kopiere teksten inn i f.eks. https://jsonlint.com/.

 

Når du har gjort dette skal i utgangspunktet en "provisioning" også være trygt, slik at du kan oppgradere programvare på USG via kontroller når det kjem ny programvare frå Ubiquiti.

 

Referanse for ekstra lesning på help.ubnt.com:

https://help.ubnt.com/hc/en-us/articles/215458888-UniFi-How-to-further-customize-USG-configuration-with-config-gateway-json

 

Mvh,

Anders

Lenke til kommentar
Del på andre sider

Restartet Edge router i går, og det ble som jeg trodde, tv sluttet å virke etter ca 20 sek. Måtte stoppe å starte igmp-server igjen, da virker det fint etterpå... Til neste gang strømmen går....

 

Jeg skjønner ikke helt hvorfor det ikke skal virke hos meg..... Virker helt fint til det blir restart av router.

Lenke til kommentar
Del på andre sider

52 minutter siden, Ingeb skrev:

Restartet Edge router i går, og det ble som jeg trodde, tv sluttet å virke etter ca 20 sek. Måtte stoppe å starte igmp-server igjen, da virker det fint etterpå... Til neste gang strømmen går....

 

Jeg skjønner ikke helt hvorfor det ikke skal virke hos meg..... Virker helt fint til det blir restart av router.

Har du sjekka om det er utgitt nyere programvare til Edgerouter som fikser dette problemet? Kjører du den standalone eller koblet til en sentral kontroller? Mener å ha lest at Ubnt har fiksa et problem med IGMP Proxy som dør ganske nylig. Usikker på om det gjelder kun USG (som eg bruker).

 

Fra bloggen til Ubnt:

Firmware changes since 3.9.2/4.3.60:
[ACIWPro] Enable DFS support.
[UAP] Add more security details to scan info.
[UAP] Security patch for the WPA2 vulnerability called KRACK (details HERE).*
[UAP] Various backend fixes and/or improvements.
[USXG] Fix fastpath tools.
[USG] Updates NTP, net-snmp, IGMP proxy, conntrack-tools, webproxy packages to same as latest EdgeRouter release.

Changes since v4.4.12 (last non-beta release version) are as follows. 

  • Added non-offloaded DPI support - DPI now functions when hardware offloading is disabled, so co-exists with features that disable or bypass it (smart queues, IDS/IPS). This does not change anything when hardware offload is enabled.
  • GeoIP fixes - all known problems with it resolved, added back end for directional control. 
  • SNMP persistent directory relocated to RAM disk, which prevents "Unhandled kernel unaligned access" crash 
  • Removed core handling script that was causing reboots when large core files were generated
  • Fix IGMP proxy failing to start during boot a few were experiencing.
Lenke til kommentar
Del på andre sider

Trur nok at Ubiquiti jobber med dette med IGMP Proxy; per i dag er det jo ikke GUI-støtte for å sette det opp, men det er mange som etterspør på grunn av samme type løsning som Altibox krever også finnes hos andre leverandører. Så dette kommer nok på plass etter hvert.

 

https://community.ubnt.com/t5/UniFi-Routing-Switching/USG-Feature-Roadmap-January-2017-update/td-p/1792230

 

...

  • IGMP Proxy UI control
  • Get up to date with latest EdgeOS 
  • Move WAN configuration from device panel into Networks screen, and make all USG interfaces usable for any purpose - any interface can be a LAN or WAN.
  • Thanks 1
Lenke til kommentar
Del på andre sider

På ‎14‎.‎03‎.‎2018 den 13.37, anders.ovreseth skrev:

 

Jeg ser at det er versjon 1.10.1 som er released men ikke public enda. Står ikke noe om igmp, men jeg får legge inn siste versjon å se.

  • Thanks 1
Lenke til kommentar
Del på andre sider

  • 1 måned senere...

Min USG har UBNT software versjon 4.4.18. Så langt har eg opplevd at IGMP proxy tjenesten har stoppa ved eit par anledninger. Det fins ein restart-kommando for å starte opp igjen IGMP proxy som kan brukes "i fart" ved å logge på med SSH mot USG. Men det er litt driftsarbeid å holde kontroll på dette, så eg vurderer et script / automatisk jobb (cron) for å restarte IGMP proxy på USG kvar søndag natt i påvente av ny programvare fra UBNT.

 

Ellers har eg berre positive erfaringer med oppsettet og er lykkelig for å kunne ha alt utstyret på ett LAN.

 

 

Mvh,

Anders

Lenke til kommentar
Del på andre sider

På ‎03‎.‎05‎.‎2018 den 10.02, anders.ovreseth skrev:

Min USG har UBNT software versjon 4.4.18. Så langt har eg opplevd at IGMP proxy tjenesten har stoppa ved eit par anledninger. Det fins ein restart-kommando for å starte opp igjen IGMP proxy som kan brukes "i fart" ved å logge på med SSH mot USG. Men det er litt driftsarbeid å holde kontroll på dette, så eg vurderer et script / automatisk jobb (cron) for å restarte IGMP proxy på USG kvar søndag natt i påvente av ny programvare fra UBNT.

 

Ellers har eg berre positive erfaringer med oppsettet og er lykkelig for å kunne ha alt utstyret på ett LAN.

 

 

Mvh,

Anders

Hei!

 

Det har virket veldig bra hos meg også, IGMP-PROXY har jeg restartet en gang uten at det var strømstans, ellers har det bare virket. Jeg har satt opp 2 stk Ubiquiti Unifi AP-AC Pro, så trådløs dekning i huset er kjempebra, savner ikke mine gamle Asus routere som var satt opp som aksesspunkt.... Var litt plaget at muticast trafikk fikk ac-pro til å fryse/gå tregt, men når jeg fant rett kryss i pc Controller sw, så virker også disse fint ( jeg trenger ikke multicast via wifi).

 

Inge

Lenke til kommentar
Del på andre sider

Eg har fiber frå Altibox/BergenFiber, og vurderer å kjøpe ein Mikrotik hAP ac. Bør eg då bridge FMG-boksen og bruke eth1 eller kjøpe ein SFP-modul og kjøre fiberen rett i hAP ac? Kva er fordeler/ulemper med begge løsninger? Kva SFP-modul passer til Altibox sine linjer? 

 

@Lazarus...

Lenke til kommentar
Del på andre sider

  • 3 uker senere...
På 7.5.2018 den 8.36, autoola skrev:

Eg har fiber frå Altibox/BergenFiber, og vurderer å kjøpe ein Mikrotik hAP ac. Bør eg då bridge FMG-boksen og bruke eth1 eller kjøpe ein SFP-modul og kjøre fiberen rett i hAP ac? Kva er fordeler/ulemper med begge løsninger? Kva SFP-modul passer til Altibox sine linjer? 

 

@Lazarus...

Bedre sent enn aldri? :-)

 

Bridge av FMG-boksen fungerer fint hos meg. Har planer om å gå over til å kjøre fiberen rett inn i mikrotik-en senere.

 

Fordelen med å kjøre fiberen rett inn er at man har en ting mindre som må ha strøm/skal fungere, slipper å ha en enhet som patches og vedlikeholdes av en tredjepart samt at man ser ut til å få mindre ping og høyere hastighet i noen tilfeller.

 

Usikker på hvilken modul som passer, trodde det var noen andre her på forumet som har gjort dette allerede. Kanskje de har noe svar på oppsett og hardware som trengs.

Lenke til kommentar
Del på andre sider

4 hours ago, Lazarus said:

Bedre sent enn aldri? :-)

 

Bridge av FMG-boksen fungerer fint hos meg. Har planer om å gå over til å kjøre fiberen rett inn i mikrotik-en senere.

 

Fordelen med å kjøre fiberen rett inn er at man har en ting mindre som må ha strøm/skal fungere, slipper å ha en enhet som patches og vedlikeholdes av en tredjepart samt at man ser ut til å få mindre ping og høyere hastighet i noen tilfeller.

 

Usikker på hvilken modul som passer, trodde det var noen andre her på forumet som har gjort dette allerede. Kanskje de har noe svar på oppsett og hardware som trengs.

 

Jeg lurer på det samme selv. Prøvde å finne datasheets for FMG-boksen, og den viste meg at det er Tx:1310nm/Rx:1550nm som gjelder. Kjøpte derfor denne fra ebay, men fikk den aldri til å fungere. Så ut som den fikk link, ihvertfall ene veien. Prøvde med de standard VLANs'a som Altibox tidligere har hatt (101, 102, 103?), men fikk ikke noe trafikk på noen av de. Kanskje noen har mer detaljkunnskap om dette?

 

Edit: Vel å merke at denne modulen var for generell switch/nettverkskort, og ikke for å bruke i Mikrotik :)

Endret av fiLLLip
Lenke til kommentar
Del på andre sider

Jeg har gjort det folk har beskrevet her, men bruker en Cisco Catalyst 2960X-48LPS-L med en SFP modul fra ebay, (men kjøpte ikke den første jeg fant siden Cisco kan være kresene på de)

c0bfe2b0b1.png

 

Jeg har fortsatt hjemmesentralen koblet til, men kun TV signal går igjennom den nå

 

Her er config på switchen

Spoiler

interface GigabitEthernet1/0/1
 description Til StueSwitch
 switchport trunk allowed vlan 30-40,100-102
 switchport mode trunk
!
interface GigabitEthernet1/0/2
 description WAN in AiB Hjemmesentral
 switchport trunk allowed vlan 100,101
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 description TV fra AiB Hjemmesentral
 switchport access vlan 36
!
interface GigabitEthernet1/0/4
 description TV Dekoder 1
 switchport access vlan 36
!
interface GigabitEthernet1/0/14
 description BULL-PC03
 switchport access vlan 30
!
interface GigabitEthernet1/0/49
 description Fiber inn

 switchport trunk allowed vlan 100-102
 switchport mode trunk
!

 

Internett er på vlan 102 så det sendes videre til stueswitch der routeren er koblet til.

 

Videre må man spoofe mac-adressen som står på hjemmesentralen +1.

Altså står det 26:7a:a5:2b:61:14 må man få routeren til å spoofe 26:7a:a5:2b:61:15

e228aa9137.png

 

 

Pluggen som man har på veggen når patche boksen med FMG sentralen heter SC plugg. SFP modulen min har LC plugg, men der finnes det mange fine overgangsfibere så det er ingen utfordring. Har selv bestillt en 50M fiber fra FS.com med LC - SC så jeg kan flytte switchen til ett sted der det ikke gjør så mye at den bråker, står på kontoret nå :P 

 

 

Endret av Bullhill
  • Like 1
Lenke til kommentar
Del på andre sider

On 5/26/2018 at 12:47, Bullhill said:

Jeg har gjort det folk har beskrevet her, men bruker en Cisco Catalyst 2960X-48LPS-L med en SFP modul fra ebay, (men kjøpte ikke den første jeg fant siden Cisco kan være kresene på de)

*snip*

 

Legger du ved link til fiberen du bestilte? Er det OS2 9/125 Single Mode Simplex som kreves?

 

Sist jeg prøvde så spoofa jeg ikke MAC-adresse, så er nok derfor jeg ikke fikk det til da. Får prøve igjen når huset nærmer seg ferdig og racket++ er på plass :) 

Lenke til kommentar
Del på andre sider

 

1 time siden, fiLLLip skrev:

 

Legger du ved link til fiberen du bestilte? Er det OS2 9/125 Single Mode Simplex som kreves?

 

Sist jeg prøvde så spoofa jeg ikke MAC-adresse, så er nok derfor jeg ikke fikk det til da. Får prøve igjen når huset nærmer seg ferdig og racket++ er på plass :) 

Tenkte jeg skulle legge ved link, men er ikke link til den lengre. Er nok godt ut.

Lenke til kommentar
Del på andre sider

  • 1 måned senere...
På 9.3.2018 den 18.55, anders.ovreseth skrev:

3) Eksporter oppsettet fra USG med kommandoen ´mca-ctrl -t dump-cfg > config.gateway.json

Hei!

 

Jeg har nå fått meg en USG, lik den du har, men alt jeg skriver i CLI blir slettet når USG starter på nytt, så jeg må tydeligvis lage en config.gateway.json, men denne komandoen? Er det en Linux komando, for når jeg sto i CLI på USG, så skjedde det ikke mye....... Og jeg kjører Windows...

Lenke til kommentar
Del på andre sider

@cozmo Tusen takk for informasjonen du har delt her.

 

Jeg vurderer en Edgerouter 6P for tilsvarende oppsett med en liten utvidelse.

 

Ser for meg følgende med Altibox FMG i bridge:

- ETH0: FMG port 3 (Internett)

- ETH1: FMG port 1 (IPTV)

- ETH2: LAN1 (Privat)

- ETH3: LAN2 (Hybel 1)

- ETH4: LAN3 (Hybel 2)

 

Tanken er da å ha både nett og tv fra Edgerouter i én kabel til 3 adskilte nettverk. Planen er da å sette en switch som støtter IGMP snooping (TL-SG105E) på hvert nettverk hvor man da kobler til Q22 og WiFi access point (Unifi NanoHD).

 

Er dette mulig å få til ved å modifisere configen litt? 

 

Tusen takk for tips:)

 

- Christian

Lenke til kommentar
Del på andre sider

9 timer siden, Ingeb skrev:

Hei!

 

Jeg har nå fått meg en USG, lik den du har, men alt jeg skriver i CLI blir slettet når USG starter på nytt, så jeg må tydeligvis lage en config.gateway.json, men denne komandoen? Er det en Linux komando, for når jeg sto i CLI på USG, så skjedde det ikke mye....... Og jeg kjører Windows...

Hei Inge,

 

gratulerer med anskaffelsen, dette skal nok bli bra for deg. Før eg uttaler meg om problemet ditt vil eg berre sjekke; kan du komme med litt informasjon om oppsettet ditt? Har du en sentral UBNT kontroller eller kjører du USG "standalone"? Dersom den er stand-alone; når du går gjennom oppsettet for å legge det inn, gjer du det via SSH og ved bruk av "configure" og husker å lagre oppsettet når du avslutter konfig-modus?

 

Kan du også poste info om versjon av USG-programvare på din enhet? Min USG kjører 4.4.18 programvare og min kontroller er 5.6.30.

 

Mvh,

Anders

Lenke til kommentar
Del på andre sider

9 timer siden, cregeland skrev:

@cozmo Tusen takk for informasjonen du har delt her.

 

Jeg vurderer en Edgerouter 6P for tilsvarende oppsett med en liten utvidelse.

 

Ser for meg følgende med Altibox FMG i bridge:

- ETH0: FMG port 3 (Internett)

- ETH1: FMG port 1 (IPTV)

- ETH2: LAN1 (Privat)

- ETH3: LAN2 (Hybel 1)

- ETH4: LAN3 (Hybel 2)

 

Tanken er da å ha både nett og tv fra Edgerouter i én kabel til 3 adskilte nettverk. Planen er da å sette en switch som støtter IGMP snooping (TL-SG105E) på hvert nettverk hvor man da kobler til Q22 og WiFi access point (Unifi NanoHD).

 

Er dette mulig å få til ved å modifisere configen litt? 

 

Tusen takk for tips:)

 

- Christian

Hei Christian,

 

dette skulle i utgangspunktet kunne gå bra og du burde kunne bruke samme "oppskrift" som for oppsett med kun 1 LAN-port. Men det blir litt meir å holde kontroll på i forbindelse med konfigurasjon. Et alternativ kunne kanskje være å ha en fysisk LAN-port og splitte opp trafikken i egne trådløse nettverk for "hybel 1" og "hybel 2" i stedet for å ha 3 LAN-porter. Då må du nok kanskje ha 2 TL-SG105 på LAN-interfacet, men det går fint.

 

Mitt oppsett er egentlig litt som dette; eg har 1 LAN port som har fleire SG105 bak, samt at eg har separate WIFI-nett for leieboere og meg sjølv. Eg har 3 Q22 pluss 3 stk UBNT AP pluss diverse anna kabla utstyr kobla til LAN-porten.

 

Mvh,

Anders

Lenke til kommentar
Del på andre sider

Bli med i samtalen

Du kan publisere innhold nå og registrere deg senere. Hvis du har en konto, logg inn nå for å poste med kontoen din.

Gjest
Skriv svar til emnet...

×   Du har limt inn tekst med formatering.   Lim inn uten formatering i stedet

  Du kan kun bruke opp til 75 smilefjes.

×   Lenken din har blitt bygget inn på siden automatisk.   Vis som en ordinær lenke i stedet

×   Tidligere tekst har blitt gjenopprettet.   Tøm tekstverktøy

×   Du kan ikke lime inn bilder direkte. Last opp eller legg inn bilder fra URL.

 Del

×
×
  • Opprett ny...