Gå til innhold
  • Bli medlem

Termostat trigger ikke z-water rele


Kal-El
 Del

Anbefalte innlegg

Jeg har begynt på en ny læringskurve for å bytte Homey med Home Assistant. Det jeg står fast på nå er å få en Heatit Temp2 til å trigge et rele på Z-water slik at aktuatoren åpner og stenger ut fra set-temp. Det eneste jeg har funnet som kan brukes så langt er Generic Thermostat og har laget følgende kode ut fra denne:

climate:
  - platform: generic_thermostat
    name: Nede
    heater: switch.z_water_6
    target_sensor: climate.battery_operated_thermostat
    min_temp: 15
    max_temp: 35
    ac_mode: false
    target_temp: 17
    cold_tolerance: 0.3
    hot_tolerance: 0
    min_cycle_duration:
      seconds: 5
    keep_alive:
      minutes: 3
    initial_hvac_mode: "off"
    away_temp: 16
    precision: 0.1

 

Jeg opprettet mappen "climate" og filen "generic_thermostat" slik at koden ligger slik:

/config/climate/generic_thermostat.yaml

I tillegg gikk jeg til /config/configuration.yaml og la inn "climate: !include_dir_merge_list climate/" nederst i denne filen.

 

Jeg opprettet et termostatkort i Lovelace og den viser samme temperatur som Heatit Temp2 og når jeg endrer set-temp følger både kort og termostat med. Så den delen fungerer bra. Men ikke pokker om rele 6 på Z-water endrer seg... Kan også nevne at jeg har kontakt med Z-water. Har også alle ti releene der og kan skru dem av og på, og jeg hører at Z-water responderer.

 

Noen som har tips til en fersking på dette?

Lenke til kommentar
Del på andre sider

Hei, 

Jeg kjenner ikke så godt til disse produktene, men regner med at disse kan assosieres sammen slik at dette også vil fungere selv om Home assistant er nede.

Nå vet jo ikke jeg om du faktisk ikke ønsker at disse skal assosieres. sammen. 🙂

Connecting to an external relay After the device is added to your Z-Wave gateway you will need to link the thermostat to the device that is going to control the heating. This is done by using association groups from the thermostat’s root device (EP0) with Group 3 (ON/OFF Control) towards your actuator device (using Multichannel or Single channel, based on the controlled device type.

 

Rune

Lenke til kommentar
Del på andre sider

RuneRH skrev (1 time siden):

Nå vet jo ikke jeg om du faktisk ikke ønsker at disse skal assosieres. sammen.

 

Det vil jeg absolutt! Er for så vidt det primære målet mitt nå. I Homey var det slik du beskriver jeg hadde satt det opp, assosierte hver termostat til de sløyfene de skulle styre.

 

Men hvor skal jeg få lagt inn den assosiasjonen? Blir det ved å redigere en fil elns? Jeg har prøvd å lage automasjoner, men lykkes heller dårlig med det. 

Lenke til kommentar
Del på andre sider

Kal-El skrev (8 timer siden):

 

Det vil jeg absolutt! Er for så vidt det primære målet mitt nå. I Homey var det slik du beskriver jeg hadde satt det opp, assosierte hver termostat til de sløyfene de skulle styre.

 

Men hvor skal jeg få lagt inn den assosiasjonen? Blir det ved å redigere en fil elns? Jeg har prøvd å lage automasjoner, men lykkes heller dårlig med det. 

 

Det skal være mulig via Z-wavejs2mqtt kontroll-panel. Har du prøvd det? Har ikke gjort det selv enda, men skal det etterhvert.

Mulig dette hjelper?

https://community.home-assistant.io/t/create-zwave-association-in-zwavejs2mqtt-control-panel/330285

Lenke til kommentar
Del på andre sider

Kal-El skrev (10 timer siden):


    target_sensor: climate.battery_operated_thermostat
   


Ligger temperatursensoren din i domenet «climate»? De pleier vel ligge under «sensor». Altså noe slikt som sensor.battery_operated_thermostat.

 

Dersom den faktisk ligger under «climate», må du kanskje lage en template-sensor som henter ut temperatur-attributten fra climate.battery_operated_thermostat, og deretter bruke denne template-sensoren som target_sensor i generic thermostate.

 

espen4001 skrev (1 minutt siden):


Ligger temperatursensoren din i domenet «climate»? De pleier vel ligge under «sensor». Altså noe slikt som sensor.battery_operated_thermostat.

 

Dersom den faktisk ligger under «climate», må du kanskje lage en template-sensor som henter ut temperatur-attributten fra climate.battery_operated_thermostat, og deretter bruke denne template-sensoren som target_sensor i generic thermostate.

 


Kan sikkert stryke denne 😴

Såg nå at du har skrevet at det fungerer slik du har satt opp. Termostaten din viser jo riktig temperatur. Så da antar jeg at det er rett med climate, slik du har brukt. 

Lenke til kommentar
Del på andre sider

Bjonness skrev (14 timer siden):

Det skal være mulig via Z-wavejs2mqtt kontroll-panel. Har du prøvd det? Har ikke gjort det selv enda, men skal det etterhvert.

Mulig dette hjelper?

https://community.home-assistant.io/t/create-zwave-association-in-zwavejs2mqtt-control-panel/330285

 

Er fullt mulig at dette er veien å gå, men mqtt er jeg helt grønn på fremdeles.

 

Lenke til kommentar
Del på andre sider

espen4001 skrev (15 timer siden):

Såg nå at du har skrevet at det fungerer slik du har satt opp. Termostaten din viser jo riktig temperatur. Så da antar jeg at det er rett med climate, slik du har brukt. 

 

Ja termostaten og kortet fungerer helt fint i HA, det samme gjør styringen av Z-water releet. Der jeg står fast er å få disse to til å fungere mot hverandre. Å bruke Generic Thermostate skulle jeg i prinsippet ha fått styrt en av de 10 releene på Z-water med termostaten. Men det er ingen respons.

 

Lenke til kommentar
Del på andre sider

Kal-El skrev (10 timer siden):

 

Er fullt mulig at dette er veien å gå, men mqtt er jeg helt grønn på fremdeles.

 

Regner med at du bruker zwavejs? 

Da bruker du kun zwavejs2mqtt som kontrollpanel. 

Skal gjøre det selv imorgen eller på mandag. 

Kanskje dette hjelper? (Har ikke sett videoen selv)

https://youtu.be/DbxBHlo6KiQ

 

Tror ellers det er feil i configen din. 

Du har "climate:" både i configuration.yaml og generic_thermostat.yaml, du skal kun ha den i førstnevnte. 

 

Prøv å endre til: 
- platform: generic_thermostat
  name: Nede
  heater: switch.z_water_6
  target_sensor: climate.battery_operated_thermostat
  min_temp: 15
  max_temp: 35
  ac_mode: false
  target_temp: 17
  cold_tolerance: 0.3
  hot_tolerance: 0
  min_cycle_duration:
    seconds: 5
  keep_alive:
    minutes: 3
  initial_hvac_mode: "off"
  away_temp: 16
  precision: 0.1

Endret av Bjonness
Lenke til kommentar
Del på andre sider

Bjonness skrev (50 minutter siden):

Regner med at du bruker zwavejs? 

 

 

Det er riktig. Jeg har brukt Youtube (selvfølgelig) for å sette opp dette spetakkelet her, men har ikke kommet til mqtt-universet enda. Eller dvs, jeg har ikke skjønt det enda. Er nok noe basic-kunnskap jeg har gått glipp av. Skal se på den videoen litt senere i dag👍

 

Bjonness skrev (55 minutter siden):

Tror ellers det er feil i configen din. 

 

 

Har rettet det opp slik du foreslår. Måtte bruke noen forsøk, prøvde først å slette første linje uten hell. Men når jeg klipte inn linjene fra denne tråden ble det godtatt, dessverre uten at det skjedde noen mirakler.

 

Som du ser av bildene så peker termostatkortet kun til sin egen entity. Mulig det er riktig. Tok printscreen av filene og plasseringen i tilfelle noen klarer å se om det er mer feil.

2021-12-18 (1).png

2021-12-18 (2).png

2021-12-18 (3).png

Lenke til kommentar
Del på andre sider

Har du sjekket loggene dine? 

 

Jeg har en en generic thermostat som jeg bruker på en mill ovn i stuen (se under). Denne virker alltid, så du kan prøve å kopiere og bytte ut heater og target_sensor. 

Ser folk har noen bugs når de bruker keep_alive funksjonen. Forsøk å fjerne denne? 

#Denne thermostaten styrer mill ovnen i stuen. 
#input_boolean.mill_stue_ovn aktiverer automasjon "stue varme"
- platform: generic_thermostat
  name: Stuen
  heater: input_boolean.mill_stue_ovn
  target_sensor: sensor.ute_temperature
  min_temp: 15
  max_temp: 25
  ac_mode: false
  #target_temp: 23
  cold_tolerance: 0.2
  hot_tolerance: 0.1
  initial_hvac_mode: "heat"
  min_cycle_duration:
    seconds: 5

 

Lenke til kommentar
Del på andre sider

Kim123 skrev (4 timer siden):

Denne virker alltid, så du kan prøve å kopiere og bytte ut heater og target_sensor. 

Ser folk har noen bugs når de bruker keep_alive funksjonen. Forsøk å fjerne denne?

 

Prøvde å bruke din uten hell, og da er vel "keep_alive" også sjekket ut.

 

Kim123 skrev (4 timer siden):

Har du sjekket loggene dine? 

 

 

Nå er det mange logger, og jeg vet ikke helt hvilke jeg skal sjekke... Men jeg gikk blant annet inn på Configuration og så Logs. Der finner jeg riktignok feilmeldinger:

Log Details (ERROR)

Logger: homeassistant.components.generic_thermostat.climate
Source: components/generic_thermostat/climate.py:430
Integration: generic_thermostat (documentation, issues)
First occurred: 4:15:09 PM (22 occurrences)
Last logged: 6:17:24 PM

  • Unable to update from sensor: could not convert string to float: 'heat'
  • Unable to update from sensor: could not convert string to float: 'off'
Lenke til kommentar
Del på andre sider

 

Kim123 skrev (21 timer siden):

Target sensoren din er feil kan det se ut som, du må inn på enheten å finne en som gir temperaturen, ikke i climate. domene, men sensor. domene (typ, sensor.battery_thermostat_temperature) 

 

Det har du helt sikkert rett i, men jeg får ikke valgene jeg trenger. Jeg har en sensor jeg kunne brukt (sensor.battery_operated_thermostat_air_temperature), men den får jeg ikke brukt. Og ikke kommer den opp som valg om jeg prøver edit i Lovelace på termostaten. Er den en måte å ordne, eller få tilgang til denne entityen på tro?

 

Uten at jeg vet hvordan jeg klarte det så kom jeg litt videre i går. I Lovelace fikk jeg valget om å bruke climate.battery_operated_thermostat som target, men også climate.nede som target. Da slo releet inn og ut når jeg endret set-point i Lovelace, men jeg fikk ikke opp set-point på den fysiske termostaten, men temeraturavlesningen på termostaten og i Lovelace var lik. Hvordan jeg fikk det til vet jeg ikke, og i ettertid har jeg rotet meg bort så jeg får ikke opp disse valgene lengre.....

Lenke til kommentar
Del på andre sider

Kim123 skrev (9 minutter siden):

Det er i teorien å ta taggen og sette inn i generic thermostat configen din

 

Sensoren ser jeg når jeg går inn på device, og der ligger den som identity ID:sensor.termostat_nede_air_temperature.

Men når jeg legger den inn i /config/climate/generic_thermostate får jeg den fremdeles ikke som valg i Lovelace-kortet. Og velger jeg likevel å skrive den inn som entity får jeg beskjed: 

Specify an entity from within the climate domain
type: thermostat
entity: sensor.termostat_nede_air_temperature
 
Men der ligger den jo for pokker!

2021-12-19 (2)_LI.jpg

Lenke til kommentar
Del på andre sider

Noe som skurrer her. 

 

Den følerne du har ringet rundt er en entity til climate.termostat_nede (?) som er en Z-wave enhet og ikke din generic_thermostat. 

 

På configen du har lagt ut tidligere har det stått "name: nede", da skal entityen for generic climaten din være climate.nede 

 

Hvis du ikke finner den, gå inn i developer tools -> states søk så etter climate og se om den ligger med et annet navn kanskje. 

 

 

 

Lenke til kommentar
Del på andre sider

Kal-El skrev (2 timer siden):

 

Sensoren ser jeg når jeg går inn på device, og der ligger den som identity ID:sensor.termostat_nede_air_temperature.

Men når jeg legger den inn i /config/climate/generic_thermostate får jeg den fremdeles ikke som valg i Lovelace-kortet. Og velger jeg likevel å skrive den inn som entity får jeg beskjed: 

Specify an entity from within the climate domain
type: thermostat
entity: sensor.termostat_nede_air_temperature
 
Men der ligger den jo for pokker!

2021-12-19 (2)_LI.jpg


I config for din generic_thermostat må du bruke sensor.termostat_nede_air_temperature som «target-sensor».

I Lovelace-kortet ditt skal du vise climate.nede, siden du har kalt termostaten din «nede» (name: Nede).

Du vil ikke finne en sensor når du prøver å legge til et termostat-kort. Da er det climate som skal brukes.

Lenke til kommentar
Del på andre sider

Kim123 skrev (29 minutter siden):

Noe som skurrer her. 

 

Den følerne du har ringet rundt er en entity til climate.termostat_nede (?) som er en Z-wave enhet og ikke din generic_thermostat. 

 

På configen du har lagt ut tidligere har det stått "name: nede", da skal entityen for generic climaten din være climate.nede 

 

Hvis du ikke finner den, gå inn i developer tools -> states søk så etter climate og se om den ligger med et annet navn kanskje. 

 

 

 


Det som er målet er, slik jeg oppfatter det, å bruke en intern føler i en z-Heatit termostat til å styre et annet relé.

En heatit-termostat (Z-TRM3 som jeg har selv) dukker opp med en masse entiteter, blant annet climate for selve termostaten, men også flere følere: intern luftføler, intern gulvføler og ekstern gulvføler. Disse ligger i sensor-domenet (feks sensor.heatit_floor_temperature).

 

Jeg har selv laget en generic_thermostat og brukt gulvsensoren fra min heatit Z-trm3 til å styre denne, og det fungerte helt fint :)

 

Og ja, den nye generic termostaten vil ifølge configen hete climate.nede.


Du skal ikke referere til noen sensor-entiteter når du skal legge til termostater i Lovelace. Sensoren du bruker til å styre termostaten, ligger kun i configen, og vil vises i Lovelace som «målt temperatur» i entiteten climate.nede.


Her er visning av en annen generic termostat jeg har:

B15C8490-7359-4EFD-85F1-8372ADC015E2.thumb.jpeg.cf4138b0ed3c03c9ef688d62be058f3c.jpeg
 

Dette er en Philips Hue Smartplug med en tilkoblet varmeovn, som styres av en annen trådløs temperaturføler.

Vises i Lovelace med entiteten climate.loftstue.

Temperaturen «Er nå:» er den som er målt av den trådløse temperatursensoren sensor.loft_temp


Configen ser slik ut:

 

- platform: generic_thermostat
  name: Loftstue
  heater: switch.philips_plugg
  target_sensor: sensor.loft_temp
  min_temp: 12
  max_temp: 28
  ac_mode: false
  target_temp: 22
  cold_tolerance: 0.1
  hot_tolerance: 0
  min_cycle_duration:
    seconds: 5
  keep_alive:
    minutes: 3
  away_temp: 17
  precision: 0.1

Endret av espen4001
Lenke til kommentar
Del på andre sider

Kal-El skrev (På 18.12.2021 den 12.09):

Det er riktig. Jeg har brukt Youtube (selvfølgelig) for å sette opp dette spetakkelet her, men har ikke kommet til mqtt-universet enda. Eller dvs, jeg har ikke skjønt det enda. Er nok noe basic-kunnskap jeg har gått glipp av. Skal se på den videoen litt senere i dag👍

 

Ser ut som du har løsningen ovenfor på generic thermostat. Ville bare legge til hvordan du installerer z-wavejs2mqtt som kontrollpanel, men bruker z-wavejs (fra scratch), da jeg selv gjorde det idag. 

1. Installer Z-wavejs2mqtt fra addon store

2. Gå på configuration på Z-wavejs2mqtt og skriv inn port 3000 på host. Deretter start Z-wavejs2mqtt

3. Gå inn på z-wavejs2mqtt, deretter innstillinger og åpne z-wave innstillinger. Legg inn riktig serial port mot din usb, og generer S2 og S0 keys. Mulig de autogenererer seg om du ikke gjør noe? Jeg trykket ihvertfall på refresh tegnet. 

3.1 Dobbeltsjekk at "Disable MQTT gateway" er slått på og "WS server" under Home assistant settings (inne på Z-wavejs2mqtt) er skrudd på.

3.5 Mulig man kan kopiere S2 og S0 keys fra Z-wavejs addon om man har denne fra før, har ikke prøvd dette, men antar det går helt fint. (Sikkert greit med en backup.)

4. Gå inn på (HA) configuration -> integrations -> add integration -> z-wave JS

5. Installer denne, men fjern haken på "Use the Z-wave JS Supervisor add-on" og bruk url: "ws://localhost:3000" evt "ws://a0d7b954-zwavejs2mqtt:3000"

6. Kos deg med Z-wave kontrollpanel :) 

 

OBS: 

Bommet litt selv først, så ble litt feil før jeg skjønte hvordan. Z-wavejs addon og integrations er 2 forksjellige ting. Om du skal bruke Z-wavejs2mqtt, må Z-wavejs addon slettes og installere z-wavejs2mqtt installeres. Z-wave JS integration skal beholdes om du kun skal bruke Z-wavejs2mqtt som kontrollpanel. 

 

image.thumb.png.d63cd7f7be0967bd22664d9625a5fc4d.png

Endret av Bjonness
Lenke til kommentar
Del på andre sider

Kim123 skrev (22 timer siden):

Den følerne du har ringet rundt er en entity til climate.termostat_nede (?) som er en Z-wave enhet og ikke din generic_thermostat. 

 

På configen du har lagt ut tidligere har det stått "name: nede", da skal entityen for generic climaten din være climate.nede 

 

Dette har jeg rotet med litt fram og tilbake, skyldes nok at jeg ikke skjønte logikken her. Takk!

Lenke til kommentar
Del på andre sider

espen4001 skrev (23 timer siden):

Og ja, den nye generic termostaten vil ifølge configen hete climate.nede.

 

espen4001 skrev (23 timer siden):

Du skal ikke referere til noen sensor-entiteter når du skal legge til termostater i Lovelace. Sensoren du bruker til å styre termostaten, ligger kun i configen, og vil vises i Lovelace som «målt temperatur» i entiteten climate.nede.

 

Takk, det hjalp å få plass denne, skjønner mer av logikken og strukturen i dette nå. Når jeg går inn på min Heatit Temp2 termostat får jeg dette bilde (stort sett det samme som du har).

 

1716003222_2021-12-20(3)_LI.thumb.jpg.f8a8cf551b99359d6eab4b4eb1d82668.jpg

 

Når jeg går inn i Configuration (bilde over her) så ser jeg informasjonen i den blå ringen. Den endrer seg når jeg endrer set-temp, og den avleser temperatur korrekt og raskt. Men dette er climate.battery_operated_thermostat, og er ikke dette da hentet fra filen min (generic_thermostate)? Om jeg legger climate.battery_operated_thermostat inn som target sensor i filen får jeg i alle fall ikke opp noen temperatur til termostaten og kan heller ikke endre set-temp med termostaten. Så det må være et blindspor å bruke i filen min?

 

Legger jeg inn den sensoren i rød sirkel (sensor.battery_operated_thermostat_air_temperature) hjelper det litt. Da får jeg opp riktig temperaturavlesning fra termostaten, og jeg ser Lovelace-kortet følger temperatursvingninger opp og ned. Men det går ulidelig treg! Vi snakker om minutter her før den reagerer... Jeg får heller ikke endret set-temp med termostaten, da er det ingen reaksjon i Lovelace-kortet så her er det noe rart.

 

Flere sensor-entity finner jeg ikke.

 

Det positive er at nå får jeg trigget releet når jeg endrer set-temp i Lovelace. Så som en nødløsning kan jeg sette set-temp der og få regulert varmen, det er jo bra. Det som er litt dumt er at jeg er en idiot! Jeg har prøvd meg fram og tilbake, og brukt alle tips og råd jeg har fått i denne tråden og eller funnet på internettet i flere dager. Og så ser jeg tilfeldigvis at jeg har glemt å sette .yaml som ending på generic_thermostate filen min.....

 

For info til andre som skulle ha trøbbel med Z-water så var ett av problemene min at jeg brukte heater: switch.z_water_6 til å begynne med. Etter noen dager...fant jeg ut at dette skulle være heater: switch.relay_control_6.

 

Jeg har prøvd å legge inn Heatit Temp2 både som sikker og usikker for å se om det er noen forskjell, men det ser ikke ut til å endre på så mye. generic_thermostate.yaml ser nå slik ut:

- platform: generic_thermostat
  name: nede
  heater: switch.relay_control_6
  target_sensor: sensor.battery_operated_thermostat_air_temperature
  min_temp: 12
  max_temp: 28
  ac_mode: false
  target_temp: 22
  cold_tolerance: 0
  hot_tolerance: 0
  min_cycle_duration:
    seconds: 5
  away_temp: 17
  keep_alive:
    minutes: 3
  precision: 0.5

Endret av Kal-El
Rettet feil info om sensorer mm.
Lenke til kommentar
Del på andre sider

Bjonness skrev (19 timer siden):

Ville bare legge til hvordan du installerer z-wavejs2mqtt som kontrollpanel,

 

Kjempebra! Takker for denne, selv om jeg begynner å nærme meg løsningen på andre måter har jeg skjønt at mqtt er genialt. Kommer til å vente litt før jeg tar i bruk guiden din. Nå må jeg få på plass de siste bitene på termostaten, og så resten av lys og bevegelsessensorene i huset over på HA så jeg kan pensjonere Homey`n. 

Lenke til kommentar
Del på andre sider

Jeg tror du må legge ut ny kode av configen din, samt feilmeldinger i loggen (som det forrige). 

 

Den skal ikke endre set temp på den fysiske termostaten din. Du har laget en ny uavhengig termostat som nå ikke har noe å gjøre med den som står fysisk plassert nede uten enn å lese av en temperaturføler. Hvis du skal endre settpunkt på den fysiske termostaten må du kjøre en automasjon som endrer setpunktet på den fysiske. 

Lenke til kommentar
Del på andre sider

Bli med i samtalen

Du kan publisere innhold nå og registrere deg senere. Hvis du har en konto, logg inn nå for å poste med kontoen din.

Gjest
Skriv svar til emnet...

×   Du har limt inn tekst med formatering.   Lim inn uten formatering i stedet

  Du kan kun bruke opp til 75 smilefjes.

×   Lenken din har blitt bygget inn på siden automatisk.   Vis som en ordinær lenke i stedet

×   Tidligere tekst har blitt gjenopprettet.   Tøm tekstverktøy

×   Du kan ikke lime inn bilder direkte. Last opp eller legg inn bilder fra URL.

 Del

×
×
  • Opprett ny...