Jump to content

Fra smartthings til HA


Recommended Posts

Hei,

 

Tibber har ikke lenger integrasjon mot smartthings, så jeg vurderer bytte til HA. Jeg har kun termostater (6 stk) som kontrollers via Tibber, så det er lite jeg faktisk tenker automatisere.

Gå til innkjøp av en raspberry pi 3, minnekort og lader og teste dette? Eller er det noe jeg må være obs på?

Link to post
Share on other sites
36 minutter siden, hjemmedude skrev:

Hei,

 

Tibber har ikke lenger integrasjon mot smartthings, så jeg vurderer bytte til HA. Jeg har kun termostater (6 stk) som kontrollers via Tibber, så det er lite jeg faktisk tenker automatisere.

Gå til innkjøp av en raspberry pi 3, minnekort og lader og teste dette? Eller er det noe jeg må være obs på?

Kjøp et minnekort av kvalitet og som er stort. I og med at minnekort har "wear leveling" så vil et 16GB kort slites 8 ganger fortere enn et 128GB kort.

Link to post
Share on other sites

Installert raspberry pi os og docker med homeassistant for pi versjon 3. Det fungerer jo greit. Men må ha tak i en z wave usb stick - trodde egentlig det var integrert 🙂

Så da er den lille saken på nett i alle fall! Og den finner en del av systemene jeg har i hus, så det er fint. Men hvordan og kanskje hvorfor jeg skal aksessere denne informasjonen vet jeg ikke, for eks netatmo 🙂 Om det er detaljnivå går jeg via app, om kun for en kjapp kikk går jeg via tibber-app.

Link to post
Share on other sites
27 minutter siden, hjemmedude skrev:

Installert raspberry pi os og docker med homeassistant for pi versjon 3. Det fungerer jo greit. Men må ha tak i en z wave usb stick - trodde egentlig det var integrert 🙂

Så da er den lille saken på nett i alle fall! Og den finner en del av systemene jeg har i hus, så det er fint. Men hvordan og kanskje hvorfor jeg skal aksessere denne informasjonen vet jeg ikke, for eks netatmo 🙂 Om det er detaljnivå går jeg via app, om kun for en kjapp kikk går jeg via tibber-app.

 

Etterhvert vil du samle alt i din Lovelace.yaml frontend så kan du bare gå dit for en detaljert kikk, istedenfor 50 forskjellige apper :) 

Link to post
Share on other sites

Høres igrunnen meget bra ut.

Har fått tak i en aeotec z wave usb stick, men sliter litt med den. Tenkte modifisere docker men vet ikke helt hvordan, docker containeren er oppe å gå så jeg får conflict når jeg kjører helt lik kode som her:

 

 

To enable access to the Z-Wave stick, add --device=/dev/ttyACM0 to the docker command that starts your container, for example:

docker run -d --name="home-assistant" -v /home/pi/homeassistant:/config -v /etc/localtime:/etc/localtime:ro --net=host --device=/dev/ttyACM0 homeassistant/raspberrypi3-homeassistant
Bash
 

If the path of /dev/ttyACM0 doesn’t work then you can find the path of the stick by disconnecting and then reconnecting it, and running the following in the Docker host:

ls -1tr /dev/tty*|tail -n 1
Link to post
Share on other sites

Det letteste da er vel å finne docker IDen med

docker ps

så kjøre

docker stop "id"

fjerne med

docker rm "id"

Så kan du kjøre kommandoen du prøvde på over her på nytt. Så lenge kommandoen peker på samme volumer som sist bør den kjøres opp med samme config/filer som sist :)

(trenger bare nok deler av iden til at den er unik, for din del sikkert bare første tegn, f.eks "docker stop e" om id'en er e983u2489ufsu98fus98f)

Link to post
Share on other sites
Posted (edited)

Takker - med remove så mister man all konfig antakelig?

Finner ikke usb stick - etter litt søking ser det ut til at en utvei er en usb hub tilkobla pi-en. Men vet ikke om det blir aktuelt.. Når jeg kjører :

pi@raspberrypi:~ $ ls -1tr /dev/tty*|tail -n 1
/dev/ttyS0

Så tror ikke usb sticken i systemet..

blir ikke detektert av dmesg heller. Nei, tror jeg leverer dette tilbake :)

Edited by hjemmedude
Link to post
Share on other sites

Hvilken PI kjøpte du? Det er kjente problemer med PI4 og Aoetec Z-stick som krever HUB, og det er mange ting som ikke støtter PI med 8GB RAM afaik.

 

Har du noe annet enn sticken koblet til? Er /dev/ttyS0 output fra kommandoen? Hvis ingen ting annet koblet til så kan jo det være sticken. Kjør i så fall

docker run -d --name="home-assistant" -v /home/pi/homeassistant:/config -v /etc/localtime:/etc/localtime:ro --net=host --device=/dev/ttyS0 homeassistant/raspberrypi3-homeassistant

 

Link to post
Share on other sites

Like greit, å kjøre i docker om det er første gang du setter opp kan gi mer problemer enn du trenger når alt er helt nytt. Anbefaler en installasjonsmetode hvor du får med "Supervisor", det vil gjøre det lettere å legge til nyttige add-ons til HA :) Alle installasjonsmetodene samt anbefalt hardware finnes her: https://www.home-assistant.io/docs/installation/

 

Håper du forsøker på Home Assistant igjen med ny hardware, så skal jeg gjerne hjelpe deg opp å kjøre om det trengs, men tror egentlig du får det fint til så lenge utstyret er kompatibelt :D 

Link to post
Share on other sites
  • 4 weeks later...

Klarer ikke legge i fra meg HA helt enda. Installert Windows på en gammel server, installert Vmware workstation (ikke pro, er pro gratis?) deretter ubuntu sol VM med HA i docker.

Fikk inn aeotec stick og fikk include på en heatit termostat. Disse er den første typen (053?) og dukker opp uten temp, uten set temp, et snurrehjul å velge temp med (uten indikasjon på temp er det litt spennende). 
Leser at flere har trøbbel og gjerne løst det med xml filer inn i konfig.
Vil samme løsning funke for meg? 

 

Et annet om vmware, vil jeg klare å kjøre VM-en ved auto-pålogging i Windows? Tenker da på strømbrudd eller Windows restart (som kan skje i tide og utide).. 

Link to post
Share on other sites

Wow, du overkompliserer stadig ting for deg selv (etter min mening). Hvis du ikke absolutt må ha Windows (hvorfor?) så er det mye mer lettvekt å kjøre Proxmox over Windows+Vmware og du får muligheten til å ha flere VMs akkurat som i Vmware. Da kan du kjøre HA som fullverdig OS slik det er ment å installeres, noe som gjør det mye lettere å håndtere enn en custom docker install. Jeg har kjørt begge deler over lengre tid så har litt erfaring. Når du kjører HA som fullverdig OS vil fortsatt alle addons osv kjøres i docker-containere. Proxmox har i hvert fall auto-boot og jeg regner med at Vmware har det samme. Si i fra om du vil ha tips til oppsett i Proxmox ^^

 

Har ikke hørt noe om at Heatit Z-term V1 krever XML-config, men hvis den gjør det så vil det fungere for deg også som alle andre :) 

Link to post
Share on other sites

Det var fra gammelt av Windows på denne og ville ikke begynne helt på scratch med ubuntu i går kveld. Har brukt denne som medieserver tidligere men er ikke noe kraftig sak så dette fungerte så som så om transkoding startet opp. 
 

Er enig i at det blir vel komplisert ja, om promox er som esxi kan jeg gi det et forsøk og installere dette som hypervisor. Jeg må kanskje få kjørt en p2v av windows da jeg ikke helt vil kvitte meg med den, men den trenger ikke kjøre til enhver tid heller. Kanskje kjekk å ha om medieserver skal opp igjen senere.

 

Er det noe forskjell på ha i docker kontra fullt os? Var egentlig det jeg ville forsøke i vmware, men fikk det ikke til (lastet ned .ova og vmdk-fil som jeg trodde var riktig for import i vmware for å få det opp å gå)
 

Link to post
Share on other sites
1 time siden, hjemmedude skrev:

Det var fra gammelt av Windows på denne og ville ikke begynne helt på scratch med ubuntu i går kveld. Har brukt denne som medieserver tidligere men er ikke noe kraftig sak så dette fungerte så som så om transkoding startet opp. 
 

Er enig i at det blir vel komplisert ja, om promox er som esxi kan jeg gi det et forsøk og installere dette som hypervisor. Jeg må kanskje få kjørt en p2v av windows da jeg ikke helt vil kvitte meg med den, men den trenger ikke kjøre til enhver tid heller. Kanskje kjekk å ha om medieserver skal opp igjen senere.

 

Er det noe forskjell på ha i docker kontra fullt os? Var egentlig det jeg ville forsøke i vmware, men fikk det ikke til (lastet ned .ova og vmdk-fil som jeg trodde var riktig for import i vmware for å få det opp å gå)
 

 

Liten grafisk fremstilling av hva de forskjellige installasjonsmetodene innebærer:

 

image.thumb.png.c583383e4dc986b28f61aa4ae3b0cf03.png

 

Alt er docker-basert så uansett hvilken måte du kjører det på så vil du få flere containere, men har du Home Assistant OS vil du få deres Supervisor som håndterer containerne for deg og de er da på forhånd konfigurert til å fungere mot HA, noe som gjør det veldig simpelt å sette opp og bruke.

 

Home Assistant OS er et Linux-basert OS, men det er mye "lettere" enn f.eks Ubuntu, så om man uansett har en mulighet for å kjøre VM så blir det unødvendig mye overhead å kjøre f.eks Ubuntu OS --> HA Core i Docker. Da er det bedre med Home Assistant OS (som kjører HA Core i docker) :) 

 

Om du går for Proxmox kan du installere HA i en VM med en kommando herfra: https://github.com/whiskerz007/proxmox_hassos_install

 

  • Like 3
Link to post
Share on other sites

OK, takk for nyttig info!

Ser nå at min workstation uten pro ikke gir samme nødvendige settings som pro, så det prøer jeg nå. Ser ut til å funke bra.

Skjønner også at Ubuntu blir overkill når det finnes eget HA OS! :)

Server/NAS-en er en AMD Athlon 5350 APAU på 2,05Ghz og har kun 4GB ram installert. Men Hass.io krever nok ikke allverden for å funke.

Blir litt voldsomt med en full esxi/proxmox akkurat nå, det er sikkert litt jobb å få dette opp å gå, men vil gå den veien etter hvert. :)

Hadde vært fint å kunne ha Windows som en vm så jeg ikke mister noe jeg kanskje trenger en gang.. :)

 

edit: da er hassio (riktig navn?) oppe å kjører med 1 inkludert heatit termostat. Men den viser ingen spesiell info og ikke noe spesiell temperatur på den visuelle termostaten... Så må finne noen easy steps for å få dette til å fungere, tips mottas gjerne :)

 

edit 2: Kom plutselig data inn i HA så da ser det ut til at det funker på denne termostaten! :D

 

edit 3: kan man styre termostatene via tibber app om man linker tibber med HA? Det var jo en grei måte å justere opp/ned temp avhengig av natt/dag, strømpris osv. Tror jeg

Edited by hjemmedude
  • Thanks 1
Link to post
Share on other sites

Hei igjen,

klarer ikke sette temperatur på mine heatit termostater via ha-app eller nettleser på mobil. Vpn tilbake til hjemmenettverk. Hverken hjul eller manuell innstilling gir ny settemperatur.

Noen tips?

Nok en gang løste det seg med en restart av server :) 

Edited by hjemmedude
Link to post
Share on other sites
  • 3 weeks later...
På 11.9.2020 den 13.04, hjemmedude skrev:

Hei igjen,

klarer ikke sette temperatur på mine heatit termostater via ha-app eller nettleser på mobil. Vpn tilbake til hjemmenettverk. Hverken hjul eller manuell innstilling gir ny settemperatur.

Noen tips?

Nok en gang løste det seg med en restart av server :) 

Ordnet det seg?

Hvilken termostat er det? Jeg har samme problem på TRM-3.

Regner med du har sett tråden om den: https://www.hjemmeautomasjon.no/forums/topic/6330-z-trm3-target-temperature-får-ikke-satt/#comments

 

Link to post
Share on other sites
3 timer siden, erikfaug skrev:

Ordnet det seg?

Hvilken termostat er det? Jeg har samme problem på TRM-3.

Regner med du har sett tråden om den: https://www.hjemmeautomasjon.no/forums/topic/6330-z-trm3-target-temperature-får-ikke-satt/#comments

 


Ja det ordnet seg og fungerer fint. Jeg har v1 eller v2, hvor sjekker jeg det?

Link to post
Share on other sites
10 timer siden, Atle skrev:

Leser at på Rasperry Pie kan minnekortet bli korrupt

Baserer seg sikkert på de som kjøper minnekort av billigste sort. Kjøper en kvalitet så holder det. Og en må kjøpe stort nok. For hver gang en dobler lagringsstørrelsen så halverer en slitasjen på det.

Link to post
Share on other sites
19 timer siden, Atle skrev:

Usikker hvilken hw HA bør kjøre på. Leser at på Rasperry Pie kan minnekortet bli korrupt. Er kanskje en NUC i3 å anbefale med SSD disk? 

 

Jeg begynte med HA på Raspberry Pi 3B+ og så et år på Raspberry Pi 4 med dette sd-kortet uten noen problemer(unntatt at Z-wave donglen til Aeotec som måtte kjøres igjennom en USB2.0 hub). Nå har kjørt HA i Proxmox på en Intel NUCi7 i snart 3 måneder og det har fungert som en drøm, angrer ikke et sekund på at jeg gikk over til en NUC.

 

Enig med det som @stigvi skriver at man bør gå for et kvalitet kort vis du skal kjøre på en Raspberry Pi.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...