Gå til innhold
  • Bli medlem

HA på Raspberry Pi 4 med USB-SSD


Anbefalte innlegg

Hei og hopp!

 

Jeg har fått meg en en Rpi4 og har en USB-SSD liggende så jeg tenkte jeg skulle se hvordan det fungerte. Jeg er klar over utfordringene rundt Aeotec USB Zwave, men ser at det kan løses med en usb-hub så det må jeg klare å fikse.

 

Det jeg ikke er så trygg på er hvordan man setter det opp til å boote fra SSD. Finner ikke så mye info om det heller.

 

Noen her som har erfaring med dette oppsettet?

Lenke til innlegg
Del på andre sider

Det aller enkleste er å boote fra et skrivebeskyttet minnekort og deretter bruke usb-ssd som datapartisjon. Dette er støttet i hassos i motsetning til å boote fra usb.

  • Like 2
Lenke til innlegg
Del på andre sider
36 minutes ago, stigvi said:

Det aller enkleste er å boote fra et skrivebeskyttet minnekort og deretter bruke usb-ssd som datapartisjon. Dette er støttet i hassos i motsetning til å boote fra usb.

Hva ligger da i så fall på det minnekortet? Blir ikke det litt tungvint med tanke på oppdateringer at det er skrivebeskyttet? Eller er det jeg som misforstår?

 

25 minutes ago, stigvi said:

Supert! Finnes det noe god beskrivelse på hvordan man praktisk gjør det?

 

Og hvordan blir dette når jeg da flyttert min siste snapshot fra gammelt oppsett som ikke har delt datapartisjon og boot til det nye som er med denne delingen?

Lenke til innlegg
Del på andre sider
Akkurat nå, Mathias skrev:

Blir ikke det litt tungvint med tanke på oppdateringer at det er skrivebeskyttet? Eller er det jeg som misforstår?

Bare jeg som forklarer dårlig. Det blir "mounted" i read-only modus. Oppdateringer går knirkefritt, men du slipper kontinuerlig slitasje på minnekort og det ligger ingenting brukerdata der. I prinsippet kan du ha et reservekort liggende og boote på det hvis det andre skulle feile.

Lenke til innlegg
Del på andre sider
8 minutter siden, Mathias skrev:

Supert! Finnes det noe god beskrivelse på hvordan man praktisk gjør det?

 

Og hvordan blir dette når jeg da flyttert min siste snapshot fra gammelt oppsett som ikke har delt datapartisjon og boot til det nye som er med denne delingen?

Ja, i forumet til HA finnes det oppskrifter. Om det er lett eller ikke er avhengig av om du har SSH tilgang. Det har ikke jeg på min så jeg gidder foreløpig ikke å styre. Regner med det kommer en pek&klikk løsning etterhvert.

Jeg ville flyttet til ny rpi og deretter flyttet data til ny partisjon. Begge de to operasjonene er støttet og forklart, men ikke å ta det i en jafs.

Endret av stigvi
  • Like 1
Lenke til innlegg
Del på andre sider
  • 1 måned senere...

Jeg har installert HA på SSD over USB og fra det jeg kan se fungerer dette bra. Brukte enkelt og greit kun Raspberry Pi Imager for å skrive Home Assistant OS imaget til SSD disken og kan da starte opp fra SSD uten SD kort i Rpi'en. Merk at det det nevnes at en må benytte 64-bit image for å få dette til å fungere.

  • Like 1
Lenke til innlegg
Del på andre sider
1 minutt siden, MikePatton skrev:

Merk at det det nevnes at en må benytte 64-bit image for å få dette til å fungere

Og det er et minus i og med at det er diverse som krever 32 bits os

Lenke til innlegg
Del på andre sider

Hei

 

Har enda ikke, i det minste konkret, oppdaget noe direkte som krever 32-bit OS. Men, og det er faktisk et stort MEN, mens ting og tang ser ut til å, for det meste, fungere helt fint er det tegn som tyder på at alt er ikke som det skal være. F.eks. jeg benytter Z-Wave og når jeg kjører fra SSD er det helt utrolig vanskelig å sette opp, jeg ender nesten alltid opp med "dead nodes", etter diverse reboots så funker kanskje noen av nodene men det er umulig å parre ekstra noder.

 

Når jeg derimot kjører via SD kort, uten SSD innkoblet, så fungerer det derimot smertefritt. Så selv om loggen ikke indikerer at noe er galt og HA starter opp hver gang når jeg kjører fra SSD så er erfaringen at noe ikke er helt som det skal være enda.

Lenke til innlegg
Del på andre sider
  • 2 måneder senere...

Jeg vil bare skrive litt om mine opplevelser med Raspberry pi 4 og SSD disk.

 

Jeg bruker bare SSD disk på min Rasberry PI 4 til å starte opp Home Assistant OS. Jeg bruker denne SSD disken nå. https://www.kjell.com/no/produkter/data/lagring/ssd/wd-green-ssd-disk-240-gb-p61618. HA databasen kan nå skrive og lese uten delay og ikke så sårbar som en microSD er.

 

Men Raspberry Pi har utfordringer med SATA til Usb-A overganger, https://www.raspberrypi.org/forums/viewtopic.php?t=245931. Kjøpte denne SATA til usb-a først, https://www.kjell.com/no/varemerker/plexgear/data/datatilbehor/harddiskkabinett/plexgear-harddiskkabinett-25-smart-access-usb-a-p61288, men fikk skrive og lese problemer til disken. Dette kunne løses med Rasberry quirks (se lenke tidligere), som gjør at en annen usb driver brukes. 

 

Jeg ville ha full utnyttelse av usb 3.0. Jeg kjøpte derfor denne Sata til usb-a overgangen,https://www.kjell.com/no/produkter/data/kabler-og-adaptere/usb/usb-adaptere/usb-3.0-adapter-for-sata-harddisk-p61199,  som fungerte glimrende uten raspberry quirks. Nå leser og skriver SSD disken lynraskt. Kan anbefales.

  • Like 2
Lenke til innlegg
Del på andre sider
  • 3 uker senere...
På 13.4.2021 den 19.53, haraldov skrev:

Jeg vil bare skrive litt om mine opplevelser med Raspberry pi 4 og SSD disk.

 

Jeg bruker bare SSD disk på min Rasberry PI 4 til å starte opp Home Assistant OS. Jeg bruker denne SSD disken nå. https://www.kjell.com/no/produkter/data/lagring/ssd/wd-green-ssd-disk-240-gb-p61618. HA databasen kan nå skrive og lese uten delay og ikke så sårbar som en microSD er.

 

Men Raspberry Pi har utfordringer med SATA til Usb-A overganger, https://www.raspberrypi.org/forums/viewtopic.php?t=245931. Kjøpte denne SATA til usb-a først, https://www.kjell.com/no/varemerker/plexgear/data/datatilbehor/harddiskkabinett/plexgear-harddiskkabinett-25-smart-access-usb-a-p61288, men fikk skrive og lese problemer til disken. Dette kunne løses med Rasberry quirks (se lenke tidligere), som gjør at en annen usb driver brukes. 

 

Jeg ville ha full utnyttelse av usb 3.0. Jeg kjøpte derfor denne Sata til usb-a overgangen,https://www.kjell.com/no/produkter/data/kabler-og-adaptere/usb/usb-adaptere/usb-3.0-adapter-for-sata-harddisk-p61199,  som fungerte glimrende uten raspberry quirks. Nå leser og skriver SSD disken lynraskt. Kan anbefales.

Skulle ABSOLUTT lest her først... etter 1. kjøp av en USB3 SSD boks som delvis fungerte og 3 dager nå med diverse tull uten å få det til... Også ser jeg denne posten om en USB adapter som funker... Nettopp vært på Kjell og skaffet meg en slik, og NUH går Rpi4 på SSD via en ekstern USB hub /m strøm (for å være sikker på at SSD´n får nok strøm) overført snapshot fra det gamle SD kortet og...its smoooooood sailing!

  • Like 1
Lenke til innlegg
Del på andre sider
52 minutter siden, xses skrev:

Nettopp vært på Kjell og skaffet meg en slik, og NUH går Rpi4 på SSD via en ekstern USB hub /m strøm (for å være sikker på at SSD´n får nok strøm) overført snapshot fra det gamle SD kortet

Men SSD, adapter til usb, hub og strømforsyning er det mer driftsikkert enn et SD kort? Det finner en neppe ut av 🙂

Lenke til innlegg
Del på andre sider
Men SSD, adapter til usb, hub og strømforsyning er det mer driftsikkert enn et SD kort? Det finner en neppe ut av [emoji846]
Sant nok.. Gikk endel raskere.. Og nå har jeg litt plass til lagring av små videoklipp fra kamera.

Sent fra min CLT-L29 via Tapatalk

Lenke til innlegg
Del på andre sider
Kan man oppleve samme problemene om man bruker en eksterndisk som har USB-inngang?
Er jo i grunn bare et SATA-USB adapter i disse....
Ja det tror jeg. Virker som RPi4 er ganske så sær på sata kontrollen. Den første jeg kjøpte fungerte fint helt til den måtte jobbe litt... Da var der feilmld i fleng..

Sent fra min CLT-L29 via Tapatalk

Lenke til innlegg
Del på andre sider
  • 1 måned senere...

@slippern @MikePatton En ny erfaring jeg ønsker å dele med dere. Dette gjelder ikke bare Raspberry pi 4, men alle pcer som har USB 2.0 og 3.0 porter tett inntil hverandre.

 

Oppdaget fra dmesg loggen at min Raspberry pi 4 disconnecter USB tilkoblinger flere ganger etter en boot og mens den kjører. Dette påvirker hvordan enheter kommuniserer mot ConBee II usb adapter og Aeotec Z-wave USB adapter.  Det kan bli pakketap og kan gjøre at lys ikke slår seg av eller på i et Zigbee nettverk eller andre problemer det er vanskelig å finne ut av.

 

[220903.879737] usb 3-10: USB disconnect, device number 19
[220904.185283] usb 3-10: new full-speed USB device number 20 using xhci_hcd
[220904.334721] usb 3-10: New USB device found, idVendor=1cf1, idProduct=0030
[220904.334726] usb 3-10: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[220904.334730] usb 3-10: Product: ConBee II
[220904.334732] usb 3-10: Manufacturer: dresden elektronik ingenieurtechnik GmbH
[220904.334735] usb 3-10: SerialNumber: DE2258405
[220904.335788] cdc_acm 3-10:1.0: ttyACM0: USB ACM device

 

Fant flere saker på dette:

-  https://github.com/dresden-elektronik/deconz-rest-plugin/issues/4029

https://github.com/dresden-elektronik/deconz-rest-plugin/issues/1598

 

Løsningen er enkel for ConBee II usb adapter. Bruk en 1.5-2 meter USB utvidelsekabel som kobles til USB 2.0 utgangen på rpi4. Deretter kobles ConBee II på denne. Deretter pakkes SSD disken inn i aluminiumsfolie. USB ledning og konnektor inn til USB 3.0 tilkobling pakkes også inn med aluminiumsfolie. Må den måten skjermes USB3 radio stråling fra SSD disken og rpi connector og vil ikke påvirke Zigbee eller Z-wave antennene. Det holdes ikke å bare ha usb-forlengerkabel. Du må faktisk bruke noe som stopper stråling fra Usb3 enheter, som SSD disken.

 

Ta samtidig og oppgrader firmware på ConBee II. Husk å bruke switchen "-t 60".

GCFFlasher -d COM3 -t 60 -f deCONZ_ConBeeII_0x26580700.bin.GCF

https://flemmingss.com/how-to-update-conbee-conbee-ii-firmware-in-windows-10/

 

Etter jeg gjorde det har jeg ingen USB disconnecter. 

 

Lesestoff for de som ikke tror meg:

USB 3.0* Radio Frequency Interference on 2.4 GHz Devices

https://www.intel.com/content/www/us/en/products/docs/io/universal-serial-bus/usb3-frequency-interference-paper.html

 

Endret av haraldov
  • Like 1
Lenke til innlegg
Del på andre sider

Bli med i samtalen

Du kan publisere innhold nå og registrere deg senere. Hvis du har en konto, logg inn nå for å poste med kontoen din.

Gjest
Skriv svar til emnet...

×   Du har limt inn tekst med formatering.   Lim inn uten formatering i stedet

  Du kan kun bruke opp til 75 smilefjes.

×   Lenken din har blitt bygget inn på siden automatisk.   Vis som en ordinær lenke i stedet

×   Tidligere tekst har blitt gjenopprettet.   Tøm tekstverktøy

×   Du kan ikke lime inn bilder direkte. Last opp eller legg inn bilder fra URL.

×
×
  • Opprett ny...