Jump to content
  • Sign Up
Støtt hjemmeautomasjon.no!

Homely integration


kolaf

Recommended Posts

SumMarius skrev (9 timer siden):

Finner ikke noe slikt. Jeg er sikkert litt dum. Vil ha ting plug'n'play helst.

Får masse som published men finner ikke noe configuration. Hvilke logger skal jeg lete i? MQTT loggen i HA eller noen logger i docker?

 

 

[16:02:14.680] DEBUG (1): Marked Contact as published
[16:02:14.722] DEBUG (1): Marked Tamper as published
[16:02:14.751] DEBUG (1): Marked Battery low as published
[16:02:14.769] DEBUG (1): Marked Battery voltage as published
[16:02:14.790] DEBUG (1): Marked Networklink address as published
[16:02:14.812] DEBUG (1): Marked Networklink strength as published
[16:02:14.833] DEBUG (1): Marked Temperature as published
[16:02:14.874] DEBUG (1): Marked Contact as published
[16:02:14.909] DEBUG (1): Marked Tamper as published
[16:02:14.929] DEBUG (1): Marked Battery low as published
[16:02:14.950] DEBUG (1): Marked Battery voltage as published
[16:02:14.968] DEBUG (1): Marked Networklink address as published
[16:02:14.989] DEBUG (1): Marked Networklink strength as published
[16:02:15.007] DEBUG (1): Marked Temperature as published
[16:02:15.025] DEBUG (1): Marked Fire as published
[16:02:15.048] DEBUG (1): Marked Battery low as published
[16:02:15.070] DEBUG (1): Marked Battery voltage as published
[16:02:15.088] DEBUG (1): Marked Networklink address as published
[16:02:15.124] DEBUG (1): Marked Networklink strength as published
[16:02:15.146] DEBUG (1): Marked Temperature as published
[16:02:15.165] DEBUG (1): Marked Fire as published
[16:02:15.183] DEBUG (1): Marked Battery low as published
[16:02:15.201] DEBUG (1): Marked Battery voltage as published
[16:02:15.221] DEBUG (1): Marked Networklink address as published
[16:02:15.241] DEBUG (1): Marked Networklink strength as published
[16:02:15.264] DEBUG (1): Marked Temperature as published
[16:02:15.283] DEBUG (1): Marked Fire as published
[16:02:15.301] DEBUG (1): Marked Battery low as published
[16:02:15.321] DEBUG (1): Marked Battery voltage as published
[16:02:15.350] DEBUG (1): Marked Networklink address as published
[16:02:15.373] DEBUG (1): Marked Networklink strength as published
[16:02:15.394] DEBUG (1): Marked Temperature as published
[16:02:15.412] DEBUG (1): Marked Motion as published
[16:02:15.431] DEBUG (1): Marked Tamper as published
[16:02:15.451] DEBUG (1): Marked Battery defect as published
[16:02:15.492] DEBUG (1): Marked Battery low as published
[16:02:15.510] DEBUG (1): Marked Battery voltage as published
[16:02:15.530] DEBUG (1): Marked Networklink address as published
[16:02:15.550] DEBUG (1): Marked Networklink strength as published
[16:02:15.568] DEBUG (1): Marked Temperature as published
[16:02:15.589] DEBUG (1): Marked Motion as published
[16:02:15.618] DEBUG (1): Marked Tamper as published
[16:02:15.644] DEBUG (1): Marked Battery defect as published
[16:02:15.672] DEBUG (1): Marked Battery low as published
[16:02:15.713] DEBUG (1): Marked Battery voltage as published
[16:02:15.731] DEBUG (1): Marked Networklink address as published
[16:02:15.760] DEBUG (1): Marked Networklink strength as published
[16:02:15.781] DEBUG (1): Marked Temperature as published
[16:02:15.802] DEBUG (1): Marked Contact as published
[16:02:15.826] DEBUG (1): Marked Tamper as published
[16:02:15.858] DEBUG (1): Marked Battery low as published
[16:02:15.879] DEBUG (1): Marked Battery voltage as published
[16:02:15.899] DEBUG (1): Marked Networklink address as published
[16:02:15.921] DEBUG (1): Marked Networklink strength as published
[16:02:15.940] DEBUG (1): Marked Temperature as published
[16:02:15.958] DEBUG (1): Marked Gateway as published

Link to comment
Share on other sites

Her er litt info :

 

RauchWohn homely Fire (binary_sensor.rauchwohn_homely_fire)
MQTT discovery data:
Topic: homeassistant/binary_sensor/edeffb64-fac3-4f02-845e-6f5ea98bdb0f/fire/config
Payload
device:
  identifiers:
    - edeffb64-fac3-4f02-845e-6f5ea98bdb0f
  name: RauchWohn
  sw_version: 1
  model: Intelligent Smoke Alarm
  manufacturer: Homely
  hw_version: 1
  suggested_area: Floor 1 - Wohnzimmer
unique_id: edeffb64-fac3-4f02-845e-6f5ea98bdb0f_fire
name: homely Fire
device_class: smoke
unit_of_measurement: null
state_class: null
command_topic: null
config_topic: homeassistant/binary_sensor/edeffb64-fac3-4f02-845e-6f5ea98bdb0f/fire/config
availability_topic: homeassistant/edeffb64-fac3-4f02-845e-6f5ea98bdb0f/online
state_topic: homeassistant/edeffb64-fac3-4f02-845e-6f5ea98bdb0f/fire/state
platform: mqtt
Subscribed topics:
homeassistant/edeffb64-fac3-4f02-845e-6f5ea98bdb0f/online
7 most recently received message(s)
homeassistant/edeffb64-fac3-4f02-845e-6f5ea98bdb0f/fire/state
0 most recently received message(s)

 

 

Som du ser, de kommer aldri en message ang. 'fire/state'

 

Link to comment
Share on other sites

howi skrev (4 timer siden):

 

 

Som du ser, de kommer aldri en message ang. 'fire/state'

 

Ikke noen config message på fire her heller, kanskje den som stopper videre import av enheter? Hvordan får jeg fjernet alle enheter og legge de til på nytt?

Finner config under home-assistant, ingen under Homely topic.

Edited by SumMarius
Utfyllende info
Link to comment
Share on other sites

howi skrev (11 timer siden):

Når jeg tester dette, sletter jeg alle enheter i HA og starter imagen på nytt.

 

Har nå fått testet. Stopper opp etter å ha lagt inn Brannvarsler.

 

Ser på MQTT Explorer at den ikke legger inn fire som sensor på HA. Den ligger i Homely

image.thumb.png.11f5a883454698b10ef23b5085def848.png

Edited by SumMarius
Link to comment
Share on other sites

Litt mer info :

Alle mine devices er der, inkludert hjemmesentralen ( den rekken i midten , fra ede ........ til  465......).

Bare 4 devices i containeren blir til en device i HA ( de 4 under binary_sensor), til de kommer det også config-messages

3 dukker opp under sensor ( helt oppe ), også med config-messages

 

Screenshot 2024-02-19 095334.png

Link to comment
Share on other sites

Det ser ut til å være for mange publiseringer på en gang, slik at et eller annet dropper resten. Dersom jeg fikser entities/create-entities-mqtt.js slik at den faktisk tester på hvorvidt en entitet er publisert før eller ei så kan jeg i sqlite-fila skru av published-flagget for en og en device (to virket også) og så ramler de inn uavhengig av type. Så om koden endres til å publisere med litt delay mellom hver så tipper jeg det fungerer bedre.

 

OK 

Link to comment
Share on other sites

9 minutes ago, OKO said:

Det ser ut til å være for mange publiseringer på en gang, slik at et eller annet dropper resten. Dersom jeg fikser entities/create-entities-mqtt.js slik at den faktisk tester på hvorvidt en entitet er publisert før eller ei så kan jeg i sqlite-fila skru av published-flagget for en og en device (to virket også) og så ramler de inn uavhengig av type. Så om koden endres til å publisere med litt delay mellom hver så tipper jeg det fungerer bedre.

 

OK 

 

Det kan gi mening ja. Muligens ett problem med mqtt-brokeren som sliter e.l? Jeg har skrevet ett lass med tester lokalt der alt virker fint, og når jeg publiserer hos meg virker alt greit, men jeg har en veldig over-specced server. Kan prøve å få lagt inn en delay på det, og eventuelt se om jeg har en måte å verifisere mottak/lest på ett vis. 

Link to comment
Share on other sites

Jeg finner ingen system med disse problemene.

HA kjører på en enkelt NUC, som har lite å gjøre, ifølge målingene.

Docker image kjører enten på en PI3 eller en dualcore Intel system, resultat er det samme.

 

Alltid de samme 4 enhetene dukker opp som devices i HA, alle andre kan jeg se i MQTT Explorer, men de kommer aldri med en config message.

 

Kjører jeg kolaf sin integrasjon, dukker alle røykvarslerne opp ( ikke Heat Sensor ) , men ingenting annet.

Link to comment
Share on other sites

3 minutes ago, howi said:

Jeg finner ingen system med disse problemene.

HA kjører på en enkelt NUC, som har lite å gjøre, ifølge målingene.

Docker image kjører enten på en PI3 eller en dualcore Intel system, resultat er det samme.

 

Alltid de samme 4 enhetene dukker opp som devices i HA, alle andre kan jeg se i MQTT Explorer, men de kommer aldri med en config message.

 

Kjører jeg kolaf sin integrasjon, dukker alle røykvarslerne opp ( ikke Heat Sensor ) , men ingenting annet.

 

Ja, jeg sier ikke at det er det som skjer, bare at det kan hende. En annen tanke er om noe annet plukker opp meldingen. Tidligere har jeg kjørt entity-oppretting med qos = 2 som betyr at en melding kan leses nøyaktig 1 gang. Bygget ut nytt image nå som gjør to ting:

- Setter qos = 1

- Har en forsinkelse på 300ms mellom publisering av hver entitet, noe som bør være plenty tid til at det plukkes opp 🙂

 

Forhåpentligvis så ordner det problemene noen av dere har opplevd. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.