Jump to content
  • Sign Up
Støtt hjemmeautomasjon.no!

Altibox oppsett med egen ruter/brannvegg - hva skal til?


espenvp

Recommended Posts

Har sett mange kompliserte og uforklarlige oppsett her og på ulike forum rundt om. Skal derfor prøve å avmystifisere og forklare enkelt hva som skal til for å få egen ruter og IPTV til å fungere sammen med Altibox:

Som de fleste vet kommer det inn tre vlan på en "trunk" fra Altibox. En trunk er en kabel med flere virtuelle nettverk over samme kabel, i dette tilfellet altibox sine tre nett, hhv: administrasjon, IPTV og Internett.

 

Det vi trenger å gjøre er å splitte disse fra hverandre. Hvorfor det? jo for å slippe å sende IPTV trafikken gjennom brannveggen/ruteren. IPTV trafikken fra Altibox er så kalt "walled garden" et lukket nett som kun gir IPTV tjenesten ut til sine kunder. Det er sløsing av brannvegg kapasitet, unødvendig kompliserende og det gir ingen økt sikkerhet.

 

Men for å kunne ta disse inn må vi først kunne terminere fiberen i en switch. Switchen må ha SFP port for å koble til BiDi (bi-directional) optikk. BiDi optikk sender både RX og TX på samme fibertråd - på hver sine bølgelengder. Hos Altibox bruker de 1310nm (TX) og 1550nm (RX). Disse SFP'ene fås kjøpt på nett til ca 3-400kr.

Når man har fått inn denne trunken i en switch lager man vlan 101 og 102 og fordeler disse hhv til IPTV og Internett. TV dekoderen(e) din(e) kan da plasseres direkte i vlan 101. Husk å aktivere "igmp snooping" og "igmp snooping querrier" på switchen (globalt eller i vlan 101 - kommer an på hvordan dette settes opp på din switch). Dette er essentielt for at IPTV multicast skal fungere. Hvis ikke dette settes opp riktig vil Live TV stoppe opp etter en liten stund. Ukesarkiv og on-demand innhold vil uansett fungere da det ikke er multicast.

 

Videre plasserer du din nye brannvegg eller ruter med sin WAN port i vlan 102. På innsiden av brannvegg/ruter kan du gjøre hva du vil 😍

 

Legger ved en tegning som forklarer litt hvordan ting henger sammen.

altibox.png

Edited by espenvp
korrigering
  • Like 4
  • Thanks 2
Link to comment
Share on other sites

On 09/07/2021 at 00:10, espenvp said:

Disse SFP'ene fås kjøpt på nett til ca 3-400kr.

Vil anbefale fs.com.  Null tull, rask leveranse og gode produkter.  https://www.fs.com/de-en/products/39135.html Velg evt "customised" hvis du vil ha SC-konnektor (slik Altibox bruker)

 

Har du en VMG hjemmesentral kan du jo også bare bruke den SFPen som står i der.

On 09/07/2021 at 00:10, espenvp said:

Når man har fått inn denne trunken i en switch lager man vlan 101 og 102 og fordeler disse hhv til IPTV og Internett. TV dekoderen(e) din(e) kan da plasseres direkte i vlan 101.

Dette er dessverre ikke korrekt lenger for kunder som er oppgradert til nyere hjemmesentraler.  Altibox aktiverer da et macadresse-filter, enten på DHCP-server eller et annet sted i nettet, som blokkerer direkte tilgang fra dekoderne.  Hvis du har en slik løsning fra Altibox så du ha en router mellom dekoder og VLAN 101.  Denne routeren må nødvendigvis kjøre igmpproxy for at multicast/linjær-TV skal virke.

 

Det er litt uklart hvilke mac-adresser som blir akseptert av filteret.  Det eneste som er sikkert er at det blokkerer dekoderne. Det enkleste er å bare spoofe adressen som står på hjemmesentralen.

 

Ja, jeg vet at dette virker rart og helt ubegripelig.  Jeg var også lykkelig uvitende om det med en løsning som den du skisserer, inntil jeg fikk prakket på meg en VMG fra Altibox.  Da sluttet TVen å virke når jeg koblet tilbake til min egen løsning, fordi dekoderen ikke lenger fikk noen ip-adresse fra Altibox.

 

Så unngå for all del å oppgradere hjemmesentralen dersom du har en slik løsning med switching av VLAN 101.  Da beholder du fleksibiliteten.

  • Like 1
Link to comment
Share on other sites

Quote

Dette er dessverre ikke korrekt lenger for kunder som er oppgradert til nyere hjemmesentraler.  Altibox aktiverer da et macadresse-filter, enten på DHCP-server eller et annet sted i nettet, som blokkerer direkte tilgang fra dekoderne.  Hvis du har en slik løsning fra Altibox så  du ha en router mellom dekoder og VLAN 101.  Denne routeren må nødvendigvis kjøre igmpproxy for at multicast/linjær-TV skal virke.

Vel, jeg skal ikke påstå at dette virker sånn for alle Altibox partnere rundt om i landet, men dette har fungert hos meg siden jeg satt det opp i Februar i år. Min leverandør er Bergen Fiber. Det virker dog uforståelig at de skal mac-filterere sine egne IPTV-bokser, det er jo disse de skal levere et produkt til.

 

PS: jeg også har også blitt tildelt VMG ruter, brukte den i kanskje ett døgn før den gikk i "arkivet".

Link to comment
Share on other sites

8 minutes ago, espenvp said:

Vel, jeg skal ikke påstå at dette virker sånn for alle Altibox partnere rundt om i landet, men dette har fungert hos meg siden jeg satt det opp i Februar i år. Min leverandør er Bergen Fiber. Det virker dog uforståelig at de skal mac-filterere sine egne IPTV-bokser, det er jo disse de skal levere et produkt til.

 

PS: jeg også har også blitt tildelt VMG ruter, brukte den i kanskje ett døgn før den gikk i "arkivet".

Interessant.  Da forsvant resten av systemet. Ja, det er helt uforståelig.

 

Jeg har Viken Fiber og har hatt det siden 2012. De første årene med en ZyXEL P2812 som hjemmesentral og en 100 Mbit mediakonverter fra Ping. Ca 2015(?) oppgraderte de til gigabit (vi snakker link-hastighet nå, ikke produkt) og vi fikk da en HET-3012 dual-rate 100/1000 media-konverter.  Da benyttet jeg sjansen til å erstatte hjemmesentral og mediakonverter med et oppsett temmelig likt tegningen din. Det fungerte helt fint i 5 år, inkludert flytting av hele opplegget til en annen leilighet

 

Men i januar i fjor fikk vi pushet på oss en VMG i stedet for HET+P2812 som en del av borettslagets fellesavtale.  Jeg forsøkte meg på å bytte eske mot eske, siden jeg helst så at jeg slapp å demontere mitt fungerende nettverk.  Montøren ble litt overrasket og måtte ta en telefon for å sjekke om det var OK, men det endte med at han måtte skru opp VMGen på veggen og koble den til. Bortkastet men greit nok, tenkte jeg.  Overraskelsen var stor når jeg koblet tilbake til mitt utstyr, og TVen ikke lenger virket.  Snooping avslørte at dekoderen ikke fikk noen ip-adresse. Koblet inn VMG og alt virket.  Kjørte dhclient manuelt på VLAN 101 fra en Linux-PC med VMGens mac - og det fungerte.  Prøvde dhclient med en annen mac - og det fungerte.  Prøve dhclient med dekoderens mac - fungerte ikke.

 

Jeg ser ingen annen forklaring enn at Viken har lagt på et filter for å blokkere direkte bruk av dekoder på VLAN 101. De har sikkert en grunn som gir mening for dem.

 

Jeg endte opp med et betydelig mer komplisert oppsett for å oppnå det samme jeg hadde før:  TV-dekoder isolert på sitt eget lille VLAN.  Det krever nå en router med igmpproxy mellom dekoder-VLAN og (Vikens) VLAN 101.  Routeren bruker en mac-adresse som ligner på VMG, men er slightly forskjellig (slik at jeg skal kjenne den igjen)

 

Samboer skaffet seg nylig hytte med VIken fiber også, men der har vi ikke TV så jeg får ikke testet om det er samme opplegg.  Men der fikk jeg ihvertfall testet gjenbruk av SFP fra VMGen.  Den funket helt fint i en ZyXEL GS1900-10HP switch (med OpenWrt - har ikke prøvd med original firmware, men jeg vil tro det virker).

  • Like 1
Link to comment
Share on other sites

Med de nye dekoderne må det litt mer magi til - det er noen ting som skal rutes andre veier enn bare å ha vlan101 rett gjennom.

Det er sikkert flere måter å gjøre det på, men det som ihvertfall virker å gjøre det slik Altibox selv gjør det, vha dhcp options.

/ip dhcp-client option
  add code=60 name=vendor-class-identifier value=0x564d47383832352d42353042
  /ip dhcp-server option
  add code=43 name=q22 value=\
  "'Altibox-TMS-Server-Address:https://tmc.services.altibox.net:37020/acs'"

 

 

jeg har kopiert deler av oppsettet for mikrotik fra dette github-repoet
https://github.com/trrunde/routerconfig

, og det har fungert prikkfritt i et halvt år nå.

Oppsettet er fiber rett i en HAP AC via en 1310/1550nm bidi SFP, og så trunk opp til nok en HAP AC. En untagged vlan101-port i begge HAP AC'ene med en dekoder i hver.

Det eneste man skal være ops på er at førstegangsautentisering/aktivering av de nye dekoderne enten må gjøres via altibox-router, eller du kan ringe inn og aktivere dem. 

Edited by quackyo
Link to comment
Share on other sites

  • 1 month later...
ahattest skrev (19 timer siden):

Forstår at det stort sett er mikrotik eller ubiquiti som er veien å gå?

Jeg har Dream Machine Pro fra Ubiquiti, og har lest side opp og side ned med forum og dokumentasjon. Jeg har ikke nok kompetanse på nettverksoppsett på dette nivået til å eksperimentere, men mangelen på relativt-rett-frem oppsett gjør meg veldig usikker på om dette lar seg gjøre med DMP'en min.

 

Se https://community.ui.com/questions/IGMPv3-Support/747a1b8f-7c79-4ae5-b44c-2beb85e37772 og https://community.ui.com/questions/IPTV-IGMP-Proxy-managed-by-Unifi-controller/c617c208-ad2a-41bb-8cee-488f19c3c625 (og mange andre lenker til samme utfordringer.)

 

Jeg løser dette med Altibox sin ruter i bromodus. Da går internett trafikken (vlan102) ut på Lan4 porten. Du har da 3 andre porter du kan bruke til tv-dekodere (jeg har foreløpig bare en). Dette er da "amatørmodus", men virker som jeg må holde meg der til noen kommer med en oppskrift 🙂 

 

For dere nettverksguruene som lurer på hvorfor en amatør investerer i Ubiquiti, så er det grunnet behovet for mange Wifi-klienter når husprosjektet er ferdig.  Det blir mange Shelly releer i veggene, og de er alle på Wifi.

Link to comment
Share on other sites

20 hours ago, ahattest said:

Kan noen anbefale en switch til dette bruket? Forstår at det stort sett er mikrotik eller ubiquiti som er veien å gå?

Kommer an på hva du vil gjøre og hva du ellers ser for deg av utstyr.  Det meste som er managed og takler en bidi-sfp virker jo.

 

Jeg bruker en Cisco WS-C3560CX-12PD-S hjemme og en ZyXEL GS1900-10HP på hytta.

Link to comment
Share on other sites

3 hours ago, evest said:

Jeg har Dream Machine Pro fra Ubiquiti, og har lest side opp og side ned med forum og dokumentasjon. Jeg har ikke nok kompetanse på nettverksoppsett på dette nivået til å eksperimentere, men mangelen på relativt-rett-frem oppsett gjør meg veldig usikker på om dette lar seg gjøre med DMP'en min.

 

Se https://community.ui.com/questions/IGMPv3-Support/747a1b8f-7c79-4ae5-b44c-2beb85e37772 og https://community.ui.com/questions/IPTV-IGMP-Proxy-managed-by-Unifi-controller/c617c208-ad2a-41bb-8cee-488f19c3c625 (og mange andre lenker til samme utfordringer.)

 

Jeg løser dette med Altibox sin ruter i bromodus. Da går internett trafikken (vlan102) ut på Lan4 porten. Du har da 3 andre porter du kan bruke til tv-dekodere (jeg har foreløpig bare en). Dette er da "amatørmodus", men virker som jeg må holde meg der til noen kommer med en oppskrift 🙂 

 

For dere nettverksguruene som lurer på hvorfor en amatør investerer i Ubiquiti, så er det grunnet behovet for mange Wifi-klienter når husprosjektet er ferdig.  Det blir mange Shelly releer i veggene, og de er alle på Wifi.

 

Fordelen med mitt forslag er at man unngår å bruke DreamMachinen til TV innhold, den skal bare være brannvegg/ruter for internett-trafikken og ferdig med det, da slipper du å sette opp komplisert ruting og multicast på dreammachinen mot IPTV tjenesten til Altibox. TV signalene "switches" direkte til dekoderen over vanlig nettverkskabel - og ferdig med det. Det var det som var hele hensikten med denne posten, å forenkle og avmystifisere det å bruke egen ruter som Altibox kunde.

Edited by espenvp
typo
Link to comment
Share on other sites

2 hours ago, Bjørn Mork said:

Kommer an på hva du vil gjøre og hva du ellers ser for deg av utstyr.  Det meste som er managed og takler en bidi-sfp virker jo.

 

Jeg bruker en Cisco WS-C3560CX-12PD-S hjemme og en ZyXEL GS1900-10HP på hytta.

 

Jeg vil egentlig bare prøve løsningen skissert i 1. post, så en switch med 4-5 porter + Sfp bør dekke dette behovet.
Kan f.eks. denne brukes? Mikrotik CSS610-8G-2S+IN | Dustinhome.no eller blir den for spinkel?

Jeg tenker å legge opp 2-3 ubiquiti-AP etterhvert, type ruter har jeg ikke bestemt meg for . Akkurat hvilke modeller jeg bør satse på vet jeg ikke, men ønsker noe stabilt jeg slipper å tenke på etter at det er installert.

 

Link to comment
Share on other sites

espenvp skrev (21 minutter siden):

Det var det som var hele hensikten med denne posten, å forenkle avmystifisere det å bruke egen ruter som Altibox kunde.

Jeg misforsto. Tror jeg. Trodde jeg kunne klare meg med bare DMP'en, kjøre fiberen rett i den, og koble tv-boksene til Altibox i DMP'en (evt. en switch som henger på DMP'en).

Link to comment
Share on other sites

4 minutes ago, ahattest said:

 

Jeg vil egentlig bare prøve løsningen skissert i 1. post, så en switch med 4-5 porter + Sfp bør dekke dette behovet.
Kan f.eks. denne brukes? Mikrotik CSS610-8G-2S+IN | Dustinhome.no eller blir den for spinkel?

Jeg tenker å legge opp 2-3 ubiquiti-AP etterhvert, type ruter har jeg ikke bestemt meg for . Akkurat hvilke modeller jeg bør satse på vet jeg ikke, men ønsker noe stabilt jeg slipper å tenke på etter at det er installert.

 

Det står ikke eksplisitt at den støtter igmp-snooping som er "the magic sauce" her, men jeg vil regne med den har det. Det er standard på de fleste switcher over 1000 kr.

Link to comment
Share on other sites

5 minutes ago, evest said:

Jeg misforsto. Tror jeg. Trodde jeg kunne klare meg med bare DMP'en, kjøre fiberen rett i den, og koble tv-boksene til Altibox i DMP'en (evt. en switch som henger på DMP'en).

Du _kan_ gjøre det, men det krever litt avansert konfigurasjon for et utrent øye. Videre kan slik hardkoding av IP ruter på sikt slutte å virke (når altibox bestemmer seg for å gjøre endringer i løsningen sin). Derfor mener jeg det er bare fordeler med å skille IPTV løsningen utenfor brannvegg/ruter og la "tuner" boksen snakke direkte med Altibox. Da overlater man transport av TV signalet til Altibox, men har full kontroll over sin egen brannvegg til internett surfingen.

  • Like 2
Link to comment
Share on other sites

  • 3 months later...
9 hours ago, ahattest said:

Har du mulighet til å dele config fra cisco-switchen din? 

Kan jo det, men du blir nok skuffet.  Den er bare en switch og den eneste funksjonen den har ifm Altibox i mitt nett er som "mediakonverter".  Routingen gjør jeg på en PC med Debian.  Men her er uansett config med de mest private tingenen fjernet.  Altibox linken er på port Gi1/0/16.  PCen som router mellom alle VLANene er på Te1/0/1.  Merk at Ciscos bruk av hastighet i portnavn gir noen pussige effekter.  Gi1/0/15 er samme port som Te1/0/1 og Gi1/0/16 er samme port som Te1/0/2. Hvilket navn som er gyldig er avhengig av om det står en SFP eller SFP+ i porten.

 

!
config-register 0xF
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service unsupported-transceiver
!
hostname c3560cx
!
boot-start-marker
boot-end-marker
!
!enable password <removed>
!
!username <removed> 
aaa new-model
!
aaa authentication login default group radius local
aaa authentication enable default group radius enable
aaa authorization exec default group radius none 
!
aaa session-id common
switch 1 provision ws-c3560cx-12pd-s
system mtu routing 1500
!
ip domain-name <removed> 
ip name-server 192.168.99.1
!
!crypto pki <removed>
!
!crypto pki <removed>
!
spanning-tree mode pvst
spanning-tree extend system-id
no spanning-tree vlan 42,77
!
vlan internal allocation policy ascending
!
lldp run
!
interface Bluetooth0
 no ip address
 downshift disable
!
interface GigabitEthernet1/0/1
 description gs108tv3
 switchport trunk allowed vlan 37,100
 switchport trunk native vlan 37
 switchport mode trunk
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/2
 description wrt1900ac
 switchport trunk allowed vlan 1,7-9,13,90,203
 switchport mode trunk
!
interface GigabitEthernet1/0/3
 description Stue
 switchport trunk allowed vlan 1,7-9,22,101,103,203
 switchport mode trunk
 flowcontrol receive desired
!
interface GigabitEthernet1/0/4
 description Loft
 switchport trunk allowed vlan 1,7-9,22,101,203
 switchport mode trunk
 flowcontrol receive desired
!
interface GigabitEthernet1/0/5
 description Soverom
 switchport trunk allowed vlan 1,7-9,13,203
 switchport mode trunk
!
interface GigabitEthernet1/0/6
 description "oob canardo"
 switchport access vlan 203
 switchport mode access
!
interface GigabitEthernet1/0/7
 description 'Telenor uplink'
 switchport access vlan 90
 switchport mode access
!
interface GigabitEthernet1/0/8
 description 'apc7920'
 switchport access vlan 203
 switchport mode access
!
interface GigabitEthernet1/0/9
 description "Kjellerstue left"
 switchport access vlan 7
 switchport mode access
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/10
 description "Kjellerstue right"
 switchport access vlan 7
 switchport mode access
 spanning-tree portfast edge
!
interface GigabitEthernet1/0/11
 description finn
 switchport access vlan 234
 switchport mode access
!
interface GigabitEthernet1/0/12
 description lte5398
 switchport access vlan 235
 switchport mode access
!
interface GigabitEthernet1/0/13
 description Spisestue
 switchport access vlan 7
 switchport mode access
!
interface GigabitEthernet1/0/14
 description mirrorport
 switchport access vlan 15
 switchport mode access
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
 description 'Altibox uplink'
 switchport trunk allowed vlan 100-102
 switchport trunk native vlan 77
 switchport mode trunk
 no cdp enable
 no lldp transmit
 spanning-tree bpdufilter enable
!
interface TenGigabitEthernet1/0/1
 description 'canardo'
 switchport trunk native vlan 10
 switchport mode trunk
 flowcontrol receive desired
!
interface TenGigabitEthernet1/0/2
!
interface Vlan1
 no ip address
!
interface Vlan203
 description Management
 ip address 192.168.99.59 255.255.255.0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip scp server enable
!
logging trap debugging
logging host 192.168.99.1
access-list 60 permit 10.4.0.2
access-list 60 permit 148.122.252.1
access-list 60 permit 192.168.3.1
access-list 60 permit 192.168.99.0 0.0.0.255
access-list 60 deny   any log
!
!snmp-server community <removed> 
!snmp-server community <removed> 
snmp-server trap-source Vlan203
snmp-server location Kjellerboden
!snmp-server contact <removed> 
snmp mib flash cache
!
radius server canardo
 address ipv4 192.168.99.1 auth-port 1812 acct-port 1813
! key  <removed> 
!
line con 0
line vty 0 4
 transport input ssh
line vty 5 15
 transport input ssh
!
ntp source Vlan203
ntp server 192.168.99.1
netconf ssh
netconf-yang
!
end

 

Link to comment
Share on other sites

  • 5 months later...
espenvp skrev (På 9.7.2021 den 0.10):

Har sett mange kompliserte og uforklarlige oppsett her og på ulike forum rundt om. Skal derfor prøve å avmystifisere og forklare enkelt hva som skal til for å få egen ruter og IPTV til å fungere sammen med Altibox:

Som de fleste vet kommer det inn tre vlan på en "trunk" fra Altibox. En trunk er en kabel med flere virtuelle nettverk over samme kabel, i dette tilfellet altibox sine tre nett, hhv: administrasjon, IPTV og Internett.

 

Det vi trenger å gjøre er å splitte disse fra hverandre. Hvorfor det? jo for å slippe å sende IPTV trafikken gjennom brannveggen/ruteren. IPTV trafikken fra Altibox er så kalt "walled garden" et lukket nett som kun gir IPTV tjenesten ut til sine kunder. Det er sløsing av brannvegg kapasitet, unødvendig kompliserende og det gir ingen økt sikkerhet.

 

Men for å kunne ta disse inn må vi først kunne terminere fiberen i en switch. Switchen må ha SFP port for å koble til BiDi (bi-directional) optikk. BiDi optikk sender både RX og TX på samme fibertråd - på hver sine bølgelengder. Hos Altibox bruker de 1310nm (TX) og 1550nm (RX). Disse SFP'ene fås kjøpt på nett til ca 3-400kr.

Når man har fått inn denne trunken i en switch lager man vlan 101 og 102 og fordeler disse hhv til IPTV og Internett. TV dekoderen(e) din(e) kan da plasseres direkte i vlan 101. Husk å aktivere "igmp snooping" og "igmp snooping querrier" på switchen (globalt eller i vlan 101 - kommer an på hvordan dette settes opp på din switch). Dette er essentielt for at IPTV multicast skal fungere. Hvis ikke dette settes opp riktig vil Live TV stoppe opp etter en liten stund. Ukesarkiv og on-demand innhold vil uansett fungere da det ikke er multicast.

 

Videre plasserer du din nye brannvegg eller ruter med sin WAN port i vlan 102. På innsiden av brannvegg/ruter kan du gjøre hva du vil 😍

 

Legger ved en tegning som forklarer litt hvordan ting henger sammen.

altibox.png

Hvilken switch bruker du?

Link to comment
Share on other sites

  • 3 months later...

Hei. 

 

Når man skal dele opp Vlan 101, 102, 102 fra SPF port, kan man gjøre dette i en ruter som TP-Link ER7206 Omada?

deretter koble denne sammen med en Tp link switch med Omada og assigne forskjellige vlan til forskjellige porter? 

Slik at man slipper switch med SFP og heller deler denne innad i ruteren?

 

image.thumb.png.f94d9f99cce37bda3c467fdfb7047428.png

 

 

Link to comment
Share on other sites

Jeg kikket raskt på spec-en og blir skeptisk når de skal kobles til en skytjeneste. Jeg vet ikke om det er påkrevet, men bare det at det nevnes gir meg frysninger på ryggen. Jeg bruker en MikroTik CCR1009-7G-1S+ mot Altibox, og med den styrer jeg separate nett for eget bruk, IoT, DMZ og leietaker. Den leverer glatt også IPv6 i Altibox sitt nett. Det finnes veiledninger hvordan du setter opp denne mot Altibox i forskjellige forum, bl.a. denne https://freak.no/forum/showthread.php?t=313333 

MikroTik har også andre modeller som er egnet til dette bruket.

Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

Hei. Jeg sliter...

 

Jeg bruker D-Link DGS-1210-24 med SFP mot Bergen fiber, men får ikke "tak i" multicast-pakkene.

Jeg tagger vlan 101 og 102 på SFP-porten og har satt opp to u-taggede vlan 101 porter til TV-boksene og en u-tagget port for mitt WAN-IF på brannmur. Vanlig internet trafikk går "så det suser".

IGMP Snooping er enablet for vlan 101 med "Querier State" enablet. 

 

Huawei TV-boksene (Q22) får ikke DHCP hvis de står i vlan 101-porter på D-Link. 

 

Hvis jeg kjører WAN tilbake (tagget 101 og 102) til hjemmesentralen (FMG3542) (via D-Link) får jeg ut multicast på port 1 og 2 på hjemmesentralen og IPTV virker.

Jeg kan også se at jeg får en dynamisk IGMP gruppe på vlan 101 på D-Link med multicast MAC-adresse.

 

Problemet er at jeg ønsker å kutte ut hjemmesentralen bl.a for å få HBO MAX og tilsvarende til å fungere på TV-boksene.
Slik jeg har det nå får jeg jo bedre utnyttelse av fiberen men må altså via hjemmesentralen igjen for IPTV...

 

Jeg lurer på om D-Link switchen kan brukes, eller om det er en instilling jeg ikke har fått med meg.

 

Håper at noen har noen tips/forklaring...

 

Hilsen Georgh

Edited by georgh
Skrev router, mente switch
Link to comment
Share on other sites

Tell skrev (På 24.10.2022 den 15.39):

@iotux, hvilket oppsett har du på MikroTik'en for Altibox? Bruker du også Altibox sin IPTV? Får du IP på VLAN 101?

For ordens skyld: Jeg ordnet IP-tildeling på VLAN 101 ved å klone MAC-adressen fra Altibox’ originale hjemmesentral. Presto!

 

Jeg opplevde også problemer med at lineær IPTV stanset opp i løpet av et halv minutts tid. Dette løste seg ved å legge til en brannmurregel som tillot trafikk innkommende fra 101-grensesnittet til LAN.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...