Jump to content
  • Sign Up
Støtt hjemmeautomasjon.no!

Energi dashboard i Home Assistant


Recommended Posts

Jeg fant ut jeg ville gjøre noe med dette selv og her er min løsning:

Jeg har laget en mal-sensor som dette
 

template:
  - trigger:
      - platform: time_pattern
        minutes: 59
        seconds: 55
    sensor:
      - unique_id: d0edb519-03b2-4848-9b86-ac39bb4d5a90
        name: klepp_energi_total_energi_denne_time
        state_class: total_increasing
        unit_of_measurement: kWh
        device_class: energy
        state: "{{ (float(states('sensor.klepp_energi_total_energi')) + float(states('sensor.energy')))|round(3) }}"


Så har jeg satt opp energy dashboard til å bruke denne nye sensoren.
 

Det som skjer er at 5 sekund før hver hele time blir denne sensoren satt til forrige times kWh teller som rapportert i fra måleren pluss timesforbruk som min HAN leser genererer ut i fra effekt som den integrerer opp. Jeg bruker amsleser. Jeg mener Tibber Pulse også har denne, men er ikke helt sikker. Uansett kan du bruke Home Assistant sin "Integration - Riemann sum integral" til å beregne den.

Løsningen har en svakhet. Det blir ikke helt nøyaktig. Litt skyldes at jeg mangler 5 sekund og litt skyldes at amsleser ikke er helt nøyaktig. Men avviket er stort sett innenfor 10-20Wh. Det er ikke mye og for meg en bedre løsning enn å ha en graf som er forskjøvet. Det positive er at integreringen starter på null hver time så en eventuell feil blir ikke summert opp gjennom hele døgnet.

Dette skrev jeg 12:40 og siste time i grafen er for 11:00 til 12:00
image.png.79fd51f093a63ebcd5d6391dc41f750f.png

Link to comment
Share on other sites

Interessant løsning og god feature request.

 

Jeg bruker primært InfluxDB til historiske strømdata og følger ikke så mye med på Energy dashboardet i Home Assistant. Ser ut som at Energy i HA matcher veldig godt opp mot InfluxDB og web-interfacet til min POW-U amsleser time for time, uten forskyvning.

 

Jeg opplevde samme problemet som deg da jeg brukte den totale målerverdien som ble oppdatert rett etter timeskift, men for meg holdt det endre til å bruke akkumulert dagsverdi fra amsleseren som sensor til Grid Consumption i HA. Den oppdateres flere ganger i minuttet, og resetter ganske presist på nytt døgn. Energy dashboardet skjønner automatisk hvordan den skal dele det opp i timesforbruk og dagsforbruk.

 

19 hours ago, stigvi said:

 

Det som skjer er at 5 sekund før hver hele time blir denne sensoren satt til (...)

 

Jeg har hatt noen sånne triggere opp igjennom, men har prøvd å styre unna et sånt design pattern når jeg kan i nyere tid, fordi jeg ikke vil måtte tenke over hva klokka er hvis jeg skal restarte eller oppdatere HA. Hvis man tilfeldigvis har litt nedetid akkurat rundt timeskift, risikerer den å gå glipp av tidspunktet den skulle ha trigget på. Når det er sagt ville jeg også fått en bitteliten feil i Energy hvis jeg restarter rundt timeskift nå.

Link to comment
Share on other sites

@gskjold

For meg er det et lite problem at jeg ikke vet hvordan amsleser kommer fram til dagsforbruket. Jeg ser av timeforbruket at de integrerer opp ved å bruke Riemann summering med "right" som innverdi. Jeg har testet litt med Riemann summering direkte i HA og ser at resultatet av integreringen blir mer nøyaktig med "middle" (eller trapezoidal) innverdi. Har planer om å skrive en feature request og spørre om de kan endre fra "right" til "middle" for å bedre nøyaktigheten.

Når det gjelder dagsforbruket som oppdateres "kontinuerlig", er det da en integrering i 24 timer eller er det integrering i 1 time pluss rapporterte målerverdier fra måleren i de foregående timene. Jeg har kikket bittelitt i koden, men fant det ikke. Hvis de integrerer i 24 timer, ser jeg for meg at dette tallet avviker en del fra det reelle når det nærmer seg slutt på døgnet.

Edited by stigvi
Link to comment
Share on other sites

Jeg fikk vel egentlig svar på det jeg lurte på. Jeg sliter med at amsleser ikke alltid får med seg kwh-teller oppdatering som sendes hver time. Jeg har nettopp byttet til en PowU fra en egenlagd og det samme problemet skjer på begge.

Det som skjedde var at den kontinuerlige telleren for dagsforbruk gikk ned ca 4kWh kl 10:00 og så spratt den opp ca 4kWh klokken 11:00. En ser hoppet mellom melding 49 og 50 nedenfor. Da tyder det på at dagsforbruket er basert på en integrasjon siste time og at resten av døgnets timer er på grunnlag av målerstand.

Det gjør det uansett svært vanskelig å bruke Energy Dashboard i HA. Jeg må egentlig mekke i hop et eller annet selv som tar høyde for at data mangler.

image.png.2711efec93be565e82e246d0afe55f85.png

Link to comment
Share on other sites

Det er mulig jeg har misforstått dette, men jeg har løst problemet med at jeg får en time forsinkelse i HA Dashboard ved å bruke sensor.ams_cf58_houruse. Du kan også sende en mail til strømselskapet å be de rekonfigurere strømmåler til å bruke DLMS data. Mer om dette her: https://github.com/UtilitechAS/amsreader-firmware/issues/630

 

image.png.03a7a51ab407adcd5e44716ee5a080ff.png

Link to comment
Share on other sites

haraldov skrev (2 timer siden):

Du kan også sende en mail til strømselskapet å be de rekonfigurere strømmåler til å bruke DLMS data

Det du linket til, gjelder Karmstrup målere. Jeg har  en Aidon og jeg kikket litt i dokumentasjonen på de. Det ser ikke ut som om de kan konfigureres til å sende noe annet enn det de allerede gjør. Med forbehold om at dokumentet jeg kikket i er foreldet, da.

Link to comment
Share on other sites

On 07/02/2024 at 11:17, stigvi said:

Det som skjedde var at den kontinuerlige telleren for dagsforbruk gikk ned ca 4kWh kl 10:00 og så spratt den opp ca 4kWh klokken 11:00. En ser hoppet mellom melding 49 og 50 nedenfor. Da tyder det på at dagsforbruket er basert på en integrasjon siste time og at resten av døgnets timer er på grunnlag av målerstand.

Det gjør det uansett svært vanskelig å bruke Energy Dashboard i HA. Jeg må egentlig mekke i hop et eller annet selv som tar høyde for at data mangler.
 

 

Jøss, det har jeg ikke oppdaget hos meg.

 

Jeg sleit tidligere med dårlig WiFi-forbindelse til POW-U da den sto i Faraday-buret, og da hadde jeg et grapsete script for å vaske all data for å ta høyde for kræsj osv., nettopp for å unngå at times/dagstelleren resatte/sank på ubeleilige tidspunkt. Laster det opp i tilfelle det er noe der du kan bruke, men pent er det ikke:

 

https://pastebin.com/raw/3sR8zLuQ

 

I korte trekk mellomlagret jeg forrige verdi, sjekket at det er plausibelt at timetelleren skal resette/synke (ca. ved timeskift), og hvis ikke fortsatte den å telle oppover fra mellomlageret verdi. Beregnet dagsforbruk baseres da på det "vaskete" timesforbruket.

Link to comment
Share on other sites

RVM skrev (23 minutter siden):

I korte trekk mellomlagret jeg forrige verdi, sjekket at det er plausibelt at timetelleren skal resette/synke (ca. ved timeskift), og hvis ikke fortsatte den å telle oppover fra mellomlageret verdi. Beregnet dagsforbruk baseres da på det "vaskete" timesforbruket.

Jeg bruker riemann sum integrasjonen i HA sammen med utility integrasjonen som resetter kwh telleren hver time. Da har jeg en kwh teller i HA som teller likt som timestelleren i amsleser. Av disse to bruker jeg max til å hente ut den med størst verdi. Da blir det kun et problem hvis jeg restarter HA i samme time som amsleser har tullet. Jeg ser den tar en omstart innimellom når den står uten usb strøm i skapet utenfor. I løpet av våren skal jeg montere en stikkontakt ute i skapet og flytte pow-u i en plastboks på utsiden av inntaksskapet.

Link to comment
Share on other sites

3 minutes ago, stigvi said:

Jeg ser den tar en omstart innimellom når den står uten usb strøm i skapet utenfor. I løpet av våren skal jeg montere en stikkontakt ute i skapet og flytte pow-u i en plastboks på utsiden av inntaksskapet.

Lurt. Å flytte POW-U til et sted med godt signal og samtidig mate den med strøm over USB fikset alle mine problemer med amsleseren.

Link to comment
Share on other sites

  • 2 weeks later...

Er det noen beskrivelse noe sted om hvordan jeg får data fra AMSleser til HA?

Jeg har bare fylt ut i vilden sky og prøvd å finne igjen noe av det jeg skrev inn ved å søke etter dem i MQTT Explorer uten hell.

Da kan jeg vel gå ut fra at det ikke kom så langt som inn i MQTT broker?

Jeg har lagt inn samme Username og Password som jeg la inn i MQTT Explorer.

 

I AMS Reader får jeg opp verdier som ser fornuftige ut.

AMS.jpg

 

Edit: jeg la merke til at i hovedmenyen på AMSreader står MQTT i grønt. Tenker det betyr at den har kontakt med broker.

Så jeg la inn gal IP og ganske riktig, da ble den rød. Satte den tilbake, og den ble grønn. Altså har jeg ne forbindelse av noe slag.

Da endret jeg Payload fra HomeAssistant til Raw. Og DA dukket den opp med topic AmS_Meter i MQTT Explorer. Men ingenting i HA.

Så tilbake til Payload HomeAssistant, Fortsatt grønn knott MQTT i AMSreader.

Prøvde å følge en danske på Youtube. Men mesteparten av dialogene ser veldig anderledes ut. Antagelig ørten versjoner siden. 

Men jeg prøvde å ape etter som best jeg kan og la inn "amsleser" i topic og Discovery topic . Ingen bedring. Og de endrer seg ikke i MQTT Explorer.

Så fant jeg på å reboote AMSleser. DA kom det en ny topic i MQTT Explorer som heter amsleser. Javel, så enkelte endringer kommer ikke i effekt uten reboot ser det ut til. Men mange endringer skjer uten reboot.
Velvel. Nå ser jeg endringene hele tiden i MQTT Explorer. Og de stemmer med dashboard i AMSleser. 


Men Home Assistant finner den ikke. Og jeg har gått meg så vill i utdaterte og ikke-eksisterende instruksjoner at det er bare flaks om jeg får det til.

 

Hvis ikke noen her kommer med en up to date veiledning da.

 

Edited by Einar
Link to comment
Share on other sites

Einar skrev (5 timer siden):

Er det noen beskrivelse noe sted om hvordan jeg får data fra AMSleser til HA?

 

 

 

Her er mitt oppsett på amsleseren:

amsmqtt.JPG.9ec5a2a57bb165467a4d588ee797278e.JPG

 

Så jeg foreslår å fjerne "hostname for URL" og "Name tag" under HomeAssistant.

 

 

  • Thanks 1
Link to comment
Share on other sites

L-A skrev (7 timer siden):

 

Så jeg foreslår å fjerne "hostname for URL" og "Name tag" under HomeAssistant.

 

 

 

Tratteraaa!
Da har jeg data inn i HA fra AMS leser. Takk for hjelpen!

 

Jeg har vel prøvd det du foreslo før. Men takk for at du sendte meg inn i en ny runde med en annen ting jeg har lært på veien:

REBOOT etter en endring! Enten du har blitt bedt om det eller ikke. 

Eller det kan være at det må være eksakt de ordene du viser her for at det skal virke. Jeg prøvde tidligere med tomme felter. Men jeg hadde vel ikke "ams" som publish topic. Så det kan være at HA ser etter eksakt det "trylleordet". Samma det, for nå virker det. Og jeg håper det vil gjøre det i nyinstallasjon av HA. For nå har den så mye prøv & feil, mest det siste, at det nok er lurt å gå en runde til uten å trykke på alle knapper som stikker ut. 😉

  • Like 1
Link to comment
Share on other sites

Topic navn for mqtt skiller mellom store og små bokstaver. Samtidig er Home Assistant veldig glad i bare små bokstaver, men om det er tilfelle når det gjelder topic, det vet jeg ikke. Men for å ikke friste skjebnen kan det være greit å holde seg til små bokstaver.

@ArnieO
Edit: Store bokstaver i name tag er verre. Her bør amsleser endre koden og kun tillate små bokstaver. Entity navn i HA kan _ikke_ inneholde store bokstaver. Det er noen andre begrensinger også som å ikke bruke mellomrom og helst unngå å starte med et tall.

Edited by stigvi
  • Like 1
Link to comment
Share on other sites

On 23/02/2024 at 19:14, Einar said:

Er det noen beskrivelse noe sted om hvordan jeg får data fra AMSleser til HA?

Javisst!
https://github.com/UtilitechAS/amsreader-firmware/wiki/How-to-add-to-Home-Assistant

On 24/02/2024 at 10:30, stigvi said:

Edit: Store bokstaver i name tag er verre. Her bør amsleser endre koden og kun tillate små bokstaver. Entity navn i HA kan _ikke_ inneholde store bokstaver. Det er noen andre begrensinger også som å ikke bruke mellomrom og helst unngå å starte med et tall.

Jeg kjenner ikke HA så godt, men det kan godt tenkes du har rett i dette.

Kan jeg plage deg til å legge det inn som forbedringsforslag under Issues på firmwarens Github?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.