Gå til innhold
  • Bli medlem

Multisensor 6, overgang fra Batteri til USB


Anbefalte innlegg

Jeg har hatt 4 stk Aeotec Multisensor 6 gående på batteri i noen måneder nå. Endelig har jeg fått trukket strøm til dem og trodde de skulle ble mye bedre. 

 

Problemet (tror jeg) er at de fremdeles tror at de går på batteri. 

Parameter 9 viser nemlig fremdeles 2

 

image.thumb.png.be3270dd4f0b6b33aa0269c113b7d5f6.png

 

og i manualen står det: 

 

image.png.974158a41fddc3af188892123db67cbe.png

 

Dette leser jeg som at Den skal ha Value 1, når den går på strøm. 

Videre så forstår jeg at dette er en "read only" parameter som settes basert på hvilken strømforsyning man har når sensoren inkluderes. 

 

Jeg slettet mine sensorer fra homeseer,  og kjørte en reset på dem før jeg forsøkte å legge dem til igjen. Likevel rapporterer de value 2 når jeg legger dem til på nytt. 

 

Er det noen jeg misforstår her? 

Endret av Armas
Lenke til innlegg
Del på andre sider

Det du må gjøre er å konvertere tallet 2 i desimal til binær, altså 10. 10 har her to bits, en most significant bit (MSB), og en least significant bit (LSB). Du kan lese litt mer her https://en.wikipedia.org/wiki/Bit_numbering.

I tabellen din med Value1 ser du annotasjonen MSB bak, det betyr i dette tilfellet tallet med høyest verdi/lengst til venstre.

Value1 kan her leses ut som 1 om jeg tolker alt riktig, og da som "0x01=Battery power mode".

 

Vet ikke om det hjalp deg noe altmed at de gjerne skulle rapportert USB-strøm, men om du leser ut 0 eller 1 (desimal) burde det være gyldig for USB-strøm.

 

Lenke til innlegg
Del på andre sider

Ser ut at du bruker feil Size verdi. Skal vel bli 2 Byte (ikke 1 Byte).

En annen ting: "Note: this parameter cannot be used as Set usage."

Personlig ser det ikke ut for meg at Parameter 9 er "viktig"...

 

Du kan også se her (fra Aeotec support): https://aeotec.freshdesk.com/support/solutions/articles/6000115071-difference-between-usb-and-battery-power-and-recommendations-multisensor-6-zw100-

 

Du kan også kontrollere enh. FW versjon. Den siste er v. 1.11

Lenke til innlegg
Del på andre sider
1 time siden, fiLLLip skrev:

Det du må gjøre er å konvertere tallet 2 i desimal til binær, altså 10. 10 har her to bits, en most significant bit (MSB), og en least significant bit (LSB). Du kan lese litt mer her https://en.wikipedia.org/wiki/Bit_numbering.

I tabellen din med Value1 ser du annotasjonen MSB bak, det betyr i dette tilfellet tallet med høyest verdi/lengst til venstre.

Value1 kan her leses ut som 1 om jeg tolker alt riktig, og da som "0x01=Battery power mode".

 

Vet ikke om det hjalp deg noe altmed at de gjerne skulle rapportert USB-strøm, men om du leser ut 0 eller 1 (desimal) burde det være gyldig for USB-strøm.

 

 

Om jeg forstår deg rett, så vil:

value 2 (som jeg har) tilsvare binær 10 som da kan leses som "battery powermode" (MSB) og "keep sleep state for battery power mode" (LSB)

mens value 1 ( binær 01) leses som USB-strøm (MSB) og "keep awake for 10 minutes battery power mode" (LSB)

og evt Value 0 (Binær 00) leses som USB-strøm (MSB) og "keep sleep state for battery power mode" (LSB)

??

 

Dere som har denne på strøm. Hva har dere på Parameter 9?

 

 

Lenke til innlegg
Del på andre sider
3 minutes ago, Armas said:

 

Om jeg forstår deg rett, så vil:

value 2 (som jeg har) tilsvare binær 10 som da kan leses som "battery powermode" (MSB) og "keep sleep state for battery power mode" (LSB)

mens value 1 ( binær 01) leses som USB-strøm (MSB) og "keep awake for 10 minutes battery power mode" (LSB)

og evt Value 0 (Binær 00) leses som USB-strøm (MSB) og "keep sleep state for battery power mode" (LSB)

??

Om jeg tolker alt riktig, så er vi veldig enig ?

Lenke til innlegg
Del på andre sider
1 time siden, hkmod25 skrev:

Ser ut at du bruker feil Size verdi. Skal vel bli 2 Byte (ikke 1 Byte).

En annen ting: "Note: this parameter cannot be used as Set usage."

Personlig ser det ikke ut for meg at Parameter 9 er "viktig"...

 

Du kan også se her (fra Aeotec support): https://aeotec.freshdesk.com/support/solutions/articles/6000115071-difference-between-usb-and-battery-power-and-recommendations-multisensor-6-zw100-

 

Du kan også kontrollere enh. FW versjon. Den siste er v. 1.11

 

Mulig at denne ikke er viktig og jeg bare styrer, men om andre får denne riktig så er det jo rart at den er feil hos meg?

 

FW er 1.11 og de andre parameterne er som i linken din. 

Skal teste disse mer i kveld og se på de har fått raskere respons med setup som i linken. 

Lenke til innlegg
Del på andre sider
8 minutter siden, hkmod25 skrev:

En gang til (så lenge jeg refererte ikke til mulig feil med Parameter Value).

Jeg refererte til feil med "Value Size".

Du bruker (på bildet over) "Value Size: 1 byte"

Det som er riktig: "Value Size: 2 byte"

 

Jeg endret Value Size til 2 byte. 

Mulig det påvirker funksjonaliteten til sensoren, men det påvirker ikke Value (decimal).  Den står fremdeles som 2

 

Lenke til innlegg
Del på andre sider
8 timer siden, Armas skrev:

Jeg slettet mine sensorer fra homeseer,  og kjørte en reset på dem før jeg forsøkte å legge dem til igjen.

 

Slettet du bare devicene eller kjørte du en «exclude»? 

Lenke til innlegg
Del på andre sider
39 minutter siden, ZoRaC skrev:

 

Slettet du bare devicene eller kjørte du en «exclude»? 

Først slettet jeg dem. Det skal jeg inrømme ?.

 

Men så tok jeg en kikk i listen over nodene, og så at der lå det flere gamle noder. Jeg forsøkte så "remove bad node", uten hell. Det som funket var å bruke "test connectivity" - ingen forbindelse og så bruke "remove bad node".  Tilsutt kjørte jeg " full Scan" på z-wave nettet og avsluttet med "fully optimize a network". Nå er det ingen gamle noder i listen. 

Etter dette kjørte jeg reset på sensorene, og inkluderte på nytt. 

Jeg har bare lagt til en sensor så langt, så vet ikke om det blir likt på de siste 3, men skal forsøke i kveld. 

 

 

Lenke til innlegg
Del på andre sider
Akkurat nå, ZoRaC skrev:

 

Prøv å ta en exclude på den og deretter include igjen. 

 

Skal prøve. 

 

Men det må bety at exclude gjør noe med oppsettet på selve sensoren, som factory reset ikke klarer?

 

Er det forøvrig noen som kan bekrefte at Value (decimal) SKAL være 1, når den er koblet til med USB?

Lenke til innlegg
Del på andre sider
Akkurat nå, Armas skrev:

Men det må bety at exclude gjør noe med oppsettet på selve sensoren, som factory reset ikke klarer?

 

Det kan hende. Er i hvertfall det eneste jeg kan tenke meg som en mulig løsning. :) 

Lenke til innlegg
Del på andre sider
5 timer siden, ZoRaC skrev:

 

Det kan hende. Er i hvertfall det eneste jeg kan tenke meg som en mulig løsning. :) 

 

Ingen endring etter exclude og ny include. 

 

Har nå lagt til alle 4 sensorene, og alle blir like på dette punktet. 

 

Her er svaret jeg fikk fra aeotec:

 

Unfortunately I am not sure about Parameter 9 in this case, value 2 based on the engineering sheet is not a valid setting or report back of this. It is possible there is a mistake in the engineering sheet where 1 = battery power and 2 = USB power in this case which is only a guess. I'll speak with our engineering team to see if this needs to change in our engineering sheets.
 
Typically this is a non-issue regardless as the gateway detected this device as a listening node. This would indicate it is not battery powered and this flag is set during the pairing process.
Lenke til innlegg
Del på andre sider
  • 1 år senere...

Noen som har funnet ut noe sikkert?

Jeg har en ny sensor tilkoblet usb, som jeg aldri har hatt batteri i.

Parameter 9 viser 2 og 1byte.

sw verson 1.13

Har ganske lang usb kabel, jeg vet ikke hvordan sensoren registrerer om det er batteri eller USB.

Har det noe med spenningen å gjøre (noe jeg ikke tror)? Høy spenning USB, lav batteri?

I kombinasjom med lang usb kabel så vil spenningsfallet butgjøre litt, så derfor hadde det vært greit å være sikker på at sensoren er i usb mode.

Endret av Slabbedask
Lenke til innlegg
Del på andre sider
13 timer siden, Slabbedask skrev:

jeg vet ikke hvordan sensoren registrerer om det er batteri eller USB.

Det er jo en smal sak å registrere om du får strøm fra en USB-port eller ei, så det er vel det mest sannsynlige.

 

Jeg har ganske lange trekk hjemme (alt går ned til sentralt rom), men det er med CAT6-kabel. Fungerer utmerket. :) 

Lenke til innlegg
Del på andre sider
11 timer siden, Moskus skrev:

Det er jo en smal sak å registrere om du får strøm fra en USB-port eller ei, så det er vel det mest sannsynlige.

 

Jeg har ganske lange trekk hjemme (alt går ned til sentralt rom), men det er med CAT6-kabel. Fungerer utmerket. :) 

Er nok som du sier.

Er litt vanskelig å trekke nye kabler hos meg. Er jo litt skeptisk til disse usb laderne, men har skaffet elko usb uttak. Er ikke sikkert de er noe bedre, men føles bedre. De har ihvertfall kortslutningsbeskyttelse. Har skaffet noen lange usb ledninger slik at elko usbboksene kan monteres ved gulv. Skjøter de med den orginale flatkabelen med scotchlok inne i batterirommet. Skjønner ikke hvorfor multisensor 6 blir levert med flatkabel, er jo helt ubrukelig å legge opp fint.

Lenke til innlegg
Del på andre sider
15 timer siden, Slabbedask skrev:

Skjønner ikke hvorfor multisensor 6 blir levert med flatkabel, er jo helt ubrukelig å legge opp fint.

Jeg mener de burde levert 2. En kort for montasje i vegg (denne kunne fulgt med innfellings-kitet), og en skikkelig lang, minst 2,5 meter, for alle andre situasjoner.

Lenke til innlegg
Del på andre sider
  • 11 måneder senere...
On 06/03/2020 at 10:21, Moskus said:

 

Jeg har ganske lange trekk hjemme (alt går ned til sentralt rom), men det er med CAT6-kabel. Fungerer utmerket

Kan du forklare nærmere hvordan du har gjort dette. Bruker du Cat6 som "strømkabel" til multisensor 6?

Lenke til innlegg
Del på andre sider
15 timer siden, toonwolf skrev:

Kan du forklare nærmere hvordan du har gjort dette. Bruker du Cat6 som "strømkabel" til multisensor 6?

Japp. Ingen RJ45-plugger på, men koblet til en USB-connector "breakout", og lasket sammen i teknisk skap. :) 

  • Like 2
Lenke til innlegg
Del på andre sider
  • 1 måned senere...

Ble det noen løsning på dette problemet? Jeg byttet fra batteri til USB i går fordi jeg trenger at denne noden er en repeater, men det ser ikke ut til at den forstod at den nå er på strøm utenom at batteriet alltid er 100%. Jeg tok derfor exclude og include node, men fortsatt ser det ut som den tror at den er en batterienhet og vil derfor ikke rapportere data ofte og heller ikke være repeater (det som er viktigst for meg)...

 

Jeg bruker ZwaveJS2mqtt og Home Assistant, men tipper det ikke har så mye å bety..

Endret av 2jan
Lenke til innlegg
Del på andre sider
9 hours ago, 2jan said:

Ble det noen løsning på dette problemet? Jeg byttet fra batteri til USB i går fordi jeg trenger at denne noden er en repeater, men det ser ikke ut til at den forstod at den nå er på strøm utenom at batteriet alltid er 100%. Jeg tok derfor exclude og include node, men fortsatt ser det ut som den tror at den er en batterienhet og vil derfor ikke rapportere data ofte og heller ikke være repeater (det som er viktigst for meg)...

 

 

Jeg har gjort akkurat det samme og får også ikke Parameter 9 til å gi mening, men har fått endret motion out til 30s så gikk ut i fra at den skjønte at den var på strøm.

Jeg vet ikke hvordan Home Assistant fungerer, men får du svar fra noden uten å vekke den?

 

Lenke til innlegg
Del på andre sider

J

17 minutter siden, aarpi3 skrev:

 

Jeg har gjort akkurat det samme og får også ikke Parameter 9 til å gi mening, men har fått endret motion out til 30s så gikk ut i fra at den skjønte at den var på strøm.

Jeg vet ikke hvordan Home Assistant fungerer, men får du svar fra noden uten å vekke den?

 

Ja noden er våken hele tiden. Jeg intervjuet noden i går kveld og sjekket loggen i etterkant, der viser det seg at den sier usb powered nå, og at den fungerer som repeater, så det ser ut til å være ok. Jeg synes det var rart at den fremdeles insisterer på å gi data kun hver time, selv på strøm, så jeg endret den parameteren fra 3600sek til 1200sek til å starte med.

Endret av 2jan
Lenke til innlegg
Del på andre sider

Bli med i samtalen

Du kan publisere innhold nå og registrere deg senere. Hvis du har en konto, logg inn nå for å poste med kontoen din.

Gjest
Skriv svar til emnet...

×   Du har limt inn tekst med formatering.   Lim inn uten formatering i stedet

  Du kan kun bruke opp til 75 smilefjes.

×   Lenken din har blitt bygget inn på siden automatisk.   Vis som en ordinær lenke i stedet

×   Tidligere tekst har blitt gjenopprettet.   Tøm tekstverktøy

×   Du kan ikke lime inn bilder direkte. Last opp eller legg inn bilder fra URL.

×
×
  • Opprett ny...