Gå til innhold
  • Bli medlem

Anbefalte innlegg

Hei

Jeg har brukt lunchen til å mekke litt på en event, men har savnet en noe fleksibilitet. Jeg har laget følgende event som skal trigge på samme hendelse, men har en forskjell i condition:

image.thumb.png.69f4c7db7bb76822c8df5cf2d4bde2ec.png

Finnes det funksjonalitet som gjør at jeg ikke trenger å "bygge så mye", men istedet gjøre:

image.thumb.png.d3ad433b3f49468e1620d29ad438a896.png

Ikke noe undergang om ikke mulig...men ville bare vært kjekt!

Lenke til innlegg
Del på andre sider

Jeg bruker "greater than" eller "less than", gitt at MDEN har verdiene 1, 2, 3 og 4 for morgen, dag, kveld og natt.

 

Så i ditt tilfelle ville det være:

Status Døgn has a value less than "kveld". 

  • Like 1
  • Thanks 1
Lenke til innlegg
Del på andre sider

Cunning! Ja, verdiene mine er stigende slik som du beskriver, så da er nok denne metoden mulig! Metoden er dog en workaround og ikke helt optimal siden jeg sannsynligvis må slå opp tallverdiene i VD´en om jeg skal gjøre endringer om to-tre år. Ønsket helst å ha betingelsene eksplisitte.

 

Lenke til innlegg
Del på andre sider
42 minutter siden, Fjosepose skrev:

Metoden er dog en workaround og ikke helt optimal siden jeg sannsynligvis må slå opp tallverdiene i VD´en om jeg skal gjøre endringer om to-tre år. Ønsket helst å ha betingelsene eksplisitte.


Som skjermbilde 2, men en ekstra and:

and if not kveld

and If not natt

  • Like 1
Lenke til innlegg
Del på andre sider

Bli med i samtalen

Du kan publisere innhold nå og registrere deg senere. Hvis du har en konto, logg inn nå for å poste med kontoen din.

Gjest
Skriv svar til emnet...

×   Du har limt inn tekst med formatering.   Lim inn uten formatering i stedet

  Du kan kun bruke opp til 75 smilefjes.

×   Lenken din har blitt bygget inn på siden automatisk.   Vis som en ordinær lenke i stedet

×   Tidligere tekst har blitt gjenopprettet.   Tøm tekstverktøy

×   Du kan ikke lime inn bilder direkte. Last opp eller legg inn bilder fra URL.

  • Lignende innhold

    • Av kjetilkl
      Så, etter å ha fiklet med HA i et par år, og aldri fått til det jeg vil pga manglende enhetsstøtte og andre ting så tok jeg mot til meg og kjøpte en HS4-lisens på Black May.
       
      Og - allerede etter en kveld så har jeg fått til å slå av og på lysene i stua med min Namrom K8 som jeg aldri fikk brukt i HA
       
      Derimot har det dukket opp endel spørsmål underveis.🤪
       
      1. Jeg har endel aqara sensorer og Opple-brytere jeg gjerne skulle ha brukt, men fant ut at Zigbee-pluginet kun støtter to (for meg)ukjente interfacet (har Conbee II) - Er det slik at jeg da må kjøpe JowiHue pluginet for å få dette til å virke? - Eller er det andre måter, eventuelt at det kommer offisiell støtte? Eller er det beste å kjøpe nytt Zigbee-interface som er støttet offisielt? (Har også noe Hue-utstyr, men dette styrer jeg kun via Hue i dag)
       
      2. Jeg ser det finnes en plugin for Ikea også som koster penger - må jeg ha denne i tillegg hvis jeg ønsker å bruke Ikea-utstyr?
       
      2. Og - jeg har satt opp dette på en W10-pc som kjører på en gammel HP microserver med ESXi, plugget usb-enhetene inn bak, og lagt de til i VMen - men, det virker som den "mister" de virtuelle COM-portene som opprettes innimellom? -Èn gang så forsvant hele COM-porten så jeg måtte legge den til i ESXI pånytt, og etter dette har det også skjedd flere ganger at HS mister forbindelsen med ZW nettverket, så jeg må slå av og på pluginet for at det skal begynne å virke igjen. - Noen som har noen erfaringer eller innsikt her? (UZB1) (edit: Når dette skjer får jeg feilmelding i node info at COM-porten ikke finnes (bilde 2), men det gjør den (den synes i Windows)
       
      3. Har heller ikke helt funnet ut om jeg kan få til kontinuerlig dimming på bryteren min. - Jeg har laget en event som setter styrken til det jeg ønsker (f.eks 25% som under), men skulle gjerne hatt det til å fungere slik at hvis jeg holder inne "av-knappen" så dimmer den ned, og motsatt opp på "på-knappen". Er det noe jeg har oversett, eller hvordan kan jeg få til dette?
       


    • Av Laterman
      Jeg hadde en stund HS4-server stående på kontoret i 1.etasje, siden den var lett tilgjengelig når jeg startet min «HS-reise» som nybegynner. 
      For et par måneder siden, så var det meste av utstyr koblet på, alt fungerte fint og da var tiden kommet for å flytte serveren ned til sin tiltenkte plass i kjelleren. Etter flytting måtte jeg sette ny com-port på Z-wave interfacet (aeotec stick) så dukka alt opp som skulle være der.  Men flere devicer er nå dobbelt opp. Dvs en device med fullt navn, mens en med kun «node xx». Det er jo svært rotete og uoversiktelig å ha mange slike dobbeltføringer, så hva kan en gjøre for å bli kvitt de? De kan vel ikke akkurat fjernes, eller må alle slike eksluderes for å inkluderes igjen?
      Hvis noen har en teori om årsaken til at de dukker opp slik, så hadde det også vært fint så en unngår slikt i fremtiden... 
      (Devicene i bildet under er samme device)

    • Av jrewing
      Har blitt med på et slags prøveprosjekt/pilot fra Lyse. De har åpnet HAN-porten og sendt meg en liten smarthus-startpakke.
       
      Jeg har Homeseer og stort sett z-wave fra før. Litt wifi og Verisure har jeg også. Men Zigbee har jeg ingenting av. Håpet nå er at jeg kan få denne hub-en til å snakke med Homeseer, helst uten å kjøpe zigbeegrensesintt.
       
      De kaller den Eva i manualen, men på pakken heter den Datek.
       
       

    • Av Decibel
      Jeg har den siste tiden fått opp jevnlige feilmeldinger i loggen i fra Easytrigger. Meldingen er "ERROR HSEventAux callback. 0 er en ugyldig verdi for intervallet. Den må være større enn 0."
      Denne feilmeldingen synes jeg ikke gir så mye informasjon, og jeg har derfor spurt inne på Homeseer-forumet, i håp om at den som har laget Easytigger (eller andre) kanskje kunne peke meg i riktig retning. Så langt har jeg ikke fått noen tips til hva problemet kan være.
      Jeg har derfor tatt den store jobben med å gå gjennom alle eventer som bruker Easytrigger. Jeg har ca 100 eventer som bruker den, så det tok litt tid. Jeg delte de inn i grupper, og disablet en og en gruppe. Fremdeles kom feilmeldingene jevnt og trutt. Jeg har derfor gått til det skritt å disable alle eventer som bruker Easytrigger. Og feilmeldingene kommer fremdeles!
      Det er kun en måte jeg har klart å fjerne feilmeldingene på, og det er ved å skru av hele Easytrigger, og det har jeg jo svært lite lyst til. Jeg bruker flere av funksjonene aktivt, så nå som alle funksjonene er disablet så er huset ganske "dumt".
       
      Er det noen her inne som har vært borti denne feilmeldingen, og som har en anelse om hva som kan forårsake den?
       
    • Av Join
      Hei!
       
      Eg prøver å bruke  Realtime LastMeterConsumption frå tibberseer som blir oppdatert kvar time til å registrere siste times strømforbruk.
      Altså nyverdi - målerstand forrige time = forbruket sist time.
       
      Planen er:
      1) å opprette et device som får målerstand NÅR  Realtime LastMeterConsumption oppdaterer seg. Denne biten er grei.
       
      2) Neste time når  Realtime LastMeterConsumption oppdaterer seg, vil eg trekke bort forrige timeverdi for å finne forbruket.
       
      3) Resultatet skrives til et annet device "kWh forbruk sist time".
       
      4) Opprette et device: "Største timeforbruk Månad".
       
      5) Lage regel som sei:
      "IF" kWh forbruk sist time" er større enn "Største timeforbruk Månad"
      "THEN" Easytrigger write device "kWh forbruk sist time" to device "Største timeforbruk Månad". Dette burde eg få til.
       
       
      Planen er å registrere den timen med størst kWh forbruk i mnd, lagre høgaste verdi for kvar mnd.
       
      Dette har med nettleige å gjere og estimering av nettleige og strømpris sammen. 
       
      Har Easytrigger, Device history, om de kan brukes.
       
      Et lite script løser nok dette, men har ingen anelse korleis bruke skript pr.d.d. i HS.
×
×
  • Opprett ny...