Gå til innhold
  • Bli medlem

Nye garasjeporter og portåpnere. Fibaro Smart Implant?


Anbefalte innlegg

  • Svar 80
  • Opprettet
  • Siste svar

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Det ser ut som om du mangler et bibliotek for "SoftPWM.h", det er det mest alvorlige.   https://forums.homeseer.com/forum/analog-digital-io-device-plug-ins/analog-digital-io-discussion/ardui

Ja, jeg testet dette, og fikk det til å fungere. Da er alt bare velstand ?   Nå er det bare å lage det som skal til for å få gjort det en skal.. Takk for hjelp!

@petersvJa, jeg angrer for at jeg ikke begynte med ESP32 på takvifteprosjektet. Det ville spart meg for mye tid, lesning og funderinger. Ser at noen gpioer flipper der også. Forhåpentligvis

Posted Images

Er det sånn at alle innganger og utganger må settes før man lager sketchen? I så fall kan jo det være årsaken til feilmeldingene. Jeg gikk inn i julen med den troen at dette skulle gjøres etterpå.

 

Hvis det er sånn som nå spør om, så må man ha full kontroll på hvordan man skal bygge ut dette... noe som ville være naturlig ?

Lenke til innlegg
Del på andre sider
19 timer siden, Moskus skrev:

Vel du har igjen en feil i SoftPWM-oppsettet:

Da har jeg funnet årsaken.. Jeg har lastet ned (og betalt for) plugin som ligger under Analog & Digital, men denne tar ikke høyde for NodeMCU-kort (eller andre?). Tar kun originale Arduino-kort. Det ligger en under Beta, med akkurat samme navn, som skal andre kort. Kanskje lite oppvakt av meg, men informasjonen er ikke bra. Hadde man bare visst..

Får laste ned trial, og se hva som skjer. Kan jeg bruke samme kode, kanskje?

Lenke til innlegg
Del på andre sider
På 24.12.2019 den 15.28, SteinarH skrev:

Da har jeg funnet årsaken.. Jeg har lastet ned (og betalt for) plugin som ligger under Analog & Digital, men denne tar ikke høyde for NodeMCU-kort (eller andre?). Tar kun originale Arduino-kort. Det ligger en under Beta, med akkurat samme navn, som skal andre kort. Kanskje lite oppvakt av meg, men informasjonen er ikke bra. Hadde man bare visst..

Får laste ned trial, og se hva som skjer. Kan jeg bruke samme kode, kanskje?

 

Ja, du må bruke beta-versjon av pluginen. Det er samme pluginen, og lisensen du kjøpte er gyldig for den også.

Sjå post #3 på denne forumtråden frå Homeseer-forumet. Den er forhåpentlegvis til hjelp.

Lenke til innlegg
Del på andre sider
1 minutt siden, Zulboom skrev:

Ja, du må bruke beta-versjon av pluginen. Det er samme pluginen, og lisensen du kjøpte er gyldig for den også.

Sjå post #3 på denne forumtråden frå Homeseer-forumet. Den er forhåpentlegvis til hjelp.

Ja, jeg testet dette, og fikk det til å fungere. Da er alt bare velstand ?

 

Nå er det bare å lage det som skal til for å få gjort det en skal.. Takk for hjelp!

  • Like 1
Lenke til innlegg
Del på andre sider
På 23.12.2019 den 19.39, SteinarH skrev:

Men dette er noe som er generert av plugin i HS. Så da er jeg usikker på hva som må bli neste skritt

Det neste skritter er å være HELT SIKKER på at du har ALLE bibliotekene installert. Det ser ikke helt slik ut.

Lenke til innlegg
Del på andre sider
1 minutt siden, Moskus skrev:

Det neste skritter er å være HELT SIKKER på at du har ALLE bibliotekene installert. Det ser ikke helt slik ut.

Joda, jeg tror nok det meste er på plass nå. Har koplet meg til og lest både temperaturer og åpne/lukkeingang. I tillegg styrt en lysdiode av og på, og blink. Skal teste mer etterhvert; mangler noen releer. Når de kommer, og hvis alt går etter planen, så blir det styring av garasjeport ?

Lenke til innlegg
Del på andre sider

@Moskus

Holder på å sette opp NodeMCU, men har et spørsmål kanskje du kan svare på.

 

I pinneoversikten i Arduino plugin, så dukker ikke IO D8 (GPIO15) opp. Er det bare hos meg, eller er dette slik det skal være? Skulle gjerne brukt den som inngang. Har bruk for fire utganger og fire innganger. Det dukker imidlertid opp D9 og D10, som er vel RX og TX? Kan disse brukes?

Lenke til innlegg
Del på andre sider
8 timer siden, Moskus skrev:

Nå ble jeg usikker, jeg må sjekke. Trodde det var flere tilgjengelige enn det...? Bruker flere selv for å styre vanningen. 

Ja, fint det. Jeg finner ikke at det flere tilgjengelige ved bruk av NodeMCU med ESP8266. Kan det være at du bruker et annet kort?

 

Styring av vanning, er et planlagt prosjekt. Hadde tenkt å bruke samme kort der også, men sliter litt med nok utganger. Finnes det alternative kort som er i samme prisnivå? Ekte Arduino er jo relativt dyrt i forhold til NodeMCU.

Lenke til innlegg
Del på andre sider
20 minutter siden, Moskus skrev:

Nei. hva skulle det være?

Nei, si det ? Jeg vet ikke hva som finnes der ute, så det var et skudd i blinde.

 

21 minutter siden, Moskus skrev:

Bruker D1-4, og har D5-7 +D9+10 igjen.

OK, skjønner. Da ser jeg at du har de samme alternativene som meg. Problemet er bare at det refereres til D9 og D10, som etter det jeg har forstått, er RX og TX. D8 er ikke tilgjengelig, som er en IO som kunne nyttes.

 

Henter min referanse fra denne, men kanskje jeg har oppfattet noe feil?

https://randomnerdtutorials.com/esp8266-pinout-reference-gpios/

Lenke til innlegg
Del på andre sider
På 30.12.2019 den 22.25, SteinarH skrev:

Da ser jeg at du har de samme alternativene som meg. Problemet er bare at det refereres til D9 og D10

Da forstår jeg egentlig ikke problemet. Hvis du har andre pinner tilgjengelig, så hvorfor ikke bruke dem?

Hva er det som refererer til D9 og 10?

Lenke til innlegg
Del på andre sider
2 minutter siden, Moskus skrev:

Da forstår jeg egentlig ikke problemet. Hvis du har andre pinner tilgjengelig, så hvorfor ikke bruke dem?

Hva er det som refererer til D9 og 10?

Plugin referer til D9 og D10, som pr. definisjon ikke er tilgjengelige IO på en NodeMCU. I tillegg har jeg sett på denne oversikten, som sier litt om hva og hvordan pinene bør benyttes.

 

Jeg beklager å stille dumme spørsmål, og kanskje referere feil. Jeg prøver bare å forstå..

Lenke til innlegg
Del på andre sider
15 minutter siden, SteinarH skrev:

I nedtrekksmenyen. Mens D8 ikke er der.

Nei, og det er jo greit? Masse andre pinner å bruke. :) 

Skal du bruke D8 må du nok programmere Arudinoen selv og bruke API-et til Arduino-plugin'en i stedefor.

Lenke til innlegg
Del på andre sider
1 minutt siden, Moskus skrev:

Nei, og det er jo greit? Masse andre pinner å bruke.

Ja, er andre pinner. Men i den linken jeg sendte (og flere andre tilsvarende tester), så anbefales det ikke å bruke andre pinner. Mye ustabilitet og konsekvenser ved å bruke de andre pinnene.

Lenke til innlegg
Del på andre sider

Da er du enten tilbake til å skrive programmet selv eller (heller) benytte Fibaro Smart Implant.

Jeg har imidlertid brukt andre pinner lenge til mye, har aldri opplevd problemer. Hva skulle det være?

 

Jeg er absolutt ikke en ekspert, men likevel: Ta det du leser på internett med en klype salt...? ;) 

Med bakgrunn i linken din, hadde jeg brukt GPIO4 eller 5.

Lenke til innlegg
Del på andre sider
På 19.11.2019 den 17.02, bjornepappa skrev:

Eg brukte Nodemcu til garasjeportstyring, brukte relé på to utganger for å få potensialfrie kontaktar. Dette var dessverre litt ustabilt, relea trekte litt i tide og utide med resultat at portane opna seg. 

 

Har kanskje funne forklaringa på dette, her.

Sitat

Conclusion: GPIOs D1 and D2 are the only safe GPIOs I can use to drive relays if I don’t want them to operate autonomously at boot.

Og det var nettopp det eg opplevde, muligens pga litt ustabil WiFi-dekning uten at det er sikkert. Eg brukte då (og bruker fortsatt) D1 og D2 til indikering og to andre, trur det var D3 og D4 til å opne dei to portane. I dag ville eg ha gjort omvendt. 

Lenke til innlegg
Del på andre sider
2 minutter siden, bjornepappa skrev:

Og det var nettopp det eg opplevde, muligens pga litt ustabil WiFi-dekning uten at det er sikkert. Eg brukte då (og bruker fortsatt) D1 og D2 til indikering og to andre, trur det var D3 og D4 til å opne dei to portane. I dag ville eg ha gjort omvendt. 

 

Ja, det er dette jeg skal frem til. Etter det jeg har lest, så er det kun ustabilt ved boot, og ikke ellers. Men dette høres ut som er en feil konklusjon, ut fra det du skriver/opplever. Kan du bekrefte at problemet er det ved generell drift også?

 

D1 og D2 (resp. GPIO 5 og 4) er sagt å være stabile, så det vil være best å styre releer via disse, spesielt hvis det man styrer har en viss konsekvens. Garasjeport må anses ha ev viss risiko ved å "styre seg selv", mens vanningsanlegget kan leve med å skvette litt vann hvis den får en hikke (eller ved boot).

Lenke til innlegg
Del på andre sider

ESP8266 gjør mye rart på gpioene ved boot og også flash.

Det er bare gpio 4 og 5 som ikke flipper.

I tillegg så brukes flere av gpioene til å bestemme bootmodus, så man må være forsiktig om ESPen leser høy eller lav ved boot.

Mange av gpioene brukes også mot flash-bikke(ne) så man kan stille spørsmål ved nytten av at disse er dratt fram på de bordene med mange io.

Dette ble veldig tydelig på takvifte-prosjektet mitt.

Der har jeg tre releer, en temperatursensor, en halleffektsensor og fire brytere.

Jeg vil påstå at dette er veldig nær max ESP8266 takler med io-messig.

De fleste gpioene jeg brukte som input måtte gå via en 330ohms motstand fordi gpioene faktisk setter ett nivå som output ved boot.

 

Lenke til innlegg
Del på andre sider

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gjest
Skriv svar til emnet...

×   Du har limt inn tekst med formatering.   Fjern formatering

  Du kan kun bruke opp til 75 smilefjes.

×   Lenken din har blitt bygget inn på siden automatisk.   Vis som en ordinær lenke i stedet

×   Tidligere tekst har blitt gjenopprettet.   Tøm tekstverktøy

×   Du kan ikke lime inn bilder direkte. Last opp eller legg inn bilder fra URL.


×
×
  • Opprett ny...