Gå til innhold
  • Bli medlem

Verisure Plugin


Anbefalte innlegg

Begynte en stund tilbake å få følgende feilmelding i loggen;

System.NullReferenceException: Object reference not set to an instance of an object at Verisure.VerisureSync.VerisureTimerElapsed (System.Object sender, System.Timers.ElapsedEventArgs e) [0x00a09] in :0

 

Pluginet fungerer fint, men spammer loggen "en del" med dette

Lenke til innlegg
Del på andre sider
  • Svar 551
  • Opprettet
  • Siste svar

Mest aktive i denne tråden

Mest aktive i denne tråden

Populære innlegg

Ting begynner å løsne, og jeg er i gang igjen. ny versjon vil bli sendt ut til et par brukere for test innen kort tid

Her har det vært endringer hos verisure. Litt svak kode av meg som ikke har isolert alle de ulike typene i metoden som henter statusen. Heldigvis var denne velig sent i metoden slik at mesteparten av

Har knapt hvert hjemme siste tiden så har ikke fått sett noe på dette. Men nå tror jeg at jeg skal klare å få lagt inn noe tid til å se på det dere har rapportert

Postede bilder

Hei...

 

Jeg har mine utfordringer hvert år når mørket kommer dessverre og derfor går litt under jorda. Nå som dagene blir lysere og lysere håper jeg å ha overskudd til å jobbe videre.

  • Like 6
Lenke til innlegg
Del på andre sider
På 24.9.2020 den 10.30, Moskus skrev:

Jeg ønsker meg muligheten til å fjerne alle meldinger fra plugin'en i loggen. For tiden tar Verisure-appen opp 60-70% av loggen, og gjør at det er vanskelig å finne ut noe om det andre som skjer.

 

Skriv det heller til en fil hvis nødvendig. :) 

 

Set loglevel i inifila til 4 :)

Lenke til innlegg
Del på andre sider
På 8.10.2020 den 13.11, ThomasBK skrev:

Hei.

 

Feilmeldingen:

okt-08 13.08.16   LSoftVerisure Error System.NullReferenceException: Objektreferanse er ikke satt til en objektforekomst. ved Verisure.VerisureSync.VerisureNorthTimerElapsed(Object sender, ElapsedEventArgs e)

 

Noen som vet hva som er galt?

..Thomas..

 

Her har det vært endringer hos verisure. Litt svak kode av meg som ikke har isolert alle de ulike typene i metoden som henter statusen. Heldigvis var denne velig sent i metoden slik at mesteparten av enheter har blitt oppdatert.

 

Men Yale status og status enhetene er de som blir berørt av denne feilen.

 

 

Jeg poster en hotfix på dette litt senere i dag tenker jeg.

 

  • Like 7
Lenke til innlegg
Del på andre sider
38 minutter siden, Kenneth skrev:

Feilmld i log hos meg er også borte :)

Hei. Har lest litt bakover, og det kan se ut til at du klarer å bruker Verisure-plugin´en på HS4? Jeg har installert den på HS4, men ser i loggen at jeg får noen varsler:
image.thumb.png.b434aa18bdde6bc34ea25184df4f7897.png

 Slik jeg skjønner så kan dette fikses med å "mekke" litt på en konfig-fil.. Om riktig, siden du har fått dette til å virke på HS4, kunne du lagt ut din anonymiserte/sladdede konfig-fil som en "golden sample"?

 

Lenke til innlegg
Del på andre sider
24 minutter siden, Fjosepose skrev:

Hei. Har lest litt bakover, og det kan se ut til at du klarer å bruker Verisure-plugin´en på HS4? Jeg har installert den på HS4, men ser i loggen at jeg får noen varsler:
image.thumb.png.b434aa18bdde6bc34ea25184df4f7897.png

 Slik jeg skjønner så kan dette fikses med å "mekke" litt på en konfig-fil.. Om riktig, siden du har fått dette til å virke på HS4, kunne du lagt ut din anonymiserte/sladdede konfig-fil som en "golden sample"?

 

 

 

Om du logger inn på Verisure mine sider og åpner utviklingsverktøy og nettverk

 

bilde.png.a82ff150861bf4181552c5c3a2a12def.png

 

Sitat

[44262228019]
active=True

savepin=True
pin=QET+rEKPy4fdhdfd0RDQ==

 

Som du ser er pin ikke lagret i klartekst så det er ikke mulighet å legge inn dette manuelt dessverre. Men du vil kunne aktivere lokasjonen og få hentet ut status

 

Endret av lilfire
Lenke til innlegg
Del på andre sider
På 11.1.2021 den 9.51, Fjosepose skrev:

Hei. Har lest litt bakover, og det kan se ut til at du klarer å bruker Verisure-plugin´en på HS4? Jeg har installert den på HS4, men ser i loggen at jeg får noen varsler:
image.thumb.png.b434aa18bdde6bc34ea25184df4f7897.png

 Slik jeg skjønner så kan dette fikses med å "mekke" litt på en konfig-fil.. Om riktig, siden du har fått dette til å virke på HS4, kunne du lagt ut din anonymiserte/sladdede konfig-fil som en "golden sample"?

 

 

@Fjosepose, jeg kjører plugin på HS4, det er korrekt. Det er litt ufordringer med å få instillings siden til å henge sammen. Så jeg har kun kopiert over konfigurasjons filene ifra HS3 installasjonen jeg hadde ifra før av. Det er den eneste veien til mål så vidt jeg vet pt frem til web sidene til plugin funker 100% i HS4.

SÅ mitt tiper er at du setter opp en temp HS3 installasjon så du får installert og resgirert verisure plugin, deretter kopiere over konfig filen til HS4.

Endret av Kenneth
Lenke til innlegg
Del på andre sider

Så bra det ser ut til å fungere for folk flest nå :D

 

Jeg satt hele gårsdagen å lekte meg men HS4 plugin. Og har kommet til den konklusjon at jeg ønsker å lage en egen versjon av denne pluginen for HS4.

 

Jeg kommer nå framover først til å utvikle ferdig den andre HS4 pluginen jeg startet på (PhilipsTV) slik at jeg blir kjent med hvordan hs4 henger sammen. Der etter kommer jeg til å forsette jobben men å skille ut verisure logikken i egegt biblotek som jeg kan dra inn i en HS4 versjon.

 

Personlig kjører jeg enda på HS3, men ser at HS4 nå begynner å bli modent nok til å kunne oppgradere.

 

 

Siden mange av dere er litt raskere på labben en meg med å oppgradere til HS4, - er det ønsklig at jeg lager et lite standalone program som kan genere kryptert passord som dere kan legge inn i configfila? (aktivering av lokasjon må gjøres manuelt som beskrevet i posten over)

 

 

Tusen takk til dere som har donert en slant :D

Endret av lilfire
  • Like 2
  • Thanks 1
Lenke til innlegg
Del på andre sider
52 minutter siden, lilfire skrev:

Personlig kjører jeg enda på HS3, men ser at HS4 nå begynner å bli modent nok til å kunne oppgradere.

Enig i at det nærmer seg! :)

... men ikke heeelt der enda. ;)

 

Jeg sitter lenger på gjerdet fra HS3 til 4 enn fra HS2 til 3, men jeg var langt fra først ut med HS3 den gangen også.

  • Like 1
Lenke til innlegg
Del på andre sider
1 time siden, Moskus skrev:

Enig i at det nærmer seg! :)

... men ikke heeelt der enda. ;)

 

Jeg sitter lenger på gjerdet fra HS3 til 4 enn fra HS2 til 3, men jeg var langt fra først ut med HS3 den gangen også.

Det er bare å kaste seg ut i det! Lag deg en "migreringsplan" og kjør på mens vi fremdeles har sosial nedstengning.

 

Jeg flyttet fra Fibaro HC2 og til HS4, og det var to ting som lugget. Det ene var mangelen på globale variabler, men det gikk over på to timer da jeg så hvordan dette abstraherte alle typer devicer inn i HS4-plattformen. Det andre var å flytte alle z-wave devicene mine, totalt 67 noder. Flytting fra HS3 --> HS4 inkluderer vel ikke noe av dette. 

Endret av Fjosepose
Lenke til innlegg
Del på andre sider
2 timer siden, Fjosepose skrev:

Det er bare å kaste seg ut i det! Lag deg en "migreringsplan" og kjør på mens vi fremdeles har sosial nedstengning.

Det er det, selvfølgelig. Men det er enda et par småbugs som må ordnes før jeg kaster anker. Jeg har kun tenkt å gjøre det én gang.

 

2 timer siden, Fjosepose skrev:

Jeg flyttet fra Fibaro HC2 og til HS4

Å bytte system vil alltid være noe arbeid, det er ikke til å komme fra.. Jeg har i utgangspunktet ikke tenkt å løfte en finger, og jeg venter til vi har kommet dit. ;) 

 

Her er det ikke bare-bare å ta ned smarthuset for en stund. Det  fungere. Hver dag, hvert sekund. :) 

Lenke til innlegg
Del på andre sider
2 timer siden, lilfire skrev:

Noen bugs du vil nevene som er deal breaker for deg?

Jeg skriver små-script som lager en device og legger passende knapper på dem. Men disse knappene blir fjernet i HS4 ved omstart. Klart det kan scriptes enda litt mer for å legge dem til på nytt ved omstart, men det er en idiotisk løsning på en idiotisk bug.

  • Like 1
  • Sad 1
Lenke til innlegg
Del på andre sider
  • 3 uker senere...
På 28.1.2021 den 22.52, Kenneth skrev:

@lilfire, nysgjerrig på HS4 versjonen av plugin. Har du kommet noe videre?
Melder meg også som tester når du kommer så langt :)

 

Den er et godt stykke unna dessverre. tør ikke en gang å estimere noe tid...

  • Like 1
Lenke til innlegg
Del på andre sider
  • 1 måned senere...

Er det noen flere som har fått problemer med denne plugin i dag? Får ikke styrt låsenMistenker at noe har skjedd hos Verisure. Appen funker som den skal. Fikk tidligere i dag andre feilmeldinger fra plugin enn den jeg viser her

image.png.1953d34f066d0e502d9df38fe6b42ac9.png

 

De andre feilmeldingene jeg fikk tidligere i dag, var av type:

Error for server https://e-api02-verisure.com...

Error XBN DAtabase is not activated

 

 

Lenke til innlegg
Del på andre sider
1 hour ago, Siggi said:

Ser ut til at det akkurat begynte å fungere igjen, så Verisure altså

Jeg er på Home Assistant og fikk også en stopp i dag på Verisure-integrasjonen. Var nedetid på en liten time eller noe deromkring.

 

Jeg fikk også feilmelding i Verisure-appen samtidig og den refererte til at den ikke hadde nettverk eller noe. Leste ikke så nøye... :) 

Lenke til innlegg
Del på andre sider

Bli med i samtalen

Du kan publisere innhold nå og registrere deg senere. Hvis du har en konto, logg inn nå for å poste med kontoen din.

Gjest
Skriv svar til emnet...

×   Du har limt inn tekst med formatering.   Lim inn uten formatering i stedet

  Du kan kun bruke opp til 75 smilefjes.

×   Lenken din har blitt bygget inn på siden automatisk.   Vis som en ordinær lenke i stedet

×   Tidligere tekst har blitt gjenopprettet.   Tøm tekstverktøy

×   Du kan ikke lime inn bilder direkte. Last opp eller legg inn bilder fra URL.


×
×
  • Opprett ny...