Gå til innhold
  • Bli medlem

GUIDE: Kjøre UZB1 over nettverk med Raspberry Pi


ZoRaC

Anbefalte innlegg

Oh, ventnå litt dette er Miniban? Jeg vet ingenting om den. Jeg håper bare at den har fått noen oppdateringer siden 2016..
Er den Debianbasert så kan det være at /etc/network/interfaces brukes.

Jeg skrev litt om det hær: https://www.hjemmeautomasjon.no/forums/topic/5971-rpi4-liten-headless-innstallasjon-med-redusert-skriving-til-minnekort/

 

 


 

Lenke til kommentar
Del på andre sider

3 minutes ago, NilsOF said:

Oh, ventnå litt dette er Miniban? Jeg vet ingenting om den. Jeg håper bare at den har fått noen oppdateringer siden 2016..
Er den Debianbasert så kan det være at /etc/network/interfaces brukes.

Jeg skrev litt om det hær: https://www.hjemmeautomasjon.no/forums/topic/5971-rpi4-liten-headless-innstallasjon-med-redusert-skriving-til-minnekort/

 

 


 

Da fikk jeg opp:

 


auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

 

Lenke til kommentar
Del på andre sider

@Knutarn jepp, dette er nettverksoppsett ala Debian. 
Eksempelene jeg har i den andre tråden er kommentert ut (med #)

Ta den for statisk IP på eth0 og tilpass.

 

MEN, dersom dette er miniban og den ikke er oppdatert siden 2016 ville jeg sett etter en annen distribusjon.

Mye har skjedd siden 2016.

Rasbian er den som jeg antar er mest "standard"

 

Om man leser imellom linjene i denne guiden og trekker ut det man vil ha fra mine skriblerier så er det mulig å få noe brukandes.

Jeg skal se om jeg putter inn litt om ser2net i tråden min når jeg får tid.

 

 

Lenke til kommentar
Del på andre sider

  • 2 uker senere...

Hvis minibian er utdatert, hvilken skal jeg da velge? Prøvde meg på Raspbian Buster med desktop, men klarte ikke å følge guiden med den versjonen. 

 

Dvs at jeg klarte ikke dette punktet:

 

Remove console
==============
sudo nano /boot/cmdline.txt
delete these 2 fields:  console=ttyAMA0,115200 kgdboc=ttyAMA0,115200
ctrl-O
Enter
ctrl-x 

 

Jeg finner ikke de 2 feltene i fila.

 

Jeg følger resten av guiden, men hs3 finner ikke usb aeotec sticken. Er det noen måte å se hva jeg har gjort galt?

 

Er langt ifra stødig på linux, men trodde det var enkelt da det var en slik teskje guide.

 

 

Edit: Tror jeg fant problemet. Aeotec og raspberry 4 har litt problemer med hverandre. Må kjøpe meg en usb-hub så skal problemet løses. 

kjørte lsusb og fant ikke sticken.

 

https://github.com/raspberrypi/linux/issues/3027

Endret av Terje Klungervik
Lenke til kommentar
Del på andre sider

Om du bruker raspian -lite så er det eneste man trenger å gjøre er å installere og konfigurere ser2net.

 

Og, ja Rpi4 bruker noen chiper fra Via som ikke virker med Aeotec g5 stikka.

Jeg har anskaffet tre huber, men det viste seg at alle hadde chipset fra Via.. ?

Jeg går over til UZB1 for å slippe den ekstra dingsen (huben).

 

Lenke til kommentar
Del på andre sider

Overføringen av Deconzbee fungerte utmerket. Nå kjører jeg den usben på raspberry pi 4 uten problemer. Kjører Raspbian med gui.

Kjøpte meg UZB1 og brukte Aeotec sitt backupverktøy. Den fungerte på serveren uten problemer.

Prøvde å flytte den over til raspberry pi. kjørte lsusb og fant den.

Skjermbilde4.PNG.0687c49d505ad4ad911ecd65f80659c7.PNG

 

 

Prøver å koble den til homeseer, men hs klarer ikke å koble den opp. Trouble initializing. Får den beskjeden selv om uzb1 ikke står i raspberryen.

skrevet: 

10003:raw:0:/dev/ttyACM0:38400 8DATABITS NONE 1STOPBIT

i conf filen.

Skjermbilde.PNG.2d55438efae8e3e6d60279a2c6674fee.PNG

Restartet både pi og homeseer software. Men ikke noe tilkobling.

377542216_Skjermbilde2_LI(2).jpg.024496ed6f0644754554399e0804d66b.jpg

Kjører dmesg | grep tty

1105660912_Skjermbilde3.thumb.PNG.318e320f7a557406de97c82fe1795776.PNG

 

Men dette sier meg ikke så veldig mye. Noen tips?

 

EDIT: løste problemet med at jeg skiftet på plass på usb-stickene. UZB1 er nå øverst til venstre. Var nederst til venstre, mens zigbee sticken var øverst. 

 

 

 

 

 

Endret av Terje Klungervik
  • Like 2
Lenke til kommentar
Del på andre sider

  • 7 måneder senere...

Mulig guiden burde vært oppdatert med image? Det den nå peker mot ser ikke ut til å fungere mer. Når jeg laster det over på SD-Kort så stopper jeg opp på "regnbue-skjermen". Jeg kommer til å fortsette guiden med Raspberry Pi OS (32-bit) Lite. Jeg skal prøve å være flink å legge inn avvik.

  • Like 1
Lenke til kommentar
Del på andre sider

  • 9 måneder senere...
iblis skrev (På 2017-1-18 den 16.00):

 

Dette kan du fikse med USB Persistent. Dette er veldig hendig hvis du f.eks må ta en soft reset på kontrolleren som gjør at den vil automatisk gå fra ttyACM0 til ttyACM1. 

 

Kjør sudo lsusb -v | more i terminalen og merk ned følgende informarsjon:



*idVendor
*idProduct
*iSerial

Opprett deretter filen 99-usb-serial.rules under /etc/udev/rules.d:



sudo nano /etc/udev/rules.d/99-usb-serial.rules

Med følgende informasjon (dette er slik min ser ut. Husk på å forandre idVendor, idProduct og iSerial for din enhet):



SUBSYSTEM=="tty", ATTRS{idVendor}=="0658", ATTRS{idProduct}=="0200", ATTRS{serial}=="12345678-9012-3456-7890-123456789012", SYMLINK+="ttyUSB-UZB1"

Neste gang du tar en reboot vil enheten din komme opp som en symbolsk link under /dev/ttyUSB-UZB1 samme om den blir registrert som ttyACM0, ttyACM1 osv. :)

 

Hei, prøver oppsettet ditt, men finner bare "0" som serie nummer. Regnet med det skulle vært et langt nummer? Er sikkert derfor din metode ikke virker?

Endret av Tinge76
Lenke til kommentar
Del på andre sider

  • 5 måneder senere...
  • 8 måneder senere...

Har nettopp oppgradert den ene pi'en til bullseye og fant ut at ser2net bruker .yaml som config fil nå. Så det er litt annerledes config oppsett. Erstatt nano /etc/ser2net.yaml med dette for å få UZB1 til å virke over nett:

%YAML 1.1
---

default:
  name: kickolduser
  value: true

default:
  name: speed
  value: 115200n81

connection: &con10003
  accepter: tcp,10003
  timeout: 120
  enable: on
  connector: serialdev,/dev/ttyACM0

connection: er portnummer.

Fant dette her: https://forums.homeseer.com/forum/lighting-primary-technology-plug-ins/lighting-primary-technology-discussion/z-wave-homeseer/1558575-stick7-on-a-rpi-with-ser2net#post1558582

 

Endre også nano /lib/systemd/system/ser2net.service med å legge til disse to linjene:

After=network-online.target
Wants=network-online.target
[Unit]
Description=Allows network connections to serial ports
Documentation=man:ser2net(5)
After=syslog.target network.target
After=network-online.target
Wants=network-online.target

[Service]
EnvironmentFile=-/etc/default/ser2net
Type=forking
ExecStart=/usr/sbin/ser2net -n -c /etc/ser2net/ser2net.yaml -P /run/ser2net.pid $OPTIONS
Restart=always

[Install]
WantedBy=multi-user.target
Alias=ser2net.service

restart systemctl

sudo systemctl daemon-reload

Reboot Raspberrypi'en

sudo reboot

Etter oppstart, se om ser2net er oppe

service ser2net status

Skal være ingen feilmeldinger

pi@raspberrypi:~ $ service ser2net status
● ser2net.service - Serial port to network proxy
     Loaded: loaded (/lib/systemd/system/ser2net.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2022-09-23 11:15:16 CEST; 1min 8s ago
       Docs: man:ser2net(8)
   Main PID: 587 (ser2net)
      Tasks: 1 (limit: 1624)
        CPU: 38ms
     CGroup: /system.slice/ser2net.service
             └─587 /usr/sbin/ser2net -n -c /etc/ser2net.yaml -P /run/ser2net.pid

Sep 23 11:15:16 raspberrypi systemd[1]: Starting Serial port to network proxy...
Sep 23 11:15:16 raspberrypi systemd[1]: Started Serial port to network proxy.

Fungerer på en raspberryPi3

Endret av PCI
  • Like 1
Lenke til kommentar
Del på andre sider

Eneste jeg ser i ser2net.service filen under service er å endre Restart til =always.

[Service]
EnvironmentFile=-/etc/default/ser2net
Type=forking
ExecStart=/usr/sbin/ser2net -n -c /etc/ser2net/ser2net.yaml -P /run/ser2net.pid $OPTIONS
Restart=always

 

Lenke til kommentar
Del på andre sider

Tror jeg fant løsningen nå som du kan prøve. Endre alle linjer i

/lib/systemd/system/ser2net.service

til dette:

Under Unit:

[Unit]
Description=Allows network connections to serial ports
Documentation=man:ser2net(5)
After=syslog.target network.target
After=network-online.target
Wants=network-online.target

Ser at

After=syslog.target network.target

under Unit ikke ble med. Eller erstatte rett og slett alt i filen med dette

[Unit]
Description=Allows network connections to serial ports
Documentation=man:ser2net(5)
After=syslog.target network.target
After=network-online.target
Wants=network-online.target

[Service]
EnvironmentFile=-/etc/default/ser2net
Type=forking
ExecStart=/usr/sbin/ser2net -n -c /etc/ser2net/ser2net.yaml -P /run/ser2net.pid $OPTIONS
Restart=always

[Install]
WantedBy=multi-user.target
Alias=ser2net.service

 

Endret av PCI
Skriveleif
Lenke til kommentar
Del på andre sider

Bli med i samtalen

Du kan publisere innhold nå og registrere deg senere. Hvis du har en konto, logg inn nå for å poste med kontoen din.

Gjest
Skriv svar til emnet...

×   Du har limt inn tekst med formatering.   Lim inn uten formatering i stedet

  Du kan kun bruke opp til 75 smilefjes.

×   Lenken din har blitt bygget inn på siden automatisk.   Vis som en ordinær lenke i stedet

×   Tidligere tekst har blitt gjenopprettet.   Tøm tekstverktøy

×   Du kan ikke lime inn bilder direkte. Last opp eller legg inn bilder fra URL.

×
×
  • Opprett ny...