Gå til innhold
  • Bli medlem
Fermate

ZigBee i HomeSeer for ELKO og IKEA Trådfri

Anbefalte innlegg

Sønnen min har akkurat total renovert leiligheten sin og der har vi puttet inn bare ELKO ESH dimmere og ELKO ESH termostater. Jeg sitter derfor å setter opp ett HomeSeer system for ham og tenkte at jeg skulle logge det jeg gjorde i en guide.

Jeg har altså valgt å kjøre en ConBee USB stick rett i samme maskin som kjører HomeSeer.

Jeg slenger på litt ekstra IKEA stoff også så kan flere ha glede av det og det er dessuten lettere å teste med i starten.

 

OBS det kan lønne seg å sette en fast IP på denne maskinen før du starter og enten starte HS FØR deCONZ slik at HS får port 80 og deCONZ port 8080.
Eller sette HS til å bruke en annen port i Tools/Setup/Network og la deCONZ få ta port 80

(Tar input på hvordan deCONZ sin web server kan konfigureres til å la være å ta port 80)

 

OK, HomeSeer er installert og oppdatert.

 

Legg til JowiHue plugin i HS

 

Kjøp en ConBee hos feks. Kjell&co 

 

Gå til denne siden og hent driveren for windows / Setup executable som beskrevet her.

 

Pakk den ut og kjør den. Restart PC

 

Gå til Dresden Elektronik og last ned siste versjon av deCONZ for Windows:
https://www.dresden-elektronik.de/funktechnik/products/software/pc-software/deconz/?L=1

 

Kjør install og start den.

 

Om den ikke finner USBStick'en kommer den opp slik med tom dropdown boks:

 

image.png

 

Forsøk da å plugge sticken i en annen USB port.

 

Om den blir gjenkjent hopper deCONZ automatisk videre til dette bildet:

 

image.png

 

Nå kan vi teste ved å åpne ZigBee nettet for JOIN slik:

 

image.png

 

Nå er ZigBee nettet åpent for JOIN i 60 sekunder.

 

Skru en IKEA Trådfri pære av og på 6 ganger (du kan godt gjøre det ved å vri pæra i sokkelen) og la den være på så vil systemet oppdage den slik:

 

image.png

 

Gratulerer du har nå et ZigBee nett kjørende :)

 

Test ved å skru på CLUSTER INFO, Klikk på den lille sirkelen til høyre på pæra, klikk på Cluster 0006 On/Off og test Av/På:

 

image.png

 

Du kan nå styre pæra fra PCen :) 

 

La oss nå koble dette til HomeSeer, først tar vi opp WebApp'en:

 

 

Trykk på WebApp og logg inn med 

user: delight

pwd: delight

 

image.png

 

Kjør software update om den er tilgjengelig:

 

image.png

 

image.png

 

Du kan følge med her:

image.png

 

 

Da er vi klar til å koble til HomeSeer med JowiHue plugin'en

 

Gå til konfigurasjons siden og trykk Register Bridge:

 

image.png

 

Mens den står og leter, gå til WebAppen, velg Settings under Menu og trykk UNLOCK GATEWAY:

 

image.png

 

 

Nå vil JowiHue finne denne:

 

image.png

 

 

Og vi kan styre pæra fra HomeSeer :) :

 

image.png

 

 

La oss nå for moroskyld inkludere en IKEA fjernkontroll (den runde)
Denne gangen kan vi bruke WebInterfacet til å åpne nettet for JOIN:

image.png

 

Ta av lokket på fjernkontrollen og trykk 4 ganger på knappen:

image.png

Og her kommer den:

image.png

Scan for Devices i JowiHue:

image.png

 

Og plopp, her kommer den:

 

image.png

 

Nå kunne vi laget en event i HS som styrer pæra (eller noe annet..) men nå er vel ikke akkurat IKEA sine  brytere å foretrekke for slikt..

 

La oss heller koble til en ELKO dimmer.

 

Sett spenning på dimmeren (elektriker!) Åpne ZigBee nettet for Join og trykk 1 og 3 samtidig til LED 2 blinker:

image.png

 

og her kommer den:

 

image.png

 

Og den ser akkurat ut som IKEA pæra i HS etter å ha latt JowiHue lete den opp:

image.png

 

OK, men hva med ELKO termostaten og ELKO "Endevender dimmeren"??

 

Vel, deCONZ rapporterer termostaten som FUBAR på et sted men lar deg sette temperaturen fra selve deCONZ softwaren. Den dukker derimot ikke opp i WebAppen og (da) heller ikke i JowiHue. Jeg tenker at APIet mangler den objekt typen og at vi bør få shippet en slik termostat til de som oppdaterer APIet.

 

Endevender dimmeren lar seg også detektere i deCONZ men dukker heller ikke opp i APIet så her har vi nok samme problemet.

 

Jeg mener å huske at @Moskus og jeg testet litt på å "binde" clustere fra denne direkte til en IKEA pære i deCONZ og fant ut at den kun lot seg binde til EN pære om gangen. (Dette hadde jo holdt om en kunne "biinde den til HS")

Problemet er at jeg ikke får til den bindingen lengre og jeg tar gjerne input på dette.

 

Skru på "Binding Dropbox" og eksprimenter med å dra et cluster til Source og Destination og trykke Bind:

 

image.png

 

Her har dere et startpunkt for å eksperimentere ihvertfall.

 

Det praktiske vi har oppnådd er å kunne styre IKEA pærer og ELKO dimmere fra HomeSeer og derfor fra alt annet som HS kan ta av innput.

(Som tale :) )
 

 

 


Vis full oppføring

  • Like 2
  • Thanks 1

Del dette innlegget


Lenke til innlegg
Del på andre sider

Hvis du bruker windows kan du endre port på deconz  i config.ini fila her:

C:\Users\"Dinbruker"\AppData\Local\dresden-elektronik\deCONZ

 

Sikkert noe lignende på rpi. Men det vet jeg ikke.

  • Like 1
  • Thanks 1

Del dette innlegget


Lenke til innlegg
Del på andre sider

Driver fortsatt kun i Z-Wave, men har skjønt at når det gjelder lysstyring et det ZigBee som gjelder. Takk for en meget god guide. Den vil bli god å ha!

  • Like 1

Del dette innlegget


Lenke til innlegg
Del på andre sider

Veldig god guide, men skal ikke inkluderingen av Elko dimmer være "trykk 1 og 3 til 2 lyser"?

3 er jo hjulet og den har vel vanskelig for å lyse ;)


Sent from my iPad using Tapatalk

Del dette innlegget


Lenke til innlegg
Del på andre sider
14 timer siden, Tor-Erik skrev:

Veldig god guide, men skal ikke inkluderingen av Elko dimmer være "trykk 1 og 3 til 2 lyser"?

3 er jo hjulet og den har vel vanskelig for å lyse ;)


Sent from my iPad using Tapatalk

 

Du har rett. Takk for tips! Rettet.

Del dette innlegget


Lenke til innlegg
Del på andre sider
4 minutter siden, Trash2000 skrev:

Veldig god guide! I og med at API-et kjører lokalt, så regner jeg med at styring fra HS -> endring i pæra skjer ganske umiddelbart? 

 

Jepp! :) 

Del dette innlegget


Lenke til innlegg
Del på andre sider
1 minutt siden, ZoRaC skrev:

 

Jepp! :) 

 

Det er jammen dyrt å surfe her inne på søndagsformiddagen ;).

 

Elektrikerne er jo veldig glad i ELKO-produkter sånn generelt. Noen som har feeling på kvaliteten til ELKO GLE-dimmeren kontra Fibaro-dimmerne? De ser jo litt mer solide ut.

Endret av Trash2000

Del dette innlegget


Lenke til innlegg
Del på andre sider
7 timer siden, Trash2000 skrev:

Elektrikerne er jo veldig glad i ELKO-produkter sånn generelt.

joda, vi er veldig glad i elko sine produkter. 😅

men etter å ha montert flere "piller" fra fibaro/qubino må jeg si at kvaliteten er bra på de også.

 

for min egen del bruker jeg for øyeblikket kun fibaro/qubino/nexa sine dimmere - mest på grunn av pris...

kommer nok til å oppgradere til Elko sine RF-dimmere etter hvert, da de er de eneste som har dimmehjul som jeg vet om

Del dette innlegget


Lenke til innlegg
Del på andre sider
7 hours ago, Trash2000 said:

 Elektrikerne er jo veldig glad i ELKO-produkter sånn generelt

De er nok mer glad i å tjene penger. Å de tjener fett på Elko produkter. Så får det heller bare være at de ikke klarer å holde seg hvite. 

Del dette innlegget


Lenke til innlegg
Del på andre sider
2 timer siden, GeneralVirus skrev:

De er nok mer glad i å tjene penger. Å de tjener fett på Elko produkter. Så får det heller bare være at de ikke klarer å holde seg hvite. 

ikke at det er så billig med elko for oss heller... i skrivende stund selger Kjell.com en Elko RF dimmer billigere enn jeg klarer å få skaffet den via grosisst.. så kommer alle andre utgifter oppå der... marginene i elektrobransjen er ikke helt slik de var før.

men la oss ikke gå helt OT her ;) 

 

 

Takker for guiden @Fermate .

jeg fikk endelig somlet meg til å legge inn den ekstra ikea-fjernkontrollen jeg hadde liggende. problemet er nå at jeg ikke har noen unnskyldning for å ikke skaffe meg mer zigbee utstyr... :P

 

Del dette innlegget


Lenke til innlegg
Del på andre sider

Har startet noen tråder for litt forskjellig

 

Har forsøkt å oppgradere FW her:

 

 

Og nå fikk jeg til en binding faktisk, her:

 

 

Del dette innlegget


Lenke til innlegg
Del på andre sider

Då har eg fått til å legge inn to Trådfri-lyspærer og ein Trådfri fjernkontroll, yohoo!

image.png.4802cc070d4c5e9f59f68d0bac2f7b18.png

 

Den eine lyspæra er RGB og den kan settast i alle slags fargar manuelt vha. xxx-(hue)-devicen. Men ved forsøk på dette vha. events så skjer det ingenting med fargen. Tips til dette? Lysstyrke vha. events fungerer fint.

Del dette innlegget


Lenke til innlegg
Del på andre sider

EDIT 1

Jeg kom forbi. Stoppet programet og startet det igjen med admin(usikker på om det hadde noe for seg, men kom nå videre...)

 

EDIT 2

Og det fungerte. Dette er kjekt. Takker for guide 🙂

 

Jeg "gjemmer mine utfordringer", men lar de stå om det er andre som er intressert i dem...

Spoiler

 

Har innstallert deCONZ - ConBee, og får registret en IKEA pære.

Men kommer ikke lenger enn der jeg skal Trykk på delight WebApp og logg inn med 

user: delight

pwd: delight

 

Når jeg trykker på WebApp så skjer det ikke noe...... Det åpner seg ikke noe ny innlogging(gul ring).

image.thumb.png.893ca2c7063601c75a01f6e98c2f3402.png

 

 

Endret av mr.rs4

Del dette innlegget


Lenke til innlegg
Del på andre sider

@mr.rs4 Har du prøvd å erstatte ip-adressen som kommer opp i browseren med localhost/login.html (eller localhost:<port du har valgt>/login.html) ?

Eventuelt sjekk om du har en firewall som stopper ting. I mitt tilfeller var det en kombinasjon.

Endret av Guahtdim
La inn info om firewall

Del dette innlegget


Lenke til innlegg
Del på andre sider
På 16.1.2019 den 16.11, GeneralVirus skrev:

Hvis du bruker windows kan du endre port på deconz  i config.ini fila her:

C:\Users\"Dinbruker"\AppData\Local\dresden-elektronik\deCONZ

 

Sikkert noe lignende på rpi. Men det vet jeg ikke.

 

Da er det denne som bør endrast til f.eks 8080?

image.png.c87515145605699e45f875965acd2be9.png

Del dette innlegget


Lenke til innlegg
Del på andre sider

Hva er det å gjøre når man ikke får lagt til IKEA pærer lenger?

Har lagt til 7stk pærer og 2 stk remote brytere. Fikk legge til 2stk trådfri pære idag, men får ikke legge til 2 siste pærene. Hva kan være galt?

I går fikk jeg heller ikke legge til en IKEA pære, så trodde det var noe galt med den og byttet den inn, og kjøpte 4stk nye idag igjen(hvor jeg har fått lagt til 2stk av 4stk).

Alle andre innstallerte IKEA pærer fungere 100%

Vanligvis har den funnet pærene etter 60sek, men har testet med opptil 3min nå, uten det hjelper.


EDIT

Når jeg har lagt til fleste om ikke 6 av 7 pærer har jeg gjort det ifra web, og ikke ifra deCONZ - ConBee PC program.

Har vel mer eller mindre gått smerte fritt, til igår/nå når jeg skal legge til 2 site av IKEA innkjøpte pærene.

 

EDIT 2

USB donglen er ca 5-10cm ifra IKEA pæren.

Trykker på bryter 6 ganger, og testet med å vri på pæra 6 ganger slik lyset går av & på.

Og når det ikke har hjulpet, har jeg skrudd av og på mer enn 6 ganger, men det hjelper heller ikke.

 

EDIT 3

JowHue er på version 2.0.3.0, som er siste...

Endret av mr.rs4

Del dette innlegget


Lenke til innlegg
Del på andre sider
2 timer siden, mr.rs4 skrev:

Hva er det å gjøre når man ikke får lagt til IKEA pærer lenger?

 

Hvilken versjon av deCONZ? Har vært/er mye bugs rundt IKEA i de senere versjonene, dessverre. :( 

 

Sikker på at pærene har ny nok firmware til at de kan legges til? Kanskje du har fått noen pærer som har ligget bakerst på hylla et års tid?

 

Denne metoden funker visst for mange også: https://github.com/dresden-elektronik/deconz-rest-plugin/issues/1237#issuecomment-462082120 

Del dette innlegget


Lenke til innlegg
Del på andre sider

Jeg bruker alltid resetknappen som er skjult i IKEA fjernkontrollen. Har også opplevd deconz har mistet sikkerhetsinstillingene i programvaren og det skapte vilkårlige feil etter hvilke protokoller som følges.

 

1. Reset med skjult resetknapp

2. Restart lampe (IKEA bør være 0-5cm fra conbee)

3, reset med link i gammelt webui

4. Inkluder.

 

samme jeg bruker på hue, men sjekk sikkerhetsinstillingene. Står kode i 0 og Mac til 00000 el må du manuelt legge dem inn, det måtte jeg 

Del dette innlegget


Lenke til innlegg
Del på andre sider
10 timer siden, aleks skrev:

Jeg bruker alltid resetknappen som er skjult i IKEA fjernkontrollen.

... men den brukes jo til å resette fjernkontrollen, ikke pærene?

Del dette innlegget


Lenke til innlegg
Del på andre sider

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gjest
Skriv svar til emnet...

×   Du har limt inn tekst med formatering.   Fjern formatering

  Du kan kun bruke opp til 75 smilefjes.

×   Lenken din har blitt bygget inn på siden automatisk.   Vis som en ordinær lenke i stedet

×   Tidligere tekst har blitt gjenopprettet.   Tøm tekstverktøy

×   Du kan ikke lime inn bilder direkte. Last opp eller legg inn bilder fra URL.


  • Lignende innhold

    • Av Baron
      får disse feilmeldingene opp når jeg starter opp Homeseer, samt da at det ikke kommer noe lyd når jeg prøver å bruke "Speak"
      noen som har opplevd samme å muligens kan gi meg noen råd?
       
      10/24/2019 5:10:19 PM:Error initializing voice recognition, maybe not installed?: Retrieving the COM class factory for component with CLSID {947812B3-2AE1-4644-BA86-9E90DED7EC91} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
      10/24/2019 5:10:23 PM:Error initializing voice recognition, maybe not installed?: Retrieving the COM class factory for component with CLSID {41B89B6B-9399-11D2-9623-00C04F8EE628} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).
      10/24/2019 5:10:26 PM:Connected
      10/24/2019 5:10:27 PM:Speak: Welcome to Home-Seer
      10/24/2019 5:10:27 PM:Error in Speak: Object reference not set to an instance of an object.
      10/31/2019 11:21:22 PM:Connected
      10/31/2019 11:21:23 PM:Speak: Welcome to Home-Seer
      10/31/2019 11:21:23 PM:Error in Speak: Object reference not set to an instance of an object.
      11/2/2019 9:44:19 AM:Connected
      11/2/2019 9:44:19 AM:Speak: Welcome to Home-Seer
      11/2/2019 9:44:19 AM:Error in Speak: Object reference not set to an instance of an object.
      11/4/2019 11:13:54 PM:Connected
      11/4/2019 11:13:55 PM:Speak: Welcome to Home-Seer
      11/4/2019 11:13:55 PM:Error in Speak: Object reference not set to an instance of an object.
      11/13/2019 12:29:29 AM:Speak: Energy high cost
      11/13/2019 12:29:29 AM:Error in Speak: Object reference not set to an instance of an object.
      11/13/2019 12:29:45 AM:Speak: Energy high cost
      11/13/2019 12:29:45 AM:Error in Speak: Object reference not set to an instance of an object.
      11/13/2019 12:29:54 AM:Speak: Energy high cost
      11/13/2019 12:29:54 AM:Error in Speak: Object reference not set to an instance of an object.
      11/13/2019 12:30:14 AM:Speak: Energy high cost
      11/13/2019 12:30:14 AM:Error in Speak: Object reference not set to an instance of an object.
      11/13/2019 12:33:19 AM:Speak: Energy high cost
      11/13/2019 12:33:19 AM:Error in Speak: Object reference not set to an instance of an object.
      11/13/2019 12:33:24 AM:Speak: Energy high cost
      11/13/2019 12:33:24 AM:Error in Speak: Object reference not set to an instance of an object.
      11/13/2019 12:33:49 AM:Error loading grammar file C:\Program Files (x86)\HomeSeer HS3\Grammar\Grammar_nuc#Default_Final.xml : Object reference not set to an instance of an object.
    • Av Offpiste
      Hei
       
      Min Home Assistant kjører på en Raspberry Pi 4, Grafana og InfluxDB kjører i docker på en NAS.
      Bruker utstyr som går på Z-wave, Wifi, MQTT, Zigbee og BLE.
       
      Noen screenshots fra mitt system:
       

       
       

       
       

       
       

       
       

       
       

       
       

       
       

       
       

       
       

       
       

       
       

       
       

       
       

       
       

       
       

       
       
       
    • Av Guahtdim
      Dette er en plugin for å kunne styre Daikin varmepumpe med wifi-modul
       
      Link til siste versjon
      DakinSeer 0.0.0.9
      (NB: Kun testet i Windows og i Ubuntu med Mono 5.16.0.79)
      Hvis du allerede har installert tidligere versjoner så slett alle enheter og opprett på nytt
       
      Hva denne plugin gjør:
      Gir deg en oversikt over forskjellige status

      Gir deg mulighet til å styre varmepumpen fra "oversiktbildet"
      eller 
      legge det inn som en action i en (eller flere) events

       

       
      Hvordan sette opp :
      VIKTIG!!! Stopp Homeseer og ta en kopi av hele katalogen til Homeseer (normalt "c:\program files (x86)\Homeseer HS3" for Windows) og legg kopien på ett trygt sted i tilfelle du trenger å gå tilbake. Pakk ut filen i din Homeseer katalog - pass på at du får følgende oppsett (katalogen "Homeseer HS3" skal inneholde 2 nye filer HSPI_DaikinSeer.exe og HSPI_DaikinSeer.exe.config, mens du i katalogen Homeseer HS3\bin og Homeseer HS3\html\images skal ha fått en ny underkatalog - DaikinSeer)   Restart Homeseer Gå inn på Homeseer->Plugins->Manage og trykk enable på DaikinSeer  
      Hvordan å legge inn en varmepumpe
      For å kunne legge inn en varmepumpe så må du vite ip adressen til den.  Dette kan du finne i f.eks. routeren din. 
       
      Når du vet ip adresse går du inn i på menyvalget for IpConfig
       

       
      Der går du inn på feltet for å legge inn en ny ip

       
      Taster inn ip adresse i popup boksen

       
      Hvis du ikke har korrekt ip-addresse eller noe annet er galt vil du se følgende feilmelding

       
      Men hvis du fikk det til så ser du at pumpen vil dukke opp i listen

      og i "home" vil det dukke opp endel nye devicer med floor og room DaikinSeer.
       
       
      I "General Settings" vil du kunne sette opp hvor lang tid det skal gå mellom hver gang det hentes info fra varmepumpen (der er det en copy&paste bug ja). Time between triggering if true skal egentlig være "Time between heat pump check" eller noe.
      Du kan sette loggnivå.
      Og du får opp antall varmepumper tilknyttet (Number of heat pumps to check)

       
      Endringslogg
      0.0.0.9 - Fikset feil nummer brukt når man skulle skifte til FAN mode. Også oppdatert slik at plugin husker siste temperatur hvis man skifter mellom modes og en av de er FAN siden FAN ikke rapporterer temperatur tilbake (Dette forutsetter at plugin har fått en temperatur før man skifter til FAN mode. Hvis man starter i FAN mode vil default temperatur være 18 grader for kjøling og 10 grader for oppvarming). Takk til @Kenneth for å ha funnet denne.
      0.0.0.8 - Fikset håndtering av tall med desimaler fra Wifi adapter når man ikke kjører US oppsett.
      0.0.0.6 - Endret bygging av temperatur dropdown for å unngå feil ved desimal verdier0.0.0.7 - Fikset visning av temperatur ikoner + ekstra sjekk når man lager enhet slik at man ikke kan ha mer enn en varmepumpe per Ip
      0.0.0.5 - endret shum tilbake, men sørget for us-formatering av temperatur sendt til varmepumpe fra HomeSeer
      0.0.0.4 - endret shum i til å ikke ha verdi (fra shum=0&.. til shum=&..)
      0.0.0.3 - Fikset flere upper/lower case  i image-path
      0.0.0.2 - Lagt på litt mer debug logging og fikset noen upper/lower case i image-path
      0.0.0.1 - Første versjon
       
       
      Problemer/utfordringer/videreutvikling
      Legge inn mulighet for å kjøre en offset på ønsket temperatur Få inn PowerMode, Streamer og EcoMode for de enheter som støtter dette. Automagisk legge dette inn i oppstart. Gjenopprette devicer tilbake til standard hvis man f.eks. har slettet eller gjort endringer på enhetene sine. Prøve å beholde deviceId hvis denne finnes. Få til en oppdatering av allerede eksisterende enheter hvis man har gjort rettelser på de. Kunne selv velge default temperatur hvis plugin ikke har noen temperatur å gå ut ifra Kunne sende Streamer on/off og Powerful on/off for de som har dette Det skal ikke være mulig å lage mer enn en enhet/samling med devicer per ip. Hvis den allerede eksisterer så skal man få opp en advarsel. Hvordan få satt en drop-down til å ha korrekt formatering i forhold til hva HomeSeer forventer.
    • Av Guahtdim
      Link til nedlasting av plugin
      MelCloudClimate versjon 1.5.8.1
       
      Kun testet i Windows
       
      Last ned
      VIKTIG!!! Stopp Homeseer og ta en kopi av hele katalogen til Homeseer (normalt "c:\program files (x86)\Homeseer HS3" for Windows) og legg kopien på ett trygt sted i tilfelle du trenger å gå tilbake. Pakk ut filen i din Homeseer katalog - pass på at du får følgende oppsett (katalogen "Homeseer HS3" skal inneholde 2 nye filer HSPI_MelcloudClimate.exe og HSPI_MelcloudClimate.exe.config, katalogen Homeseer HS3\bin skal ha fått en ny underkatalog - MelcloudClimate - med 12 filer og katalogen html\images skal ha fått en ny katalog MelcloudClimate med 4 filer)   Restart Homeseer Gå inn på Homeseer->Plugins->Manage og trykk enable på MelcloudClimate For å legge inn brukernavn og passord velger du fra Plug-ins menyen MelcloudClimate->Melcloud General Config og legger inn i User name og Password Plugin vil nå prøve å starte opp og hente ned data som gjør at den lage enheter for styring og info
       
      Ansvarsfraskrivelse:
      Laste ned og bruke plugin gjøres på eget ansvar. Skulle jeg ødelegge Homeseer oppsettet ditt så kan jeg desverre ikke hjelpe deg.
       
       
       
      Det er fortsatt endel som ikke er på plass, men grunnet sykdom så har jeg ikke kommet helt i mål. Dette vil komme etterhvert.
       
      Ta kontakt her i tråden hvis det er noe som mangler/ikke fungerer.
       
      Den som vil fortsette å leke med koden finner den på 
      https://github.com/oesolberg/MelcloudClimate
       
      Takk til @aleks for å ha startet dette 
      og @Fjaeran for å la meg få en konto å "leke" litt på
       
      Endringer siden forrige versjon:
      1.5.8.1 - Fan speed bygges litt penere opp. Fikset innhenting og laging av devicer hvis man har skrevet inn brukernavn og passord etter første oppstart. 1.5.8.0 - Fan speed er nå lagt inn som forskjellige ikoner og med knapper istedenfor dropdown. 1.5.7242.13984 - Tåler nå å miste kontakt med internett. Vil da prøve på nytt ca hvert andre minutt. Har i tillegg en egen "Connected" device som viser om man er koblet opp eller ikke (hatt kontakt de siste 5 minuttene)  
       
    • Av Guahtdim
      RfLinkSeer er en plugin for å støtte RfLink (hardware) et alternativ til RfxTrx. Dette er hardware man selv kan sette sammen eventuelt bestille på nett (se under RFLink gateway).
       
      OBS OBS OBS
      Dette er i Alfa(nivået før beta, som igjen er nivået før man faktisk sier man har en versjon man er fornøyd med) og ser ut deretter Kun testet i windows.   
      Hva som er støttet så langt:
      "Lytting" til det som skjer (plugin er i hovedsak laget for å håndtere mine prologue tempmålere). Mulighet til å legge enheter inn i Homeseer  Mulighet for å sende kommandoene ON/OFF/ALLON/ALLOFF.  
      Testet med:
      433Mhz brannvarsler (Kjell.com Konig SAS-SA200)- tar imot signal og kan også trigge denne (testet uten familien i hus) 433MHz fjernstrømbrytere (Håndterer ON/OFF/ALLON/ALLOFF)  
      Hva som kommer til å skje videre:
      Gjøre ting penere i GUI Begynne å se på å sende kommandoer for de enheter som kan motta kommandoer Stabilitet når man mister kontakten med en RfLink enhet over tcp/ip Fange opp om en kommando kom seg over ok til RfLink  
      *** Link til siste versjon: RfLinkSeer_V_0474  ***
       
      Hva gjør jeg for å installere?
      VIKTIG!!! Stopp Homeseer og ta en kopi av hele katalogen til Homeseer (normalt c:\program files (x86)\Homeseer HS3) og legg kopien på ett trygt sted i tilfelle du trenger å gå tilbake. Pakk ut filen i din Homeseer katalog - pass på at du får følgende oppsett (katalogen "Homeseer HS3" skal inneholde 2 nye filer HSPI_RfLinkSeer.exe og HSPI_RfLinkSeer.exe.config, mens du i katalogen Homeseer HS3\bin skal ha fått en ny underkatalog - RfLinkseer - med 17 filer) og under Html\images katalogen skal du ha fått en RfLinkSeer katalog 3 underkataloger og diverse bilde filer (totalt 49 bildefiler under RfLinkSeer og tilhørende underkataloger)  Restart Homeseer Gå inn på Homeseer->Plugins->Manage og trykk enable på RFLinkSeer  
      Brukermanual:

      Hvis du kobler til RFLink direkte så må du sette opp korrekt Com-port. Dette gjøres under Plugins->RfLinkSeer->Comport config. Velg fra dropdown og trykk på knappen "Add comport"
       

      Hvis du har koblet RFLink vha RasberryPi og ser2net så må du inn på TcpIp config. Tast inn ip, port og trykk "Add Tcp/Ip address".
       

      I begge tilfeller skal man se noe i løpet av 5-30 sekunder hvis man går inn på Plugins->RfLinkSeer->Found Units.
       

      Ser du ikke noe så gå inn på General config og sett logging til debug. Går du i logvinduet så skal du se en masse med RfLinkSeer meldinger. Hvis alt går bra ser du også noen av typen "received 20;12;....". Hvis du får en haug med feilmeldinger om reconnect etc så er det mulig at du har satt opp comport eller tcpip feil.
       

      For å velge enheter så går du til siden Plugins->RfLinkSeer->Found Units. Vent i 5-10 sekunder så skal det komme opp en tabell med enheter som den finner. Trykk på knappen Add for den/de enhetene som du ønsker å legge inn i Homeseer.
       

      For å endre kommandoport eller protokoll og enhetsId går man inn og konfigurerer enheten (trykker på navnet til enheten i oversikten). Man skal under fanen RfLinkSeer ha en eller 2 dropdowns. Den ene velger kommandoport (det man har konfigurert under com og/eller tcp/ip).
      Den andre porten velger enhet som man skal ta protokoll og enhetsid fra. I tillegg til at man viser protokoll og enhetsid så viser jeg også sist mottatte data slik at det skal bli enklere å velge (noe jeg savner i RfxCom plugin).
       
      Plugin støtter å kjøre mer enn en kilde. Hjemme kjører jeg to enheter (433MHz og 868Mhz) over tcpip og det ser ut til å gå greit. Jeg antar at man også kan kjøre ett par comporter også samtidig, men har ikke fått testet så mye på det.
       
      Mer info vil komme etterhvert som jeg får mer tid til å "pusse" på koden.

       
      Ansvarsfraskrivelse:
      Laste ned og bruke plugin gjøres på eget ansvar. Skulle jeg ødelegge Homeseer oppsettet ditt så kan jeg desverre ikke hjelpe deg.
       
      Endringer
      0.4.7.4 - Fikset manglende link mellom child og parent devices.  
       
      Endringer i Alpha4 (2018-06-08)
      * Kommandoene On, Off, AllOn, AllOff, Set_level kan nå bli sendt fra RfLinkSeer til RfLink (som igjen sender det ut til enhetene)
      * Mulighet for å endre porten som enheten skal sende kommandoer over. (ligger i RFLinkSeer-fanen når man configurerer eksisterende enhet i HomeSeer)
      * Mulighet til å endre enhetens protokoll og adresse til en funnet enhet som ikke er i HomeSeer, men funnet av RfLink. Dette gjør det enklere å hente inn enheter som endrer seg etter batteribytte. (ligger i RFLinkSeer-fanen når man configurerer eksisterende enhet i HomeSeer)
       
      Endringer i Alpha3 (2018-03-28)
      * Alle enheter skal nå ha ikon
      * Lagt til knapp for å manuelt slå av røykvarlser i Homeseer (den sender IKKE ut til brannvarslerne)
      * Fikset opp i oversikt over enheter slik at man
      Fjerne fra Homeseer devicer Oppdatere med nye ikon hvis man har en enhet installert fra før, men uten korrekt ikon * Mulighet til å endre hvor lenge man tar var på enheter som har gitt signal i oversikt over enheter som er funnet, men som ikke er lagt til i Homeseer
      * I oversikt er det nå enklere å se hvilke enheter som man har lagt til i Homeseer
       
      Endringer i Alpha2 (2018-02-22)
      * Bedre håndtering av On/Off kommandoer fra enheter
      * Unitconfig har fått en skikkelig overhaling og har nå følgende:
      Mulighet for søk Sortering Enkelt å legge til en ny enhet  
      Kjente feil
      Krangler med Arduinoplugin hvis du bruker com port både på RfLinkSeer og Arduino plugin. Uvist hvordan dette skal løses siden jeg har lagt opp til at man skal kunne bruke mer enn en comport samtidig. Den antar at alle kommandoer som sendes går ok. Jeg har desverre ikke implementert noen sjekk på returen jeg får fra RfLink når jeg sender en kommando. Mye logging til console som ikke er fjernet, men dette vil du kun se om du kjører plugins i developer mode. "Testing testing"-teksten i config siden jeg først tenkte over den da jeg oppdaterte disse sidene.  
       


×
×
  • Opprett ny...